Jump to content
XPEnology Community

[Résolu - Merci] Étendre le volume : option grisée


epmijelsi<fhj___;
 Share

Recommended Posts

Bonsoir,

 

Sur mon NAS HP Proliant N54L, j'ai mis à jour le bios et DSM à la version 5.2-5644.5

 

Maintenant l'étape suivante c'est que j'ajoute mon 5ème disque dur. Il est connecté depuis un moment mais n'était jusqu'ici pas reconnu par le système. Maintenant, je sais qu'à partir du bios il est reconnu, j'ai 5 disques durs WD de 2To chacun.

 

Actuellement je n'ai qu'un volume de 4 disques en RAID5, ext4. Je suis passé par le gestionnaire de stockage pour "étendre ce volume", mais l'option est grisée :

 

58816920160312211824SynologyDiskStationFlora.png

 

Au début j'ai pensé que je devais d'abord passer par la première étape, Démarrer le nettoyage de données. Ça m'a bouffé l'aprem, c'est pas grave, mais ça n'a rien changé.

 

Le disque est exactement de la même capacité que les autres car j'avais acheté les 3 derniers ensemble, et normalement en RAID5 comme en SHR, je dois pouvoir ajouter un 5ème disque à ce volume.

 

Ce cinquième disque est bien reconnu dans le bios, j'en suis certain, mais pas par le système.

 

Merci de votre aide

Edited by Guest
Link to comment
Share on other sites

Salut,

Dans le gestionnaire de stockage es-tu sûr que ton "nouveau" disque apparait quand tu cliques dans le menu à gauche HDD/SSD?

 

Salut et merci pour ta réponse. Non, le disque n'apparaît nul part dans le système, il n'est détecté que dans le bios.

 

edit : je n'ai moi-même jamais ajouté de disque, je ne savais pas que ça devait apparaître dans ce menu.

 

72791620160317151047SynologyDiskStationFlora.png

Link to comment
Share on other sites

Hi,

 

En ssh vois-tu ton 5 ème disque ?

Voilà ce que j'ai avec la commande fdisk -l

 

HPN54L> fdisk -l

 

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sda1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sda2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sda3 588 182401 1460417440+ fd Linux raid autodetect

 

Disk /dev/sdb: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdb1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sdb2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sdb3 588 182401 1460417440+ fd Linux raid autodetect

 

Disk /dev/sdc: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdc1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sdc2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sdc3 588 182401 1460417440+ fd Linux raid autodetect

 

Disk /dev/sdd: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdd1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sdd2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sdd3 588 182401 1460417440+ fd Linux raid autodetect

 

Disk /dev/sde: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sde1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sde2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sde3 588 182401 1460417440+ fd Linux raid autodetect

 

Disk /dev/sdu: 1006 MB, 1006632960 bytes

4 heads, 32 sectors/track, 15360 cylinders

Units = cylinders of 128 * 512 = 65536 bytes

 

Device Boot Start End Blocks Id System

/dev/sdu1 * 1 256 16352+ e Win95 FAT16 (LBA)

Link to comment
Share on other sites

Hi,

En ssh vois-tu ton 5 ème disque ?

Voilà ce que j'ai avec la commande fdisk -l

 

Pardon mais je n'avais pas reçu de notification.

 

À partir d'un PC Windows, comment entrer cette commande fdisk -l ? Est-ce que je dois passer par un programme comme Putty ? J'ai peur de faire un bêtise car je sais que la commande fdisk est aussi utilisée pour effacer un disque…

 

Merci

Link to comment
Share on other sites

Hi,

 

Non tu ne feras pas de bêtises si tu te contentes de faire cette commande via Putty, oui.

Penses à activer le SSH dans le panneau de configuration de ton Syno, dans la rubrique Terminal si je ne me trompe pas.

 

Merci pour cette réponse rapide !

Oui j'étais en train d'éditer mon message quand j'ai compris qu'il s'agissait de PuTTY, mais j'avais un Fatal Error, impossible de me connecter alors que le NAS est accessible.

 

Effectivement dans le panneau de configuration, terminal, l'option SSH avait sauté. Je l'ai réactivée mais ça ne fonctionne pas mieux. Je reboot le NAS pour voir.

Link to comment
Share on other sites

Hi,

 

Non tu ne feras pas de bêtises si tu te contentes de faire cette commande via Putty, oui.

Penses à activer le SSH dans le panneau de configuration de ton Syno, dans la rubrique Terminal si je ne me trompe pas.

 

J'ai bien reçu ta proposition d'aide par skype et je t'en remercie.

 

Depuis hier je t'ai envoyé au moins 4 messages mais rien ne passe, j'ai jamais vu ça !

 

Pourtant je fais Send message ou Reply, puis Submit, exactement comme ici, c'est incompréhensible.

 

Tous les messages restent stockés dans une Outbox et rien dans Sent messages, j'ai vraiment la poisse.

 

65914720160319101800NotificationView.png

Link to comment
Share on other sites

Bonjour a tous,

J'ai depuis peu monté un serveur Xpenology avec 6 disques dur pas de problème je veux en ajouter 2

et l'option étendre le volume reste grisée.

J'ai vérifié dans HDD/SSD mes deux disques sont bien reconnu seul leurs statut reste sur non initialisé.

Quand je veux créer un autre volume mes disques sont bien trouvés.

Voici le résultat de la commande fdisk -l avec Putty :

 

Disk /dev/sda: 500.1 GB, 500107862016 bytes

255 heads, 63 sectors/track, 60801 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sda1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sda2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sda3 588 60801 483660912 f Win95 Ext'd (LBA)

/dev/sda5 589 60789 483556480 fd Linux raid autodetect

fdisk: device has more than 2^32 sectors, can't use all of them

 

Disk /dev/sdb: 2199.0 GB, 2199023255040 bytes

255 heads, 63 sectors/track, 267349 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdb1 1 267350 2147483647+ ee EFI GPT

fdisk: device has more than 2^32 sectors, can't use all of them

 

Disk /dev/sdc: 2199.0 GB, 2199023255040 bytes

255 heads, 63 sectors/track, 267349 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdc1 1 267350 2147483647+ ee EFI GPT

 

Disk /dev/sdd: 1500.3 GB, 1500301910016 bytes

255 heads, 63 sectors/track, 182401 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdd1 1 66 530125 83 Linux

/dev/sdd2 67 132 530142 83 Linux

/dev/sdd3 133 182338 1463569693 83 Linux

/dev/sdd4 182339 182400 498012 83 Linux

fdisk: device has more than 2^32 sectors, can't use all of them

 

Disk /dev/sde: 2199.0 GB, 2199023255040 bytes

255 heads, 63 sectors/track, 267349 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sde1 1 267350 2147483647+ ee EFI GPT

 

Disk /dev/sdf: 2000.3 GB, 2000398934016 bytes

255 heads, 63 sectors/track, 243201 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdf1 1 66 530125 83 Linux

/dev/sdf2 67 132 530142 83 Linux

/dev/sdf3 133 243138 1951945693 83 Linux

/dev/sdf4 243139 243200 498012 83 Linux

 

Disk /dev/sdg: 1000.2 GB, 1000204886016 bytes

255 heads, 63 sectors/track, 121601 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdg1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sdg2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sdg3 588 121601 972036912 f Win95 Ext'd (LBA)

/dev/sdg5 589 60789 483556480 fd Linux raid autodetect

/dev/sdg6 60790 121589 488367952 fd Linux raid autodetect

 

Disk /dev/sdh: 1000.2 GB, 1000204886016 bytes

255 heads, 63 sectors/track, 121601 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

 

Device Boot Start End Blocks Id System

/dev/sdh1 1 311 2490240 fd Linux raid autodetect

Partition 1 does not end on cylinder boundary

/dev/sdh2 311 572 2097152 fd Linux raid autodetect

Partition 2 does not end on cylinder boundary

/dev/sdh3 588 121601 972036912 f Win95 Ext'd (LBA)

/dev/sdh5 589 60789 483556480 fd Linux raid autodetect

/dev/sdh6 60790 121589 488367952 fd Linux raid autodetect

 

Disk /dev/sdu: 15.7 GB, 15720251392 bytes

4 heads, 32 sectors/track, 239872 cylinders

Units = cylinders of 128 * 512 = 65536 bytes

 

Device Boot Start End Blocks Id System

/dev/sdu1 * 1 384 24544+ e Win95 FAT16 (LBA)

 

 

Quelqu'un aurait il une solution ?

 

Merci a vous.

PS: je dois encore ajouter deux disques mais je transfert mes données au fur et a mesure de mon ancien NAS au Xpenology car j'ai peur de perdre mes données.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Bonjour

J'ai eu le même souci, c'est un problème de paramétrage du BIOS ci dessous le paramétrage a effectuer

 

 

 

From the main screen go to ‘Chipset > Southbridge Configuration > SB SATA Configuration’ and make sure your settings are the same as below:

OnChip SATA Channel = Enabled

OnChip IDE Type = IDE

SATA IDE Combined Mode = Disabled

SATA EPS on all PORT = Enabled

SATA Power on all PORT = Enabled

Return to the main screen then go to ‘Advanced > IDE Configuration’ and again, make sure your settings are the same as below.

Embedded SATA Link Rate = 3.0Gbps MAX

 

Voila

 

A+

Link to comment
Share on other sites

Bonjour

J'ai eu le même souci, c'est un problème de paramétrage du BIOS ci dessous le paramétrage a effectuer

 

From the main screen go to ‘Chipset > Southbridge Configuration > SB SATA Configuration’ and make sure your settings are the same as below:

OnChip SATA Channel = Enabled

OnChip IDE Type = IDE

SATA IDE Combined Mode = Disabled

SATA EPS on all PORT = Enabled

SATA Power on all PORT = Enabled

Return to the main screen then go to ‘Advanced > IDE Configuration’ and again, make sure your settings are the same as below.

Embedded SATA Link Rate = 3.0Gbps MAX

 

Voila

 

A+

 

 

Bon, y'a plus qu'à croiser les doigts pour que je ne perde aucune donnée pendant l'augmentation du volume…

79607220160422165656NotificationView.png

 

…mais tu as débloqué ma situation.

 

Merci beaucoup pour ton aide, ça traînait depuis des semaines et à vrai dire je n'ai pas beaucoup d'autre recours que ce forum, sur d'autres forums où il y a des gens également très compétents le sujet xpenology est banni.

 

Merci encore infiniment pour ton partage.

Link to comment
Share on other sites

 Share

×
×
  • Create New...