XPEnology for dummies LINK Update 02/02/2013


Recommended Posts

I'm running esxi 5.1. I added a new SCSI disk along with a VMware Paravirtual SCSI controller in my VM. After booting up it gets to a certain point and then begins shutting itself back down. Removing the SCSI drive and controller fixes this. Are you sure PVSCSI is working correctly in this ++ build? Can anyone else test to confirm the same issue?

 

I can also confirm the same issue. After adding the PVSCSI to the kernel, recompiling and installing, the boot process will display:

 

want_idx 1 index 3
want_idx 1 index 3. delay and reget

 

many times, after that

 

want_idx 1 index 4
want_idx 1 index 4. delay and reget

 

again many times. Then the boot process resumes and after a while:

 

BUG: Unable to handle kernel NULL pointer dereference at 0000000000000068

 

That happens in syno_libata_index_get_by_map+0x2c/0xb0

 

And even more after that:

 

scemd[3738]: segfault at 8 ip ......... sp .............. error 4 in scemd

 

And the system shutdowns after that. I guess there is some kind of watchdog that checks that the scemd is alive.

 

My hypothesis is that there is some kind of enumeration of ata disks in drivers/scsi/sd.c that prints out the want_idx errors. I guess the index starts at 3 if because I have 2 ide devices and 3 pvscsi devices and the ide devices get the first slots? When initializing the pvscsi devices it expects them to start at index 1?

Link to post
Share on other sites
hi,

 

i import the .ovh in vmware Workstation 9, but don't start the machine !!! i modify the disk creat a 1to , and after i export the machine to my esxi5.1 (path from december) , and i start the machine , all done

 

thanks !

will try this tonight.

 

What do you mean with this:

i modify the disk creat a 1to

Link to post
Share on other sites
I managed to add a 200GB harddisk, but when i try to use packages i get this:

Syn.png

 

I have connectivity to internet when i ping to eg http://www.synology.com

PING wrpx.service.mirror-image.net (81.22.37.106): 56 data bytes

64 bytes from 81.22.37.106: icmp_seq=0 ttl=246 time=19.803 ms

Or is it not possible to use packages with XPEnology?

 

 

EDIT:

When i use the ovf file in ESXi5.1 it does not work..., when i use the virtualbox howto http://xpenology.com/forum/viewtopic.php?f=2&t=3 i works...

Did you use the the above mentioned howto on ESXI, or did you just use virtualbox instead ?

Link to post
Share on other sites
Yes i did. i´m now trying to increase disk capacity from workstation and then upload again to ESXi.

Everything ran ok.

 

Ok, thank you !

 

Did you just import it in VMw WS9, and then did an export (to again OVF ?) and imported that in VSphere ? Or did you do something special ?

Link to post
Share on other sites

In workstation 9 (i dont remeber in other versions) you have the option to upload to vmware servers any virtual machine you have in your workstation. It´s as simple as right button --> upload. You import OVF to Workstation (doble click) and then upload to ESXi.

Link to post
Share on other sites
(worked on my esxi 5.1)

Make RDM link:

# ls -l /dev/disks

# cd /vmfs/volumes/datastore1/

for pRDM (Physical RDM):

# vmkfstools -z /vmfs/devices/disks/ rdm_anydisk.vmdk

for vRDM (Virtual RDM):

# vmkfstools -r /vmfs/devices/disks/ rdm_anydisk.vmdk

Add one more IDE disk

Edit .vmdk of new IDE disk:

# Disk DescriptorFile

version=1

encoding="UTF-8"

CID=907f50af

parentCID=ffffffff

isNativeSnapshot="no"

createType="vmfsRawDeviceMap"

 

# Extent description

RW 976773168 VMFSRDM "rdm_anydisk.vmdk"

 

# The Disk Data Base

#DDB

 

ddb.adapterType = "ide"

ddb.geometry.sectors = "63" - your HDD value

ddb.geometry.heads = "255" - your HDD value

ddb.geometry.cylinders = "60801" - your HDD value

ddb.uuid = "60 00 C2 9b 97 a8 bd d9-93 09 9e 49 05 59 4a be"

ddb.longContentID = "ed52f62d56900538fd0971af907f50af"

ddb.virtualHWVersion = "9"

now your RDM attached as IDE to XPEnology

 

 

i've tried without success to map a SATA WD160Gb Drive using RDM.

 

i follow instructions and when i start the virtual machine, i have Specified file is not a virtual disk.

Could someone help me on this issue ?

 

Thanks for your help.

Link to post
Share on other sites
This topic is for OVF version (VBOX export, VBOX->Convert to VMWARE export) based on XPEnology DS3612xs DSM 4.1 build 2668++ (more hardware)

 

it's a fresh install, no password, DHCP ethernet and 2 disks :

-disk 1 200mb for synoboot (keep version to restore boot if grub loading error)

-disk 2 thin provisioning up to 20Go for system (373Mo used)

 

Links for VBOX_OVF 4.1 Version VirtualBox 4.2.6 :

http://depositfiles.com/files/5uw4ldgtv

 

Links for VMWARE_OVF 4.1 Version Workstation 9 :

http://depositfiles.com/files/1l16hcpji

 

Links for VMWARE_OVF 4.1 Version Workstation 8 :

http://depositfiles.com/files/vszlfuwbb

 

Links for Hyper-V Version : need to build this version

 

Thank for you Post.

is it Possiable to post it on "shareonline.biz" , I can not to download from depositfiles. for download i have pay and give my Telephon nummber!!!!

 

I need "

Links for VMWARE_OVF 4.1 Version Workstation 9 :

http://depositfiles.com/files/1l16hcpji "

or one for ESXI5.

thanx

Link to post
Share on other sites
Yes i did. i´m now trying to increase disk capacity from workstation and then upload again to ESXi.

 

Everything ran ok.

 

[attachment=0]NAS.jpg[/attachment]

 

do you have a linke for ESXI , did yoou convert workstions to ESXI ?

 

can you upload it to shareonline ?

 

thanx

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.