Jump to content
XPEnology Community

Disc 2 and 3 inverted


Recommended Posts

Hello everyone, I get this :

I use a E350-M1 motherboard

I've Xpenology installed on the machine I prepared to use as NAS .

I installed 2 WD RED 4 TB connected to the SATA ports 1 and 2 of the motherboard .

They are regularly recognized by the bios of the motherboard in positions 1 and 2

Xpenology sees the disks in positions 1 and 3 .

If you exchange the SATA cables of disk 2 and 3 Xpenology correctly sees the HDDs in the 1 and 2 positions but in the bios on the motherboard of course find them on 1 and 3 .

In practice, the HDD connected on SATA1 is seen in position 1 , SATA 4 in position 4 , while 2 and 3 are only reversed on Xpenology but not on the motherboard and bios .

It ' happened to any of you ?

It ' a Xpenology firmware bug ?


Thanks to those who want to help me !


Zippi .


P.S.: Excuse me for my poor english!

Link to comment
Share on other sites

Unless you have hot swap drive bays and multiple drives then I would not worry about this 'bug'. I've seen the same with various mobos and controllers and my solution is just to label the sata leads with their DSM storage manager positions so if you have a disk failure you know which it is



Sent from my iPad using Tapatalk

Link to comment
Share on other sites

OK, thanx to all......

My goal is to set up a 4 disks NAS in RAID 5 with 4 WD RED 4TB

I can leave the 4 disks in the right position seen correctly from the mobo, i just gotta remember that i have disk 2 and 3 inverted.

The system will work well? ( RAID 5 with 4 disks )

I will install the disks in a 4 slots backplane.

THX again....

Link to comment
Share on other sites

I've seen something similar.


In my case I have three Rosewill RSV-SATA-Cage-34 hot swap bays which support 4 HDD each. They are natively configured as 1 through 4 but I wanted to set them up as 1 through 12 (rather then 1, 2, 3, 4, 1, 2, 3, 4, 1, 2, 3, 4) which took some doing to arrange correctly. I tested the configuration by swapping in and out a 2TB HDD which worked as expected with respect to drive number detection and physical position.


However, one time, far removed and unrelated to the earlier test, I swapped in a HDD and it wasn't numbered correctly. Tried it again in another slot and it was more of the same. After a reboot it all went back to functioning correctly.

Link to comment
Share on other sites

  • Create New...