Jump to content
XPEnology Community

XPEnoboot 5644.5: HDDs werden nicht erkannt, BIOS-Reset


haloworld
 Share

Recommended Posts

Hallo Forumgemeinde,

 

ich versuche nun seit einigen Tagen die aktuelle XPEnology-Version 5644 auf meinen Server zu bekommen, leider nur mit mäßigem Erfolg.

 

Zunächst mal meine Hardware:

Dell Poweredge 2900 mit 2x2,5 GHz Xeon Quadcore, 16 GB RAM, Dell Perc6i RAID-Controller mit aktueller Firmware

 

Das XPEnoboot 5644.5 wurde genau nach Anleitung auf den USB-Stick gebracht und MAC-Adresse und SN wurden händisch in der syslinux.cfg eingetragen.

Der Server bootet und nachdem er fertig ist, kann ich auch die DS über die entsprechende IP-Adresse aufrufen. Allerdings wird keine HDD erkannt und ich komme mit der Einrichtung der NAS nicht weiter.

In der Version 5644.4 werden die Platten einwandfrei erkannt und ich kann das System einrichten.

 

Dabei ist mir folgendes beim Booten aufgefallen:

Kurz vor Ende des Bootvorgangs kommt diese Zeile:

 

cat: can't open '/sys/block/sd*/device//model' : no such file or directory

 

Der Doppelslash in der Zeile ist kein Schreibfehler meinerseits, sondern er wird so in der Meldung ausgegeben.

Jede Version vor der 5644.5 läft problemlos durch und erkennt die HDDs.

 

Kurios an der ganzen Sache ist, dass das ganze in einer VM auf einem ESXi 6.0 nicht auftritt.

In der VM wird die HDD einwandfrei erkannt. Die NAS kann dann problemlos eingerichtet werden.

 

Ein weiterer Missstand beschäftigt mich allerdings auch noch. Unabhängig von der Bootloader-Version wird beim Dell-Server ständig das BIOS resettet, sobald der Rechner neu gestartet wird. Dabei werden Bootreihenfolgen verändert, die Uhrzeit verstellt, ATA Controller abgeschaltet usw.

Danach läuft das System in einen Halt und es wird nicht durchgebootet. Ein Sprung ins BIOS zeigt dann wieder, dass alle vorher vorgenommenen Einstellungen wieder zurückgestellt wurden.

Das Setzen eines BIOS-Passworts brigt auch nichts. Der Reset erfolgt trotzdem.

 

Hintergrund beider Installationsvarianten ist, dass XPEnology als eigenes System auf dem Server laufen soll. Der Lauf im ESXi diente lediglich zu Testzwecken. XPEnology soll nicht dauerhaft auf dem ESXi bleiben.

 

So, jetzt hab ich lange genug gefaselt.

Hat jemand von Euch eine Idee, woran das oben beschriebene liegen kann?

Für Anregungen bzw. Hilfe wäre ich sehr dankbar.

 

Gruß Achim

Link to comment
Share on other sites

Hallo Leute,

 

ich habe nun mal eine Zeit lang rumexperimentiert, aber das Problem mit den nicht erkannten HDDs bleibt weiterhin bei der 5644.5 bestehen.

Der Fehler ist auch auf einem anderen Dell-Server reproduzierbar.

Hier bin ich noch nicht weitergekommen.

 

Da ich aber die VirtualBox verwenden möchte, bin ich auf die Version 5592.2 zurückgegangen. Hier klappt VirtualBox.

 

Das Problem mit dem BIOS-Reset konnten allerdings eingegrenzt werden. Es tritt auf, sobald im DSM unter "Hardware und Energie" der Zeitplan zum selbständigen Hoch- und Runterfahren aktiviert wird.

Fährt der Server dann runter, bleibt er beim nächsten Hochfahren hängen, da das BIOS resettet wurde und diverse BIOS-Einstellungen ein weiteres Durchbooten verhindern.

Das bleibt auch solange, bis man den Zeitplan deaktiviert bzw. die Einträge löscht. Danach kann das BIOS wieder korrekt eingestellt werden und alles klappt wieder wie gewohnt.

 

Vielleicht fällt ja jetzt jemandem was ein, was vorher so nicht erkennbar war.

 

Gruß Achim

Link to comment
Share on other sites

  • 3 weeks later...

Hallo Achim,

 

da ich auch noch vorhabe, einen DPE-2900III (Du müßtest den gleichen haben) auf Synology umzubauen bin ich schon mal froh über Deine Erfahrungen zu lesen.

Da das programmierte hoch und runterfahren nicht auf dem originalen Synology-Weg funktionieren kann, sollte klar sein, da die originalen Synology´s ein UEFI/EFI-BIOS benutzen, wo die DSM-Software ihre Einstellungen hinein schreiben kann (was Hardware-nah ist).

Ich kann meinen Server dann im Dauerbetrieb laufen lassen, da spielt das also keine Rolle.

Welchen anderen Dell-Server hast Du noch getestet? Ich hätte noch einen DPE-T610 zur Verfügung.

 

Herzliche Grüße

 

Heiko

Link to comment
Share on other sites

Hallo Achim,

 

da ich auch noch vorhabe, einen DPE-2900III (Du müßtest den gleichen haben) auf Synology umzubauen bin ich schon mal froh über Deine Erfahrungen zu lesen.

Da das programmierte hoch und runterfahren nicht auf dem originalen Synology-Weg funktionieren kann, sollte klar sein, da die originalen Synology´s ein UEFI/EFI-BIOS benutzen, wo die DSM-Software ihre Einstellungen hinein schreiben kann (was Hardware-nah ist).

Ich kann meinen Server dann im Dauerbetrieb laufen lassen, da spielt das also keine Rolle.

Welchen anderen Dell-Server hast Du noch getestet? Ich hätte noch einen DPE-T610 zur Verfügung.

 

Herzliche Grüße

 

Heiko

 

Wie sieht es denn auf einem Boad mit UEFI Bios aus? Ich nutze das MSI B150M ECO und dieses hat ein UEFI Bios. Ist hier der offizielle Weg über die Synology möglich?

 

Gruß

Infosucher

Link to comment
Share on other sites

da ich auch noch vorhabe, einen DPE-2900III (Du müßtest den gleichen haben) auf Synology umzubauen bin ich schon mal froh über Deine Erfahrungen zu lesen.

Da das programmierte hoch und runterfahren nicht auf dem originalen Synology-Weg funktionieren kann, sollte klar sein, da die originalen Synology´s ein UEFI/EFI-BIOS benutzen, wo die DSM-Software ihre Einstellungen hinein schreiben kann (was Hardware-nah ist).

Ich kann meinen Server dann im Dauerbetrieb laufen lassen, da spielt das also keine Rolle.

Welchen anderen Dell-Server hast Du noch getestet? Ich hätte noch einen DPE-T610 zur Verfügung.

 

Hallo Heiko,

 

leider sind alle von mir getesteten Server DPE 2900, nur mit unterschiedlichen BIOS-Versionen und unterschiedlicher Hardware.

Das mit dem UEFI-BIOS war mir so nicht klar. Dann wird das von mir angestrebte Ziel, den Server zeitgesteuert hoch- und runter zu fahren leider so nicht realisierbar sein, zumindest nicht mit dieser Hardware.

 

Das Problem ist bei dem Dell-Server der enorm hohe Stromverbrauch im laufenden Betrieb. Da der Server als Backup-Server herhalten soll, muss er also auch nicht dauerhaft laufen und so teure Nebenkosten verursachen. Bei einem 24/7-Betrieb würden da locker etwa 700 Euro Mehrkosten an Strom auf mich zukommen. Das ist enorm und für mein kleines Heimnetzwerk so nicht tragbar.

Da der Dell-Server mit dem zeitgesteuerten Hoch- und Runterfahren in Verbindung mit XPEnology so nicht funktioniert, kommt XPEnology dann für diese Hardware auch nicht in Frage.

 

Da ist meine alte, echte DS209+ doch wesentlich sparsamer, allerdings auch bei weitem nicht so leistungsfähig.

 

Momentan teste ich diverse NAS-Systeme aus und werde mal sehen, ob andere NAS-Beriebssysteme meine Zwecke erfüllen können.

 

Herzlichen Dank nochmal für deine Rückmeldung.

Gruß Achim

Link to comment
Share on other sites

Das automatisierte Hochfahren geht doch über das BIOS direkt. Zumindest kenn ich das so aus dem Dell-Optiplex so.

Ich muß mich mal auf den Server schalten und das nochmal prüfen ...

Runterfahren läßt sich dann bestimmt auch im DSM mittels Script ...

Somit müßte das doch realisiert werden können.

Zum Stromverbrauch kann ich nur sagen, der T610, was ja dem Nachfolger entspricht, der genehmigt sich mit 2x QuadCore E5540, 96GB RAM, 8x HDD und 2x Netzteilen ca. 232Watt effektiv - zumindest stehts vorne auf dem Display ... dafür hat er aber massiv Rechenpower, so das man genügend virtuelle Maschinen in php VirtualBox noch laufen lassen könnte.

Der 2900III braucht fast das doppelte - müßte den glatt mal mit einer Fritz-Steckdose (DECT200) ausmessen.

Als anderes NAS-System könnte nur noch maximal QNAP mithalten, schade das es da noch kein "Nachbau"-Projekt von gibt - Hardware ist ziemlich ähnlich.

 

Herzliche Grüße

 

Heiko

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...