Jump to content
XPEnology Community

Missing firmware for Brocade 10G


Trantor
 Share

Recommended Posts

Current release lack two firmware for Brocade 10G adapters.

 

Firmware : https://download.xpenology.fr/drivers/bna-firmware.zip

 

Put the two .bin files in /lib/firmware/

 

I did that but it still gives errors

 

I created a folder for with the names and put the files in that but it still gives errors.

 

[   55.808142] Brocade 10G Ethernet driver - version: 3.1.2.1
[   55.808151] bnad_pci_probe : (0xffff880807572000, 0xffffffffa03ebc60) PCI Func : (2)
[   55.811000] Can't locate firmware ctfw-3.1.0.0.bin
[   55.811001] Failed to load Firmware Image!
[   55.811007] bnad_pci_probe : (0xffff880807562800, 0xffffffffa03ebc60) PCI Func : (3)
[   55.813711] Can't locate firmware ctfw-3.1.0.0.bin
[   55.813713] Failed to load Firmware Image!

Link to comment
Share on other sites

Current release lack two firmware for Brocade 10G adapters.

 

Firmware : https://download.xpenology.fr/drivers/bna-firmware.zip

 

Put the two .bin files in /lib/firmware/

 

rmmod bna

insmod /lib/modules/bna.ko

dmesg

 

[  402.232673] Brocade 10G Ethernet driver - version: 3.1.2.1
[  402.232687] bnad_pci_probe : (0xffff880807a9a000, 0xffffffffa0ee5c60) PCI Func : (2)
[  402.242749] bar0 mapped to ffffc90019a00000, len 262144
[  402.242809] bna 0000:01:00.2: irq 47 for MSI/MSI-X
[  402.242813] bna 0000:01:00.2: irq 48 for MSI/MSI-X
[  402.242815] bna 0000:01:00.2: irq 49 for MSI/MSI-X
[  402.242820] bna 0000:01:00.2: irq 50 for MSI/MSI-X
[  402.242823] bna 0000:01:00.2: irq 51 for MSI/MSI-X
[  402.242825] bna 0000:01:00.2: irq 52 for MSI/MSI-X
[  402.697483] bnad_pci_probe : (0xffff880807abe800, 0xffffffffa0ee5c60) PCI Func : (3)
[  402.697543] bar0 mapped to ffffc90019a80000, len 262144
[  402.697591] bna 0000:01:00.3: irq 53 for MSI/MSI-X
[  402.697594] bna 0000:01:00.3: irq 54 for MSI/MSI-X
[  402.697596] bna 0000:01:00.3: irq 55 for MSI/MSI-X
[  402.697599] bna 0000:01:00.3: irq 56 for MSI/MSI-X
[  402.697601] bna 0000:01:00.3: irq 57 for MSI/MSI-X
[  402.697603] bna 0000:01:00.3: irq 58 for MSI/MSI-X

 

 

i tired to issues those comands and that is the output it seems to load but it does not show anything nor does it do anything after a reboot

Link to comment
Share on other sites

  • 2 weeks later...
Current release lack two firmware for Brocade 10G adapters.

 

Firmware : https://download.xpenology.fr/drivers/bna-firmware.zip

 

Put the two .bin files in /lib/firmware/

 

I have done this and i am still getting error in dmesg and it does not load i have posted updates to the post but the brocade works in windows and is showing in bios do i have to have certain firmware on the brocade adapter? please let me know i need this to move my data over.

Link to comment
Share on other sites

  • 2 weeks later...
Same issue is happening to me. I followed the instructions of copying the firmware files and rebooting thinking that there would be automatic detection. I got the same out put in "dmesg" as the previous thread.

 

what is your firmware version on the brocade?

Link to comment
Share on other sites

 Share

×
×
  • Create New...