bricked trying to upgrade 6.2.3 to 6.2.4, now struggling to restore

Recommended Posts

I ran xpenology 1.03b 6.2.3 on esxi 6.7. I have 4 hdds in the setup,

1st is the synoboot I believe.

2nd is the main 16GB filesystem on a shared ssd. 

3rd is a physical 2TB hdd

4th is a 3TB dell hardware raid 1 disk, which has 2 hdds behind it. 


I backup this vm with virtual machine backup in Active Backup for Business on a different Synology. 


I tried to upgrade the xpenology to 6.2.4 and now it wont ping and is bricked.  

I attempted to do full restore of the vm using Active Backup for Business but that does not work because 3rd and 4th drives are too big and as it tried to "restore" them I ran out of space. 


So I did an instant restore. Then disk 1 and 2 vmdk files I moved from remote mounted drive by Synology onto esxi drive where my vms are. 

For the original xpenology vm I removed disk 1 and disk 2 hard drives in the settings and added disk 1 and disk 2 hard drives that I moved from instant restore. If I remove hdd 3 and hdd 4 from settings, then I can start the original xpenology without the 2 storage drives. But I need those drives. If I readd those drives as existing virtual machine drives then I think they have dsm 6.2.4 written into some hidden partition on them and xpenology goes into recovery screen and it cannot be recovered. Is it possible to remove that hidden synology partition from hdd 3 and 4, so that I can add them as "fresh" disks except for they will still have my data?




Link to post
Share on other sites

deleting partition did not work. obviously. just made the drive unusable in synology, maybe could have used it under linux. what did work was hot plugging hardware raid 1 drive in when xpenology was already running, it said not initialized, then after restarting xpenology, it booted and just needed a repair. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.