zorrobyte137

How I got read+write SSD Caching working (maybe devs read?)

Recommended Posts

Greetings! I am Zorrobyte of http://www.rossfisher.me blog, I just returned my DS716+ and DX513 as I couldn't bear having spent a grand when I have a Intel i7-2600s 14 port server going to waste, so I switched back to Xpenology.

 

We all know that SSD Caches on Xpenology leads to issues but I finally got mine to work, instead of a how-to, I'll share the specific events which i got mine to work so maybe it'll help developers or users can try.

 

This is the hardware:

i7-2600s

16gbRAM

2x Gbie Intel Pro Server in LACP

MSI Z77MA-G45 mATX board

2x SYBA SI-PEX40064 PCI-Express 2.0 Low Profile Ready SATA III (6.0 Gb/s) Controller Card

 

I have 3x WD Red Pro 6TB drives connected to the PCIE cards along with 2x Samsung 840 Evos (also on the expansion SATA card).

 

I created a USB stick with XPEnoboot DS3615xs5.2-5644.4 and installed DSM_5.2-5644 & DSM_5.2-5644 Update-1 & DSM_5.2-5644 Update-2

 

I created a SHR-1 volume with the 3x Wd PRO

 

I created a read cache with one ssd, it works perfectly. I then deleted the read SSD Cache.

 

I created a read+write SSD Cache with the 2x 840 Evos and it crashed the volume, I rebooted and the 3x WD RED was normal, the SSD Cache reported missing, I removed the R+W SSD Cache from Storage Manager

 

I shutdown and flashed XPEnoboot 5.2-5592.1 DS3615xs to USB, I booted and tried making R+W SSD Cache, it bootlooped

 

I shutdown manually and reflashed XPEnoboot DS3615xs5.2-5644.4 (without removing SSDs or deleting SSD Cache from previous bootlop)

 

The machine booted and Storage Manager said it was resyncing/repairing the SSD Cache. I waited an hour for it to finish and now it works perfectly, even after reboots!

 

Long story short, I think the solution is to create your SSD Cache under XPEnoboot DS3615xs5.2-5644.1, let it bootloop, shutdown manually then flash XPEnoboot DS3615xs5.2-5644.4 for it to resync and it'll work then. I also read that some users had issues with the SSD Cache on certain SATA ports so try shifting your ports around. This is why I went only with the PCIE cards for my SATA drives to rule out any motherboard issues.

 

Links to exactly what xpenoboot I used is here (IMG files):

https://drive.google.com/open?id=0B8WTs ... DZhNE9Wb2s

https://drive.google.com/open?id=0B8WTs ... k5tMVhNMk0

 

No idea why this works, but it did for me. Maybe something to do with the drivers. If devs can take a look at why this works and implement the fixes in a future version, it'd be grand!

 

Note that the drivers, the ko files that get updated during a new Xpenoboot ran each time between versions, this may be the key.

Share this post


Link to post
Share on other sites

Is read only SSD cache supported to reset / go back to zero after a reboot?

 

Sorry to jump on your thread but trying to figure this out and can't find any mention of it.

Share this post


Link to post
Share on other sites