Sign in to follow this  
Sabrina

[Tuto] Wake on lan avec Freebox Server.

Recommended Posts

Salut à tous,

 

Voici un petit tutoriel de comment activer et utiliser la fonction Wake On Lan depuis une Freebox Server.

 

 

Mon server NAS me sert uniquement pour télécharger, j’ai mis en place des plages horaires pour éviter de le laisser allumer 24/7 car pour moi il y a aucun intérêt.

 

Tous les jours mon NAS s’allume à 16H pour s’éteindre à 02H.

 

Il m’arrive parfois d’avoir du temps libre pendant le boulot et j’aimerais bien me connecter à mon server NAS mais quand il est 13H c’est difficile car il faut attendre 16H pour qu’il soit allumé.

 

La fonction Wake On LAN est bien pratique pour mes besoins, allumer l’ordinateur à distance à n’importe quel moment de la journée c'est vraiment top :mrgreen:

 

1: Pour mettre en place cette fonction, il faut que votre ordinateur soit compatible Wake ON LAN, pour cela faut aller dans le bios de votre carte mère et regarder si l’option y est présente et activé.

 

 

2: Pour que le Wake On Lan soit opérationnel, il faut l’activer depuis la Freebox Server comme suit.

 

Allez sur mafreebox.freebox.fr

Entrer votre mot de passe.

 

Allez dans Paramètres de la Freebox / Mode Avancé / Configuration et activer Proxy Wake ON LAN

 

 

3: Pour allumer votre ordinateur à distance, depuis l’extérieur ou en réseau local.

 

Allez sur mafreebox.freebox.fr

Entrer votre mot de passe.

 

Périphérique réseau

Repérer votre server NAS qui doit être grisé ( éteint ) , faite un click droit avec la souris et sélectionner réveille réseau WAKE ON LAN et ensuite Allumer.

 

 

Vous pouvez utiliser l'application Freebox Compagnon depuis iOS ou Android.

 

Allez dans Machine en réseau et sélectionner votre server et puis la à droite il y a une petite flèche, clicker dessus et ensuite Allumer L'appareil ( WOL )

 

 

J'espere que cela va vous servir :mrgreen:

Share this post


Link to post
Share on other sites

:eek: ... super, merci, je n'avais jamais pensé à utiliser cette fonction sur la box server, ça fonctionne parfaitement !

 

il faut juste activer le WOL dans le bios ( ou resume by PME, by PCI ... suivant votre bios et votre hardware).

 

ensuite, il faut s'assurer que le WOL est bien configuré sur linux.

 

- activer ssh dans le panneau de config du diskstation (si ce n'est pas déjà fait).

- se connecter en ssh en root.

 

ethtool eth0

 

- vérifier le statut du WOL (Wake-on: g)

 

- sinon:

 

ethtool -s eth0 wol g 

 

- réveiller le diskstation avec le server freebox en suivant les indications de Sabrina, ou avec n'importe quel programme qui envoie le paquet.

 

 

****

sur mon server mail sous debian, j'ai du d'abord installer le paquet nécessaire:

 

apt-get install ethtool 

 

****

 

Si vous n'avez pas besoin de faire tourner votre diskstation (ou autre server) H24, et par souci de consommation électrique, cette fonction de WOL est très simple à mettre en place, et très pratique.

 

@+

Share this post


Link to post
Share on other sites

Oui c'est vraiment pratique en effet.

J'ai découvert cette fonction en trifouillant la Freebox et j'en suis ravie.

 

Bonne continuation :mrgreen:

Share this post


Link to post
Share on other sites

C'est une fonction très ancienne et effectivement pratique.

Par contre pour ma part depuis que je suis avec ESXi sur mon HP N54L impossible de le faire fonctionner... Si qqn à une idée je suis preneur.

Share this post


Link to post
Share on other sites

je rencontre un problème, la manip que j'ai décris fonctionne, mais le réglage WOL=g n'est pas persistant.

cad après le réveil du PC le WOL repasse à "d" dans la config synology.

 

je suis en train de chercher ... dès que j'ai du neuf ...

 

@ Sabrina: comment as tu configuré le WOL sur ton diskstation ?

Share this post


Link to post
Share on other sites

Personnellement moi je n'ai rien touché, j'ai juste activé le Wol depuis la Freebox et c'est tout.

Sur le DSM 5.2 Update 2, je n'ai strictement rien touché, tout fonctionne d'origine.

 

Peut être que mon Pc est mieux adapté :?:

Share this post


Link to post
Share on other sites

c'est juste que habituellement le WOL est desactivé via le BIOS pour eviter les abus et que seule une personne sachant de quoi il s agit puisse l utiliser :wink:

Share this post


Link to post
Share on other sites
c'est juste que habituellement le WOL est desactivé via le BIOS pour eviter les abus et que seule une personne sachant de quoi il s agit puisse l utiliser :wink:

 

rien à voir (lit mes précédents messages).

mon bios est correctement configuré.

 

Je fais actuellement des tests sur une CM à base d'atom avec une install fraiche DSM 5.2n (et avec un bios bien configuré).

j'arrive à réveiller n'importe quel PC sur le réseau, sauf les XPEnology.

 

exemple, sur cette carte atom, je réveille une fedora ou une debian sans problème.

si je boot avec la clef d'XPEnology et que j'installe la DSM, le wol ne fonctionne plus (sans la commande "ethtool -s eth0 wol g").

... au second arrêt cela ne fonctionne plus, eth0 wol repasse à "d" dans le fichier de config.

 

Je suis en train de tester des modifs dans le fichier de config.

Sans résultat, pour l'instant.

Je cherche ...

Share this post


Link to post
Share on other sites

Bon ben c'est bon ça fonctionne, et ça fonctionne même avec le synology assistant maintenant.

 

J'ai tenté tellement de modifications que je ne sais plus quelles sont les modifs appropriées.

Je refais une instal propre, et je vous donne la marche à suivre.

 

Personnellement moi je n'ai rien touché, j'ai juste activé le Wol depuis la Freebox et c'est tout.

Sur le DSM 5.2 Update 2, je n'ai strictement rien touché, tout fonctionne d'origine.

 

étrange, car le WOL c'est à la fois hard (bios de la CM ou de la carte réseau) et soft (réglage de l'OS) ... :sad:

Share this post


Link to post
Share on other sites

perso, je pense avoir tout vu en matière de WOL!

Exemple : j'ai un (vieux) PC type P4 (c'est pour dire) dans son BIOS le réglage WOL était à disabled et pourtant j'arrivai à l'allumer.

Un autre où il n'y a pas ce réglage et j'arrive aussi à l'allumer.

Le seul cas où ça ne peut pas marcher est lorsque qu'il s'agit d'une carte réseau WIFI (typiquement un portable ou un dongle Wifi). Mais chez moi (sans vouloir me répéter) avec ESXi sur mon N54L impossible de le réveiller.

Share this post


Link to post
Share on other sites
Sign in to follow this