sel

Virtualbox ошибки запуска.

Recommended Posts

Помогите решить проблему с virtualbox.

После установки и попытки запуска машины вискакивает Failed to load VMMR0.r0 (VERR_SUPLIB_SYMLINKS_ARE_NOT_PERMITTED)

Причем не важно вновь созданная или готовый образ.

Как побороть???

Virtualbox установлен и запущен на dsm по ссылке http://xpenology.me/how-to-run-virtual-machine-at-dsm/

Share this post


Link to post
Share on other sites

Виртуализация в биосе хоста Xpenology есть\включена? Какие нибудь виртуалки вообще запускаются?

Попробуйте отключить в конфиге виртуальной машины все устройства (lan, звук и т.д.). У меня ругалось на звуковую карту.

Share this post


Link to post
Share on other sites

В биосе параметр включен.

Пробовал отключать все устройства ишибка осталась.

Виртуалки все вываливаются с ошибкой.

Share this post


Link to post
Share on other sites

Попробуйте виртуалку https://dev.windows.com/en-us/microsoft-edge/tools/vms/linux/ windows 7 c любым ie . Это оф. мелкософтовский триал у меня заработала из коробки.

Напишите версию пакета VirtualBox и Версию DSM.

Edited by Guest

Share this post


Link to post
Share on other sites

Версия dsm 5.2-5592 up 4.

Vertualbox 4.3.30.1

 

Отправлено с моего Redmi Note 2 через Tapatalk

Share this post


Link to post
Share on other sites

В версиях DSM я сам запутался :smile: . У меня DSM 5.2-5592 up 4 [как ваша]и VirtualBox (пакет от сообщества) 5.0.10-104061-1 seba/dodo-dk/DI4bI0 работает.

 

В старшей вроде проблемы.

Virtualbox не работает в 5.2-5644, vpn вроде как тоже

viewtopic.php?f=2&t=10525#p50967

PS: sel2008 и sel :?: Ценю людей с раздвоение личности... :lol:

Share this post


Link to post
Share on other sites

Новая ошибка

VirtualBox (пакет от сообщества) 5.0.10-104061-1 seba/dodo-dk/DI4bI0

An unknown PHP error occurred. This is most likely a syntax error in config.php in phpVirtualBox's folder. The most common errors are an unclosed quote or a missing semicolon in a configuration item that has been entered (e.g. location, username, or password).

Depending on your PHP configuration, navigating directly to config.php in your web browser may display the PHP error message.

If find that this is not the case,or have no idea what this error message means, please raise the issue at http://sourceforge.net/p/phpvirtualbox/discussion/help/

Share this post


Link to post
Share on other sites

Упс. Давайте еще потыкаем вашу систему. Удалите VB. Перезагрузитесь. Поставьте пакет PHP PEAR. Поиграйте галкой Включения WEB сайта (Панель управления - Веб-службы).

Еще как то раз из-за истязаний над NAS были проблемы из-за .htaccess . Его по моему можно просто удалить в папке web и перезагрузиться.

Выложите скрин Панель управления - Веб-службы Настройки PHP с развернутым списком PHP extention так чтобы все влезло. Поиграйте там галками сброса и Настроить PHP open_basedir. Попробуйте др. браузер или сбросьте кэш. Выключите NAS на минутку из эл. сети (лучше корректно) и потом опять включите. Проверьте права группы http.

 

Другие веб службы из папки web работают? (Веб морда трансмишен и т.п.)

Я правильно понимаю что пятый виртуалбокс совсем не стартует? Или ошибка при старте вирт. машины?

 

PS Перед играми забекапьтесь.

 

Народ подтягивайтесь. Первая линия ТП выдохлась и достигла своего уровня некомпетентности.

Share this post


Link to post
Share on other sites

Все службы работают нормально. Virtualbox по вашей ссылке вообще не стартует после установки. Сразу ошибка при открытии.

 

Отправлено с моего Redmi Note 2 через Tapatalk

Share this post


Link to post
Share on other sites

В virtualbox на PC поднял чистую установку xpenology.

Поставил пакет, ошибка та же.

Share this post


Link to post
Share on other sites

Другой браузер исправил ситуацию.

Share this post


Link to post
Share on other sites

Все равно не запускается

Failed to load R0 module /opt/VirtualBox/VMMR0.r0: Symlinks are not permitted: '/opt' (VERR_SUPLIB_SYMLINKS_ARE_NOT_PERMITTED). Failed to load VMMR0.r0 (VERR_SUPLIB_SYMLINKS_ARE_NOT_PERMITTED)

 

Детали

Share this post


Link to post
Share on other sites

Exception Object

(

[message:protected] => Failed to load R0 module /opt/VirtualBox/VMMR0.r0: Symlinks are not permitted: '/opt' (VERR_SUPLIB_SYMLINKS_ARE_NOT_PERMITTED).

Failed to load VMMR0.r0 (VERR_SUPLIB_SYMLINKS_ARE_NOT_PERMITTED)

[string:Exception:private] =>

[code:protected] => 0

[file:protected] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php

[line:protected] => 2429

[trace:Exception:private] => Array

(

[0] => Array

(

[file] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php

[line] => 951

[function] => remote_progressGet

[class] => vboxconnector

[type] => ->

[args] => Array

(

[0] => Array

(

[progress] => 6890a5beaa36c396-0000000000000005

)

 

)

 

)

 

[1] => Array

(

[file] => /volume1/web/phpvirtualbox/endpoints/api.php

[line] => 316

[function] => __call

[class] => vboxconnector

[type] => ->

[args] => Array

(

[0] => progressGet

[1] => Array

(

[0] => Array

(

[progress] => 6890a5beaa36c396-0000000000000005

)

 

[1] => Array

(

[0] => Array

(

[data] => Array

(

[responseData] => Array

(

[progress] => 6890a5beaa36c396-0000000000000005

[info] => Array

(

[completed] => 1

[canceled] =>

[description] => Starting VM

[operationDescription] => Starting virtual machine

[timeRemaining] => Array

(

)

 

[timeElapsed] => Array

(

[days] => 16810

[hours] => 15

[minutes] => 10

[seconds] => 47

)

 

[percent] => 20

)

 

)

 

[success] => 1

[key] => 53474945cfd7ac0bf8114767c209c2a6

)

 

[errors] => Array

(

)

 

[persist] => Array

(

)

 

[messages] => Array

(

)

 

)

 

)

 

)

 

)

 

)

 

[2] => Array

(

[file] => /volume1/web/phpvirtualbox/endpoints/api.php

[line] => 316

[function] => progressGet

[class] => vboxconnector

[type] => ->

[args] => Array

(

[0] => Array

(

[progress] => 6890a5beaa36c396-0000000000000005

)

 

[1] => Array

(

[0] => Array

(

[data] => Array

(

[responseData] => Array

(

[progress] => 6890a5beaa36c396-0000000000000005

[info] => Array

(

[completed] => 1

[canceled] =>

[description] => Starting VM

[operationDescription] => Starting virtual machine

[timeRemaining] => Array

(

)

 

[timeElapsed] => Array

(

[days] => 16810

[hours] => 15

[minutes] => 10

[seconds] => 47

)

 

[percent] => 20

)

 

)

 

[success] => 1

[key] => 53474945cfd7ac0bf8114767c209c2a6

)

 

[errors] => Array

(

)

 

[persist] => Array

(

)

 

[messages] => Array

(

)

 

)

 

)

 

)

 

)

 

)

 

[previous:Exception:private] =>

)

Share this post


Link to post
Share on other sites

Нет, проверил все в порядке

Edited by Guest

Share this post


Link to post
Share on other sites

Хмм... Я даже не знаю точно как правильно проверить... Вроде через консоль владельца каталога? Какие должны быть? Я то все-всем сильно много раз ковырял...

Пакеты optware или entware стоят? Что-то правильные мысли закончились...

Share this post


Link to post
Share on other sites

По ssh папки все root/root 755

 

Отправлено с моего Redmi Note 2 через Tapatalk

Share this post


Link to post
Share on other sites

Это уже читал. :sad:

 

Отправлено с моего Redmi Note 2 через Tapatalk

Share this post


Link to post
Share on other sites

1) Я думаю по поводу прав нужен такой бубен:

NAS> ls -a -l
drwx------    7 root     root          4096 Dec 17 17:44 .
drwxr-xr-x   29 root     root          4096 Jan  9 22:58 ..
drwx------    4 root     root          4096 Sep 23 10:41 .cache
drwx------    5 root     root          4096 Dec 26 16:54 .config
-rw-------    1 root     root            16 Sep 23 15:01 .esd_auth
drwx------    2 root     root          4096 Sep 21 22:29 .gnupg
drwx------    3 root     root          4096 Sep 23 10:41 .local
-rw-r--r--    1 root     root           364 Mar 12  2015 .profile
drwx------    2 root     root          4096 Jan  9 21:43 .pulse
-rw-------    1 root     root           256 Sep 23 15:01 .pulse-cookie
-rw-r--r--    1 root     root             0 Dec 17 17:44 ls


NAS> cd /root/.config
NAS> pwd
/root/.config
NAS> ls -a -l
drwx------    5 root     root          4096 Dec 26 16:54 .
drwx------    7 root     root          4096 Dec 17 17:44 ..
drwxr-xr-x    2 root     root          4096 Jan  9 22:52 VirtualBox
drwx------    2 root     root          4096 Dec 26 16:54 htop
drwx------    3 root     root          4096 Jan 10 20:09 mc

NAS> cd ~
NAS> pwd
/root
NAS> cd /opt
NAS> pwd
/opt
NAS> ls -a -l
drwxr-xr-x    3 root     root          4096 Nov 21 15:46 .
drwxr-xr-x   29 root     root          4096 Jan  9 22:58 ..
drwxr-xr-x   14 root     root          4096 Nov 11 01:30 VirtualBox

Edited by Guest

Share this post


Link to post
Share on other sites

Я правильно понимаю, что вебморда VB теперь стартует, но по прежнему ругается при запуске виртуальной машины?

Share this post


Link to post
Share on other sites

Мартышкины решения:

Удалить пакет VB. Перезагрузить NAS. Зайти в Веб морду DSM дефолтным админом (или если раньше ставили из-под дефолтного админа, то создать нового). Установить пакет от другого админа. Огорчиться/обрадоваться. Отписаться. Если в вашей полосе вечер, то забить до утра и пойти спать. Надеяться, что еще кто-то прочитает и поможет.

Share this post


Link to post
Share on other sites