HP N54L Blinking Cursor "Screen will stop updating shortly"


Recommended Posts

Most likely the files on my USB device are correct? But How Do I Edit the Boot Loader Files?????

 

WinImage is so crap, it doesn't see any of my USB devices (even running as admin). So I use Rufus which works perfectly. I can boot from the USB fine, i see "This mod is brought to you by...." etc. etc., but i never seen that page change and I dont see anything loading. Also the num lock light stuck and no caps lock light, so it has definitely hung.

 

So presumably I need to edit the boot files? But the USB volumes are inaccessible/unformatted in Windows 10...

 

I have installed OSFMount, but that still does not open the IMG file into a format I can read/open/edit, i cannot see any grub file or anything else I can edit to try to resolve this.


Can anyone offer advice please?

 

PS I am reasonably IT savvy, but clearly doing something wrong or just that being a Windows user means much of this is more difficult than with a linux distro...

Edited by MikhailCompo
improved content
Link to post
Share on other sites
  • MikhailCompo changed the title to HP N54L Blinking Cursor "Screen will stop updating shortly"

Once the bootloader gets to "Screen will stop updating shortly", it really means it. The next step is to open a browser on a PC connected to the network and type in find.synology.com - or alternatively download Synology Assistant to your PC and run that.

From this point on, neither monitor or keyboard do anything - after all a real Synology has neither.

Edited by billat29
Link to post
Share on other sites
Posted (edited)

No. It is not getting that far, the device is hung and its not getting an IP address. If it's not on the LAN doesn't matter what I scan with, its not going to be found is it...

 

I need to edit the grub.cfg but I do not know what with. I have set the VID, PID and MAC but it is still hanging.....

Edited by MikhailCompo
Link to post
Share on other sites

OK. I am missing something here. I do not understand why you wouldn't go back to the source files you used to create the bootloader in the first place, make changes and write to USB anew.

 

I am happy to work through the steps to get you to install DSM on your N54L but I would take you back to the beginning and go through what you have done, step by step. It sounds like that would just annoy you at this point.

But if it is not booting - have you disabled C1E in the BIOS?

Link to post
Share on other sites

Yes, I have disabled C1E in BIOS.

 

I have written the following boot loaders to USB, taking from the original IMG files, so I am starting from new each time. All have the same effect, the machine boots from USB but freezes.

 

Jun's Loader v1.03b DS3615xs [Synoboot_3615]

Jun's Loader v1.03b DS3617xs [Synoboot_3617]

Jun's Loader v1.04b DS918+ [Synoboot-ds918]

 

The only thing I am changing in the grub.cfg is the VID, PID, MAC and timeout.

 

I am checking my router logs to see the DHCP lease request, I know the MAC, but its not doing it, the NIC is not initializing and device is not accessing the LAN at all, hence freezing.

 

Any ideas what I could try?

 

This is SOOO frustrating because I had DSM on this machine a few years ago......

Link to post
Share on other sites

I can eliminate some of the possibilities:

DS918 won't work. It's for a later Intel processor.

extra.lzma is not required. N54L will work with integrated nic without.

For the initial boot of the loader, it doesn't matter about VID, PID and MAC. You can't install without VID and PID set, but it should appear on the network.

SO, do you get any messages on the screen after the BIOS starts the bootloader?

 

and, are you sure that the box is physically connected the network (no cable problems etc_

Link to post
Share on other sites

FFS! Fixed it

 

I tried a different USB port and it worked.

 

I downloaded a PDF showing the ports and it showed them all USB 2.0 and none of the ports are coloured. Despite that, the USB port at the back works...... I presume the ones on the front are in actual fact 3.0.

 

So, now to load the image.....

 

Link to post
Share on other sites
Posted (edited)
3 minutes ago, billat29 said:

Good news! There is also an internal USB but lets stick with the one that works :-)

25426 is the one you want

 

Yes I use the internal USB, but its fiddley when you are re-writing it 100 times!!! 😩 Thanks again for your help.

 

I have loaded 25426 and its fully operation. However, I now see there is a 25556 from March.

 

Do I need to be careful updating? I gather from forum comments that people have lost network access updating?

Edited by MikhailCompo
Link to post
Share on other sites
10 minutes ago, MikhailCompo said:

Do I need to be careful updating? I gather from forum comments that people have lost network access updating?

 

Answered my own question again!!!!

 

It appears that updating to 25556 killed my server.

 

Is there any good general advice for A) How to update (do I go through DSM?) and B) when I should update?

Link to post
Share on other sites

a) Good advice is: DON'T. See all the messages at the top of the forum page. The latest release that is currently supported is the one I suggested. 6.2.3 is the latest release that works.

b)You will need a new loader to go to 6.2.4 or 7.x. This is currently being developed (see the "redpill" thread in the developer section).  In general you need to refer to the forum before you attempt any new release. In the meantime, make sure that automatic updates are disabled in Control Panel.

For now, stick with 6.2.3

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.