Recommended Posts

Hi there!


I am using a real synology server (1 bay. ds115j), but i know that this forum is much more useful for my question than officail synology forum, so please let me answer my question here.


So what is the problem: i have a 2tb hdd, but only about 500 gb is using by synology. I created new partition (/dev/sda4) with parted with a size of 1500 gb, so now when i run fdisk -l command i see:


Device     Boot     Start        End    Sectors   Size Id Type
/dev/sda1            2048    4982527    4980480   2.4G 83 Linux
/dev/sda2         4982528    9176831    4194304     2G  1 FAT12
/dev/sda3         9437184  976768063  967330880 461.3G 83 Linux
/dev/sda4       976768064 3726033203 2749265140   1.3T 83 Linux


But when i run df -h command i see:


 df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       2.4G  1.2G  1.1G  53% /
none            117M     0  117M   0% /dev
/tmp            122M  752K  121M   1% /tmp
/run            122M  2.3M  119M   2% /run
/dev/shm        122M  4.0K  122M   1% /dev/shm
/dev/sda3       455G  451G  3.2G 100% /volume1


I tried to modify fstab file, adding the last line:


none /proc proc defaults 0 0
/dev/root / ext4 defaults 1 1
/dev/sda3 /volume1 ext4 usrjquota=aquota.user,,jqfmt=vfsv0,synoacl,relatime 0 0

/dev/sda4 /volume2 ext4 usrjquota=aquota.user,,jqfmt=vfsv0,synoacl,relatime 0 0


But after reboot this file rewrites and i see no /volume2


Of course, i can't do anything inside dsm web panel, the button "create" is not active (inside storage manager/volume in dsm). So i have to work with cli only. All tools are installed (fdisk, parted,pvcreate commands can be executed), also yes, root is working in ssh...What can i do in this case ?

Link to post
Share on other sites

You cannot make two volumes on the same physical disk.

The "create" button in the UI is not available because the UI won't make two volumes on the same physical disk either.


Offload your files, delete the volume you have, add it back in to use the balance of the disk space for /dev/sda3.

Link to post
Share on other sites

Well, you can do what I suggested, which is copy off files, delete and remake your Storage Pool/Volume and it will use the size.


Synology will automatically expand multi-drive arrays that are grown, but it has no provision for expanding a single drive.


It can be done manually and is a basic procedure common to all Linux systems. You can follow this thread to get it done:


You have an ext4 filesystem and you are not using lvm, and you have a one-disk system so DSM appears to be using the physical partitions instead of arrays, so choose your command arguments accordingly.  Also it goes without saying that you run the risk of volume corruption if a mistake is made, so you should have all your files backed up somewhere else before trying this.


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.