Sign in to follow this  
yop

Installation sur NAS netgear

Recommended Posts

Salut,

 

J'ai déposé un post dans la section anglaise, je suis à la recherche de complément d'information concernant l'installation de XPEnology 5.2 sur un Netgear RNDU 4000.

 

J'ai regardé le post : http://xpenology.com/forum/viewtopic.php?f=2&t=2565

Mais je trouve malheureusement pas toutes les infos.

 

J'ai bien réussi à lancer l'installation, cependant comment faire pour se débarrasser de la clef USB après l'installation. Si je retire la clef et après reboot le nas refuse de se lancer, avec la clef pas de soucis.

 

Le second problème c'est le ventilateur qui tourne à fond et je ne parviens pas à suivre les etapes, j'ai comme la sensation qui manque des etapes.

 

Merci d'avance pour votre aide

Share this post


Link to post
Share on other sites

Avec XPENOLOGY il faut impérativement une clé de démarrage USB sauf si vous savez "bidouiller"

 

Tout d'abord il faut une machine Linux

Dans la partition du disque dur il y a un petit espace de 128 mo disponible dans les partitions

Il faut recopier le contenu de la clé à cet endroit et rendre cette partition bootable

 

Pour le ventilateur je n'en ai aucune idée car c'est un matériel spécifique

Si vraiment c'est ennuyeux peut-être un contrôle "hard" avec CTN et transistor pourrait peut être faire l'affaire ou un système genre rhéostat comme avec certains ventilateurs de PC

Share this post


Link to post
Share on other sites

  dd if=/dev/sdu of=some_file_name 

 

Si je comprend bien cela sert comme backup. Par contre comment je la recupere ou ?

ce qui m'etonne ici c'est que /dev/sdu semble faire reference à la partition de lancement mais faut il pas preciser la sortie autre part ?

 

Ensuite :

 

dd if=synoboot-5-beta.img of=/dev/sdu

 

L'image doit se situer ou, sur la clef usb ?

A titre d'exemple XPEnoboot_DS3615xs_5.2-5644.4.img ?

Comment la mettre en place ?

A moins qu'il y as deja une image sur la partition comment je trouve son nom ?

Share this post


Link to post
Share on other sites

EDIT : supprimé . j ai lu trop vite et j ai dit une connerie !

Edited by Guest

Share this post


Link to post
Share on other sites

La clé USB remplace un peu le BIOS du matériel Synology + la partition d' amorçage de l'OS

 

Il n'y a pas besoin de rawrite mais simplement de recopier le contenu de la clé dans la "fameuse " partition de 128 Mo

 

J'ai fait l'essai mais c'est ennuyeux car à chaque mise à jour il faut refaire la manipulation donc la clé c'est et restera le plus simple et il vaut mieux que vous abandonniez cette solution

Share this post


Link to post
Share on other sites

L'idée était d'essayé, je trouve ça ennuyé de devoir appuyé sur le bouton backup pour booter sur la clef etc.

Ensuite je m'attaque à FanSpeed.

Du coup je tourne toujours en rond pour recuperer le backup et l'installation du contenu de la clef dans la partition...

Share this post


Link to post
Share on other sites

Du coup je tourne toujours en rond pour recuperer le backup et l'installation du contenu de la clef dans la partition...

 

Il n'y a rien à faire de ce coté là et comme dit précédemment juste une clé USB suffira

 

Même avec mes boitiers Synology il faut bien appuyer sur le bouton marche arrêt pour les démarrer je ne vois donc pas ou est le souci

Share this post


Link to post
Share on other sites

J'avance tout de meme sur mon "fancontrol"

 

J'ai utiliser le boostrap "syno-i686-bootstrap_1.2-7_i686.xsh" pour pouvoir installer les ipkg :

bash, perl, mktemp, lm-sensors

 

Après avoir lancer le "bash pwmconfig" et fait la configuration

 

Je lance un "bash fancontrol" pour vérifier les réglages.

Je ne parviens pas à faire fonctionner la régulation du fancontrol

 

 

Select fan output to configure, or other action:

1) hwmon1/device/pwm1 3) Just quit 5) Show configuration

2) Change INTERVAL 4) Save and quit

select (1-n): 5

 

Common Settings:

INTERVAL=10

 

Settings of hwmon1/device/pwm1:

Depends on hwmon1/device/temp3_input

Controls hwmon1/device/fan1_input

MINTEMP=20

MAXTEMP=100

MINSTART=62

MINSTOP=12

MINPWM=12

MAXPWM=165

 

 

Select fan output to configure, or other action:

1) hwmon1/device/pwm1 3) Just quit 5) Show configuration

2) Change INTERVAL 4) Save and quit

select (1-n): 4

BusyBox v1.16.1 (2015-11-12 18:06:25 CST) multi-call binary.

 

Usage: readlink FILE

 

Display the value of a symlink

 

 

Saving configuration to /etc/fancontrol...

Configuration saved

test> bash fancontrol

Loading configuration from /etc/fancontrol ...

Some mandatory settings missing, please check your config file!

 

Share this post


Link to post
Share on other sites

Pourtant au moment des paramétrages avec pwmconfig, il test bien plusieurs vitesse du ventilo.

Mais je ne parviens pas à figer son etat ...

Share this post


Link to post
Share on other sites

J'avais regardé à cela dans le temps avec mes DS109J et le problème était lié aux sensors et non pas à la commande de vitesse du ventilateur ...

Share this post


Link to post
Share on other sites

Sincèrement je ne sais plus mais le problème avait été le suivant :

Ventilateur bruyant et remplacement par un autre qui ne fonctionnait pas bien car n'ayant pas les mêmes caractéristiques que celui d'origine

 

On trouve des infos ici :

http://www.cachem.fr/synology-changez-ventilateur/

http://www.nas-forum.com/forum/topic/4600-r/

 

Mais finalement j'ai réussi à obtenir gratuitement des nouveaux ventilateurs en remplacement de ceux qui faisaient un bruit épouvantable et donc ...

Share this post


Link to post
Share on other sites

Es ce qu'il y as un moyen de fixer une valeur et non pas de la réguler.

Meme si je dois taper la ligne de commande à chaque allumage ça me gene pas trop dans l'immediat.

Share this post


Link to post
Share on other sites
Sign in to follow this