shrabok

Hardware Recommendation for new build

Recommended Posts

Hello,

 

I am new to the forum, and I wanted to as a few questions after researching the forum for a first time build:

 

I wanted to build a mITX board NAS, and could use some clarification on a few things:

 

1: Is it best practice to install XPEnology on ESXi, or is the only option, can XPEnology be installed on a system without a hypervisor?

 

2: I was looking through the supported hardware information, but there is no recommended hardware requirements that I can find. Is there limits to the system in terms of cpu, memory, drives, network interfaces, power etc?

 

3. I wanted to build a system with 6 Sata3 onboard ports and wanted to configure as follows:

4x 3TB HDD in Raid 10

1x 1TB HDD for Surveillance

1x 128GB SSD for Raid Cache - still unclear if its supported or not from what I can find on the forum, any advice would be appreciated

 

Is raid done in software by XPEnology or do are the disks requiring a raid controller?

 

4. Is there any expected issues with the hardware on this board: GIGABYTE GA-H97N-WIFI

http://www.gigabyte.com/products/produc ... id=5253#sp

 

5. If there are some docs to read before ordering hardware or installation, please let me know.

 

I appreciate any help, thanks!

Share this post


Link to post
Share on other sites
Hello,

 

I am new to the forum, and I wanted to as a few questions after researching the forum for a first time build:

 

I wanted to build a mITX board NAS, and could use some clarification on a few things:

 

1: Is it best practice to install XPEnology on ESXi, or is the only option, can XPEnology be installed on a system without a hypervisor?

 

2: I was looking through the supported hardware information, but there is no recommended hardware requirements that I can find. Is there limits to the system in terms of cpu, memory, drives, network interfaces, power etc?

 

3. I wanted to build a system with 6 Sata3 onboard ports and wanted to configure as follows:

4x 3TB HDD in Raid 10

1x 1TB HDD for Surveillance

1x 128GB SSD for Raid Cache - still unclear if its supported or not from what I can find on the forum, any advice would be appreciated

 

Is raid done in software by XPEnology or do are the disks requiring a raid controller?

 

4. Is there any expected issues with the hardware on this board: GIGABYTE GA-H97N-WIFI

http://www.gigabyte.com/products/produc ... id=5253#sp

 

5. If there are some docs to read before ordering hardware or installation, please let me know.

 

I appreciate any help, thanks!

First of all, welcome!

 

1) You can use ESXi or another hypervisor, or just run bare metal. If you choose to run bare metal, make sure the chipsets are supported by xpenology.

2) Hardware requirements depends of what you want to do with it. A powerfull, but still basic build can be found in my signature.

3) SSD Caching is not supported afaik. Therefore, i should add an extra disk to the Surveillance so you can have redundancy.

4) I have that board too, however, when i tried 16GB RAM it wouldn't boot. Not sure if that is a problem with this one or a general problem.

5) Still busy with this site.. but you can have a look :wink:https://dev.myxpenology.com/tutorials

Share this post


Link to post
Share on other sites

Thanks for the quick reply. The tutorials look great, thanks for all of your hard work!

One other question, I noticed there are no mention of AMD based systems here, is there issues with AMD systems and XPEnology?

Share this post


Link to post
Share on other sites
Thanks for the quick reply. The tutorials look great, thanks for all of your hard work!

One other question, I noticed there are no mention of AMD based systems here, is there issues with AMD systems and XPEnology?

Afaik there are some xpenology AMD build, so it looks like it works.

Share this post


Link to post
Share on other sites

I am currently trying to setup a GA-H97N WiFi ITX system with ESXi 6 and Xpenology. I have successfully installed ESXi and got the Xpenology VM to boot but I am having issues seeing the hard drives. I have posted in a separate thread but will update you if I get a solution.

 

viewtopic.php?f=2&t=10704

Share this post


Link to post
Share on other sites

 

4. Is there any expected issues with the hardware on this board: GIGABYTE GA-H97N-WIFI

http://www.gigabyte.com/products/produc ... id=5253#sp

 

I will answer to this very question alone if you don't mind.

 

I am using (and others too) the GA-H97N Wifi mobo (rev1.0) without any issues. The only apparent difference with the (rev. 1.1) is that the 2nd NIC is an Atheros instead of a Realtek on the (rev. 1.1). You need to check if this is an issue or not but personally I don't think so.

 

The only issue I have experienced with my GA-H97N Wifi is the built in wifi card. The problem is actually not the card itself it's just that Xpenology has not included the wifi drivers yet, thus DSM is not recognising the wifi card but if I am not wrong they are working on it.

 

Example of that mobo being used: http://jarvis.pimpmyrig.com

Share this post


Link to post
Share on other sites