Jump to content
XPEnology Community
  • 0

Please, help me to get my DATA back! (RAID5 fail)



Hello professionals!

I have a DS3615xs running since 2017.

DSM Version 6.1.3-15152 Update 8

The disk configuration is: 5 discs in raid5.


I recently got a problem - my raid crashed.😲 I found a similar situation and a detailed description of what to do. That happy man solved his problem, returned the data and described the whole process in great detail! He described it here. I studied his experience described in that post. I already thought that I was a couple of minutes away from returning the lost data... But something went wrong... Please help.

Let me show you my config:

root@datafield#/etc/space# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [raidF1] 
md2 : active raid5 sda3[0] sde3[5] sdd3[3] sdc3[6]
      11701778176 blocks super 1.2 level 5, 64k chunk, algorithm 2 [5/4] [U_UUU]
md1 : active raid1 sda2[0] sdb2[1] sdc2[2] sdd2[3] sde2[4]
      2097088 blocks [12/5] [UUUUU_______]
md0 : active raid1 sda1[12] sdb1[13] sdc1[2] sdd1[3] sde1[4]
      2490176 blocks [12/3] [__UUU_______]
unused devices: none


So I want to copy my data from Array md2. The problem with this array is that its sdb3 partition has dropped out. It seems to me that all my data is in good condition. 

Because the disk with the sdb3 partition is visible in the system.

Disk /dev/sdb: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 95EDE5F7-DB8A-4767-BEC9-56C8A76DEB09

Device     Start      End		 Sectors  Size  Type
/dev/sdb1     2048    4982527    4980480  2.4G Linux RAID
/dev/sdb2  4982528    9176831    4194304    2G Linux RAID
/dev/sdb3  9437184 5860328351 5850891168  2.7T Linux RAID

I skip my thoughts and move on to accemble the raid procedure:

root@datafield:/etc/space# mdadm --stop /dev/md2
mdadm: Cannot get exclusive access to /dev/md2:Perhaps a running process, mounted filesystem or active volume group?

And this is the first problem.

root@datafield:/etc/space# mdadm --assemble --run /dev/md2 /dev/sda3 /dev/sdb3 /dev/sdc3 /dev/sdd3 /dev/sde3 -v
mdadm: looking for devices for /dev/md2
mdadm: /dev/sda3 is busy - skipping
mdadm: /dev/sdc3 is busy - skipping
mdadm: /dev/sdd3 is busy - skipping
mdadm: /dev/sde3 is busy - skipping
mdadm: Found some drive for an array that is already active: /dev/md2
mdadm: giving up.


Then I looked at what is mounted on the system from raids

root@datafield:~# mount | grep md
/dev/md0 on / type ext4 (rw,relatime,journal_checksum,barrier,data=ordered)

Help please, can anyone come across a similar situation?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0



Some of what you are reporting doesn't make sense.  Maybe you have tried some recovery activity from the thread?  The thread you cited is a pretty catastrophic failure recovery with multiple bad drives, and the procedures in it circumvent the protections inherent to the md system.


Also, this post is in the Q&A session and you really need much more than a simple, single post response.


Please repost in a support forum like The Noob Lounge or Post-Installation Questions as this will take many post iterations.


And, use the first few posts in this example thread, to help you with data gathering that will be needed to determine if your data still exists in a recoverable form.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...