Docker HW Transcoding Help


Recommended Posts

I can get hw transcoding to work for plex in docker but to make it work I have to run plex from package center first or /dev/dri/ is empty. Rebooting (manually or from losing power) results in no /dev/dri/ being empty again and I have to stop docker plex and run package center plex then stop it and start docker plex for hw transcoding to start working again in docker.  /dev/dri/ also magically goes empty after a few days even if there's no power loss.  


Currently I have some scheduled scripts that run at 5am that stops docker plex, installs package center plex, stops package center plex, then starts docker plex to ensure hw transcoding will be available at least daily if there's a power loss or something that happens without me being aware of it.

 

I know, it's all weird and confusing but my question is if there's another way to get /dev/dri/ to populate without having to run package center plex.  Also, because of the default unchangeable port number of plex I can't have both plex's running.

Link to post
Share on other sites
1 hour ago, toyanucci said:

Also, because of the default unchangeable port number of plex I can't have both plex's running.


don’t know the answer to you main question. I’ve not seen that happen on my setup (docker).
However you should be able to run both package centre and docker Plex together. Just expose a different port I.e 32401 mapped to the 32400 port in the container . (Bridge networking) in docker 

 

Link to post
Share on other sites
2 часа назад, toyanucci сказал:

I can get hw transcoding to work for plex in docker but to make it work I have to run plex from package center first or /dev/dri/ is empty. Rebooting (manually or from losing power) results in no /dev/dri/ being empty again and I have to stop docker plex and run package center plex then stop it and start docker plex for hw transcoding to start working again in docker.  /dev/dri/ also magically goes empty after a few days even if there's no power loss.  


Currently I have some scheduled scripts that run at 5am that stops docker plex, installs package center plex, stops package center plex, then starts docker plex to ensure hw transcoding will be available at least daily if there's a power loss or something that happens without me being aware of it.

 

I know, it's all weird and confusing but my question is if there's another way to get /dev/dri/ to populate without having to run package center plex.  Also, because of the default unchangeable port number of plex I can't have both plex's running.

 

 

docker run -d \
--name=PlexMediaServer \
--net=host \
--device=/dev/dri:/dev/dri \
-e PLEX_UID=USER_ID \
-e PLEX_GID=100 \
-e TZ=Europe/Moscow \
-v /volume1/docker/plex/database:/config \
-v /volume1/docker/plex/transcode:/transcode \
-v /volume1/Video:/Video \
plexinc/pms-docker

where USER_ID - your's ID

 

and in task scheduler every boot from root user

chmod 777 /dev/dri/* 

 

Edited by Amoureux
  • Thanks 1
Link to post
Share on other sites
12 minutes ago, Amoureux said:

 

 



docker run -d \
--name=PlexMediaServer \
--net=host \
--device=/dev/dri:/dev/dri \
-e PLEX_UID=USER_ID \
-e PLEX_GID=100 \
-e TZ=Europe/Moscow \
-v /volume1/docker/plex/database:/config \
-v /volume1/docker/plex/transcode:/transcode \
-v /volume1/Video:/Video \
plexinc/pms-docker

where USER_ID - your's ID

 

and in task scheduler every boot from root user



chmod 777 /dev/dri/* 

 

docker run -d \

--name=plex \

--net=host \

-e PUID=1026 \

-e PGID=100 \

-e TZ=America/Chicago \

-e VERSION=latest \

-v /volume1/docker/plex/config:/config \

-v /volume1/docker/multimedia:/Multimedia \

--restart unless-stopped \

--device=/dev/dri:/dev/dri \

linuxserver/plex:latest

 

That's what I used to create the docker plex.  The issue is at boot nothing is in /dev/dri/ unless I run run native plex first.
 

Edited by toyanucci
Link to post
Share on other sites
2 минуты назад, toyanucci сказал:

 

That's what I used to create the docker plex.  The issue is at boot nothing is in /dev/dri/ unless I run run native plex first.
 

 

you have a native transcoding from Synology? (original serial numbers and mac)

 

Link to post
Share on other sites
3 minutes ago, Amoureux said:

 

you have a native transcoding from Synology? (original serial numbers and mac)

 

I do but it's like if a native app doesn't attempt to use it it's not enabled so docker can't access it until it is.

Link to post
Share on other sites
21 минуту назад, toyanucci сказал:

I do but it's like if a native app doesn't attempt to use it it's not enabled so docker can't access it until it is.

it's not right.

I have a Plex in Docker. And all works well.

 

Снимок экрана 2021-09-24 в 09.17.32.png

Edited by Amoureux
  • Thanks 1
Link to post
Share on other sites
9 minutes ago, Amoureux said:

it's not right.

I have a Plex in Docker. And all works well.

 

Снимок экрана 2021-09-24 в 09.17.32.png

Just restarted and checked and /dev/dri/ is populated...maybe it's a permission thing as you said.

 

about to try what you said:

 

chmod 777 /dev/dri/* 

 

So that fixed it!!  I am so thankful as this has been a MAJOR annoyance for many months.  I didn't want to bother anyone with the problem but so glad I finally just asked.

 

Thank you so much for you help!!  I can finally stop running those daily scripts lol.

Edited by toyanucci
update
Link to post
Share on other sites
3 hours ago, toyanucci said:

chmod 777 /dev/dri/* 

 

Ok Forgot to say I do run a script on boot , (I use chmod 666 /dev/dri/*)  :)

Strange you were having issues where it was reverting , without rebooting, unless native plex changes permission 

Link to post
Share on other sites
3 hours ago, scoobdriver said:

 

Ok Forgot to say I do run a script on boot , (I use chmod 666 /dev/dri/*)  :)

Strange you were having issues where it was reverting , without rebooting, unless native plex changes permission 

Man it was weird! After 3 to 4 day's it would stop working...Thinking about it now maybe that coincided with when watchtower updated plex 🤔

 

And yes, maybe native plex sets the permission during setup as well which is why docker plex would work afterwards.

Edited by toyanucci
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.