• 0

SMB (Samba) writting speed on 6.2.x


Question

Dear Xpenology user!

 

I'm use to upgrade every about 3years my Xpneolgy NAS. 

I've first own a N40L and now I own a J3455-ITX board (bios 1.8 (last) with an additionnal sata card 

 

I'm actually doing many test before  migrating my DS916+  DSM6.1.7 to 6.2 branch (6 SATA HDD)

 

Best results I can get is with 6.2.2 DS918+ (dev/dri present and activation.conf populate)

 

But:

 

before migrating I've tested fresh install 6.1.7 with 1.02b bootloader on a formated HDD and I can get a writting of 4 Go in about 1min 15 on samba (sounds correct)

 

On any 6.2.x version in same condition I can only obain 4Go in 7 to 10min... 

 

(reading from nas to my computer is 110Mo/s so few seconds)

 

I've tried different extra modules, samba version no chance. changing sata port of my HDD in the NAS have no effect

When I do CPU test or copy speed, results are all good and close in both 6.1.7 or 6.2.x branch

 

Could help me on the issue with SAMBA slow transfert WIN10 to NAS please? What should I test, or SSH command to diagnosis better? 

 

Thanks for you help!

 

 

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Dear 

I found a solution. smb and cpu speed are now good with lastest xpenology 

 

buy an intel NIC card pcie 2.0 + a M.2 adaptator key E (or E+A) to PCIE

use bios version 1.3 (to downgrade use afudos and command " afudos APLITX1.30 /X /B /P /N "

in bios disable C1E,enable speedstep, v-t and wlan + blutooth, disable other (soundcard, nic card...)

512mb for integrated video card

use 1.04b loader + extra 0.13.3 from IGG "extra918plus_v0.13.3.zip"

 

in grub file change vid pid and change to 2 netif line

add 2 mac address and SN

 

change this line by:

set common_args_918='syno_hdd_powerup_seq=1 HddHotplug=0 syno_hw_version=DS918+ vender_format_version=2 console=ttyS0,115200n8 withefi elevator=elevator quiet syno_hdd_detect=0 syno_port_thaw=1 video=eDP:d video=DP-1:d video=HDMI-A-1:d video=HDMI-A-2 :d'

 

install 6.2.3 (DSM_DS918+_25426)  without any monitor pluged in

 

be patient during first start and during installation (update 3 will automaticaly be installed... it tooks about 45min

 

HW works good under video station and plex (plex pass)  ( ls /dev/dri/ shows card0  renderD128


cat /usr/syno/etc/codec/activation.conf give results after a first reading on video station

{"success":true,"activated_codec":["hevc_dec","h264_dec","h264_enc","aac_dec","a                                                                                                             ac_enc","vc1_dec","vc1_enc","mpeg4part2_dec","ac3_dec","mpeg4part2_enc"],"token"  :"...

 

sudo dmidecode -t processor | grep Speed
give good info:
        Max Speed: 2416 MHz
        Current Speed: 1500 MHz

 

ls /usr/lib/firmware/i915/ give me:
bxt_dmc_ver1_07.bin  kbl_dmc_ver1_01.bin  skl_dmc_ver1_27.bin
cnl_dmc_ver1_06.bin  kbl_dmc_ver1_04.bin
glk_dmc_ver1_04.bin  skl_dmc_ver1_26.bin
 

only one error remains but seems to be not an issue:

 dmesg |grep -i error
[  169.555144] [drm] parse error at position 5 in video mode 'HDMI-A-2'

 

i hope it will help somone, because those test took me several evening to archive this result!

Link to post
Share on other sites
  • 0

Dear all

 

afterfurther test, SMB performance are still too bad to use DS918+ pat file.

So as now I have intel nic card I use 1.03b and DS3617xs pat file. performance are very good, but dev/dri do not show anything so I don't have HW transcoding (never used anyway before)

 

I've used during last test extra 0.11.2.test but i have me warning message (DSM can't repair it self) on clean install so before migrating I'm reinstalling for test a 1.03 without additionnal extra (stock 1.03b)

 

I will come back in few hours or days to inform you how it works

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.