Headless, Baremetal, N54L install


Recommended Posts

Hi all, I have an N54L (no hardware changes) running Trantor's DSM 5.0-4418. It has been solid for for about 7 years. 

 

I want to use software which isn't compatible with that version. So want to upgrade to the latest compatible version - which can be installed headless (I don't have any VGA monitors easily available).

 

I have tried lots of Jun's loaders (inc. some modded ones) - 1.03b DS3615xs, v1.03b DS3617xs, v1.04b DS918+, v1.02b DS3615xs, v1.02b DS3615xs with MBR partition. I have tried booting with a hard drive installed and without. The server never shows in Synology Assistant (on my router it isn't listed as a connected device). The network light on the front of the device does show activity.

 

When I put my DSM 5.0-4418 USB drive and and my 4 hard drives back in it boots up to my old system fine (so I assume USB is set as boot?).

 

Reading on the forums I found this thread (and quite a few others) - https://xpenology.com/forum/topic/33207-hp-microserver-n54l3615xs-complete-rebuild-advice-request/

 

 

Key bit:

Quote

@captainmidnight After editing and creating the v1.02b USB boot loader, the N54L appears to boot through the loader and sits at the screen as per the tutorial but is completely invisible on the network - it's not even trying to pickup a DHCP lease.

 

Quote

@billat29 Ah! C1E needs to be disabled in the BIOS.


Now as I am running headless I can't connect a keyboard to access the bios and disable C1E.

 

  1. Is there an older version that I can install without disabling C1E?
  2. Can that version then be upgraded to one of the later ones? (checking the forum 6.1.7 looks like a good stable version - it does things like hibernate the drives).

 

Thanks.

Link to post
Share on other sites

If you follow the tutorials for N54L floating around there. It works as baremetal just plug and play.

 

Latest DS3615xs 1.03b jun's loader do the job perfectly well.

 

You must have the right modded bios to configure it (C1E disabled)

 

And you must set PID and VID inside the grub.cfg to match your USB key.

 

No need to re-eplain it again... everything needed is already explained.

 

Mine is rock stable :

image.thumb.png.482542386fe8c55c4ac45272630f1ca7.png

 

I have a PCI-e network card but it is not really needed with 6.2.3. Not needed anymore.

It may be needed for next loaders, I did not check it yet.

 

You won't acheive anything without screen and keyboard...

Edited by Orphée
Link to post
Share on other sites

I am going to send you here:

Out of the loaders you have tried, the 1.03b DS3615xs and the v1.02b DS3615xs loaders are compatible - if you disable C1E. As you haven't the box doesn't appear on the network,

 

The v1.01 loader might, might not require it. (It's been a long time. I can't remember). You could follow the link in the above to try to install 6.0.3 which is the version it would allow. You could try to create a loader, see if it boots and the box appears on the network.

 

If not you will have to pull the box out and attach KBD and monitor.

 

 

  • Thanks 1
Link to post
Share on other sites
19 minutes ago, Orphée said:

(C1E disabled)

 

You won't acheive anything without screen and keyboard...

 

Ok thanks, looks like I am stuck on DSM 5.0-4418 as I don't have a compatible monitor/adapter at the moment.

Link to post
Share on other sites

@billat29 thank you (I have read lots of your other posts about HP MicroServers and they have been really helpful).

 

I will try v1.01 (it's one of the few I haven't tried :)).

 

If it fails I will have to try and source a VGA monitor/adaptor disable C1E then go with 1.03b DS3615xs / v1.02b DS3615xs loaders.

Link to post
Share on other sites
Posted (edited)

Thanks @Orphée, I will check the forums.

 

I have a friend who has an old VGA monitor which I should receive in a few days. I will try again then.

 

For now I'll revert to my functioning DSM 5 and rest, I've been trying to make this work for days, numerous USB sticks, loaders, formatting USB flash drives... 😣

 

EDIT

@billat29 - unfortunately no luck with v1.01 - Syno Assistant doesn't find anything (and router doesn't see the box).

Edited by Quizzer16
Link to post
Share on other sites
1 hour ago, Orphée said:

Be prepared to flash/update the BIOS with modded FW can't remember which one exactly.

It works with stock BIOS. However, if you want to put a 5th HDD in, then you need it

 

54 minutes ago, Quizzer16 said:

For now I'll revert to my functioning DSM 5 and rest, I've been trying to make this work for days, numerous USB sticks, loaders, formatting USB flash drives... 

I'm with you on that. Sometimes you just need to walk away. Beer often helps.

Link to post
Share on other sites

Got a hold of a VGA monitor. Disabled C1E. With v1.02 loader. Syno Assistant finds it.

 

Is there any advantage of using 6.17 over 6.23, I read this but may be out of date:

 

Quote

 

If you stay with DSM 6.1.x, it's more of a "plug and play", no need for extra drivers and to me it feels more "bullet-proof"  

as I think it will only get security updates and no bigger changes, due to the age.

 

 

If 6.23 is now equally 'bullet-proof' I will go with v1.03 loader and DSM_DS3615xs_25426.pat.

 

On 8/30/2021 at 3:58 PM, billat29 said:

Beer often helps.

 

Beer may have been the problem - on the first day I tried for hours. And at the end of the night I realised I had the VID and PID the wrong way round - had to retry everything. Pain! :) 

Link to post
Share on other sites

The first quote IS out of date. It refers to 6.2.2 not 6.2.3. (After 6.1.7, Synology made changes which meant the onboard nic no longer worked, so we were all playing around with extra drivers or buying a supported nic but then they put it all back to the way it was in 6.2.3 so it worked again).

 

Either release is good. I was happy on 6.1.7 for a long time and then got bored one day and did the upgrade. I am happy with 6.2.3.

 

You haven't said how you plan to get there from where you are. I would build a new system and migrate the data if at all possible. I can't say whether an inplace upgrade from 5.0 all the way to 6.1.7 or 6.2.3 would work, but the following is relevant to all systems that had DSM5 previously installed.

 

Link to post
Share on other sites

Hi @billat29 thanks again. 
 

Yes I’m going for a fresh install. All my data is copied to other devices/drives. 
 

My plan is an as new v1.03b, DS3615xs and 6.2.3 installation.
 

I’ll trial it with some dummy data for a week or so for stability. And make sure I can get all the services and software I need working. If I’m happy I’ll copy the data across. 
 

@Dfdsthanks - really useful. I think I’ll upgrade the bios whilst I’m under the hood as one day I may stick a 5th drive in. 

Edited by Quizzer16
Link to post
Share on other sites
  • 2 weeks later...

Well this thread gives me hope. :)
I just got a new (to me) N54L and I can't get it to boot from the USB. I have a N40L too and it runs perfectly.

The N50L will boot stuff like a freeDOS BIOS update (TheBay) just not the boot loader. Drives me mad.

 

Could it be that it doesn't like the USB stick? It's a 16GB USB3 Kingston Datatraveler. Should I try to find an older USB2 stick?

Link to post
Share on other sites
23 minutes ago, KmanSweden said:

Yes, I did disable c1e.
Haven't tried the N40L stick.. Since the MAC is wrong I never thought of that. Thanks I'll try it out tonight.

The other thing is that if you absolutely know without going into the BIOS that the N40 has c1e disabled, then you could try boot that from the new stick after pulling the drives.

But I would strongly advise not messing with the old box in case you find you are trying to diagnose why two boxes won't boot.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.