• 0

Poor plex transcoding performance


Go to solution Solved by premikkoci,

Question

Getting some 4k content, and noticing that when set to 1080p high, it has to stop and buffer contantly.

Task manager indicates ~60-80% cpu usage.

HW transcoding is enabled in plex.

Running:

baremetal
- i3 9100
- asrock rack c246 wsi
- 6.2.3 U3 w/ Jun's 1.4b - DS918+ and driver extension

Plex seems to indicate transcoding is taking place on hardware
image.png.d2fae8a60c1a552c66f1c8b25e2b9585.png


and cd/dev/dri ls indicates card0 + renderD128 present in the folder

Turning off hw acceleration + transcoding in plex yields no change in performance or CPU usage.

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
  • Solution

Probably caused by HDR tone mapping. Native PMS on Synology does not have necessary drivers to do HDR tone mapping using GPU and so video transcoding is done by GPU and tone mapping by CPU. To utilize GPU for both video transcoding and HDR tone mapping, You need to use docker linuxserver.io PMS version which have all drivers.

 

So first try to turn off hdr tonemapping in PMS settings to make sure that the problem still occurs.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.