HHawk

Web Station Service couldn't be started?

Recommended Posts

Hi guys,

 

Unfortunately, I read the warning post a bit late. :S

 

I was still on 5.2-5592 and decided to update my NAS (should have postponed it, I know).

 

First I downloaded the DS3615xs 5.2-5644.1 x64 image and wrote it on my USB stick.

After that I booted up my NAS and installed first: DSM 5.2-5644 (28.10.15)

Installation went fine and after a few reboots it was up.

 

Then I downloaded: DSM 5.2-5644 Update-1

Installation went fine and after a few reboot it also came up.

 

However the only and main issue I have are:

 

1. I get the message "Web Station Service" cannot be started.

2. I cannot connect to my NAS through Windows / SMB.

 

I already tried disabling and enabling Windows File Service and Windows Network Detection, but no luck.

 

Any ideas or solution. Oh and it's not possible to downgrade to vanilla DSM 5.2-5644 (28.10.15), right?

 

Sorry for my ignorance. This normally doesn't happen to me. :S

 

Thank you in advance.

 

Note to myself: shouldn't have done this with a headache.

 

//edit

 

By the way; I can get the "Web Station Service" started again when I disable it and enable it, HOWEVER after a reboot it's the same problem again.

...this doesn't work for SMB / Windows File Sharing.

Share this post


Link to post
Share on other sites

I had a similar problem but not after upgrading. Server was cut off from the outside world, not accepting connections, numerous error messages when trying to connect to it, although console access was fine (via hard-wired connection). After much head scratching I noticed that the network cable was ever so slightly hanging out of the port on the switch....

 

Pushed it home, all OK.

 

I know it's basic, but have you checked all connections?

Share this post


Link to post
Share on other sites

Thanks for replying djf.

 

I checked the cables, but while doing so, I thought that it couldn't be the problem, because I can connect to DSM interface. :S

But I checked the cables, it isn't the problem. :sad:

 

I noticed another issue; I cannot connect to SSH, unless I disable and re-enable SSH-service. Than it works. Sigh.

...I wish I didn't run this stupid update, or read the warning post earlier. :sad:

 

Anyone else has an idea? Downgrading isn't possible I presume?

 

//another update

 

Noticed something else... In DSM's 'Infocenter' the following are set to 'minus' (if I hover it, it says 'error'):

 

- FTP

- SFTP

- Windows-fileservice

- NFS-service

 

I double click them to enable them (and save them) but when I run "test" it keeps saying 'Busy with testing'.

Share this post


Link to post
Share on other sites

Bleh... Think I now totally fooked up.

 

I changed the VERSION file, to the old version, then ran DSM 5.2-5644 (28.10.15) update and rebooted, but now I can't access anything anymore. No DSM, no SSH, no nothing.

 

Great.

 

//edit

 

Nevermind the above, I can access DSM again (after several reboots). And it says "DSM 5.2-5644" (not 1).

Anyways, still that Web Station message and NFS, SAMBA aren't working.

 

If anyone has an idea, let me know. I am going to sleep. Thank you in advance.

 

//small update

 

Well apparently I can play movies from my Kodi machine from my NAS through NFS.

But SAMBA isn't working, nor is Web Station.

Share this post


Link to post
Share on other sites

I checked the logs, as far as I can with my limited knowledge and found this.

 

Dec 7 13:32:24 DiskStation S99zbootok.sh: Error! synoservices start timeout! (service [ "webstation" ] failed on bootup. service [ "cups-lpd" "nfsd" "synomount" "synovfsd" "pgsql" "avahi" "ssh-shell" "httpd-sys" "httpd-avahi" "sftp" "findhost" "ntpd-client" "synoindexd" "snmp" "httpd-user" "ftpd" "synosnmpcd" "nmbd" "samba" ] not ready. )

 

Don't know if it's useful. Also I am wondering if this even related to the update?

Share this post


Link to post
Share on other sites

I have a small feeling that the configs are messed up.

What you could do is the following:

- create a vm with xpenology 5.2-5644

- backup configs with fresh installed VM

- login in to the 'broken' dsm via ssh

- do a diff between the configs and correct them if necessary

- reboot

Share this post


Link to post
Share on other sites

Thanks brantje for taking the time to answer.

 

Yeah, I am starting to think this wasn't caused by the update. Apparently you think the same, I guess.

So if I create a VM with xpenology, what config files do I need to check? Though I have been using xponology for 2+ years, I never had to do this before. So not experienced with it.

Share this post


Link to post
Share on other sites

Well since I hardly received answers (except for brantje) I decided to go in kamikaze style!

 

Downgraded again, but this time from 5644 back to 5022.

Changed VERSION, then rebooted, did install/upgreage and and ran 5022 upgrade.

 

Rebooted. Samba not working, but apparently this is normal. Enabled it and noticed straight away that everything else was working also again. Even after reboots.

Will run the other upgrades now in series, skipping the patch versions (hopefully). And after I am done I hope that everything works as it should.

 

//update 1

 

Currently updating to DSM 5.2-5592 Patch 3, so far so good, no more problems at all!

Will report back in a little when I am done with the last one.

 

//update 2

 

Well the problem is, at least in my case (and 100% sure about it), DSM_DS3615xs_5644(28.10.2015).pat.

I flashed my USB stick with the XPEnoboot_DS3615xs_5.2-5644.1.img, selected install/upgrade and ran the update through Synology Assistent. Rebooted and I already noticed it was slower than normal (I can tell after running all the updates and patches). It took (for example) 3 more minutes to get into DSM. Though Web Station is still working now, I do have other problems, like: disabled FTP, SFTP, Windows File Service, NFS-service and SSH.

 

I will reboot a few times and see what happens, but I think I will re-downgrade to DSM 5.2-5592 (latest patch) as that version didn't cause any problems at all.

 

/update 3

 

Downgraded back to DSM 5.2-5592 and installed patches. No more problems. Will stay at this version until problems are solved.

 

Case closed.

Share this post


Link to post
Share on other sites

Thank You!

I went from 5644 back to 5022 via downgrade.

 

It couldnt see my drives when i rebooted to 5022 , but I just went up to 5592 Patch 0 and the drives were there again.!

That was TENSE.

 

Im now patching up 5592 and am going to leave it. Web Services are all working again, so brilliant article Hawk, I would not have done it with out you!

 

UPDATE - I got to 5592 patch 2, autorebooted and now its not being detected on the network. more tinkering to be done.

UPDATE 2 - DSM 5.2-5592 Patch 2 has a network problem, fix here (top post - viewtopic.php?f=2&t=6247&start=10)

- DSM 5.2-5592 Patch 3 has cause the web services problem all over again for me.

 

UPDATE 3 - Pat 3 web services problem Fixed by restoring previous backup, but only selecting Web Services.

 

Im staying at Patch 3 for now.

 

UPDATE 4 - 20150216 - I have to restore the Web Services config as above after every reboot it seems now.

Share this post


Link to post
Share on other sites

Having recently encountered this problem I am pretty sure it has nothing to do with the version being used.

 

I have two boxes both running 5.2-5644-5, one has the problem, the other does not.

 

As people have pointed out the issue is some of the services not starting on boot. This causes a long delay in the boot time and can easily be identified by running "/usr/syno/etc/rc.d/S99zbootok.sh start" which reports services it is waiting on. In my case "service [ "synoindexd" "ntpd-server" "pgsql" "snmp" "synosnmpcd" "findhost" "synovfsd" ] not ready."

 

The kicker is you can manually start the offending services using "start ". Just be aware that some services, like findhostd are reported as findhost.

 

Further investigating shows S99zbootok.sh script uses "synoservicecfg" to determine the status of the services.

 

Using this command "synoservicecfg --status findhost" shows that the status for the problem services is "error" (not sure if the is the cause or symptom):

 

service [findhost] status=[error]

required upstart job:

[findhostd] is stop.

=======================================

 

Checking the logs for those services shows no reported errors while running "synoservicecfg --start " will start the offending service (just like "start "). Unfortunately the situation will be repeated if the system is rebooted.

 

Checking the "/var/run/synoservice/restart" directory shows files being created that are obviously designed to control the restart process. In my case the offending process files have a zero length which probably explains why the services are not being automatically restarted.

 

Still more to do on this…….

Share this post


Link to post
Share on other sites

Discovered that the blocked services are never receiving the network ready event and are blocking waiting on it.

 

You can manualy release them by using the command "/sbin/initctl emit --no-wait syno.network.ready".

 

This command is normaly sent by "/etc/init/syno-network-check.conf" when it is processed by the upstart boot process.

 

I'm using a fixed IP address which may be part of the problem - need to do more testing.....

Share this post


Link to post
Share on other sites

@disneysw : Thank you very much for your work.

Although I can not find the reason for this not starting services, but with your help I can gett access to my server if needed.

 

I wonder why there is a difference in accessing the server through wlan than through wired network. Synology assistant says "no connection" using wlan. The same laptop connected through wire it works fine.

 

(bare metal N54L running Xpenology DSM 5.2-5644 Update 8)

Share this post


Link to post
Share on other sites