Sign in to follow this  
b0fh

[SOLVED-ish] Installing on ESXi 6.0

Recommended Posts

I built a new Xpenology box in a VM last night for testing purposes and have an issue I had hoped to solve.

 

During the initial install, everything went find booting the vmdk. I installed the OS but it defaulted to using the vmdk that was the boot image and overwrote it such that the machine would not boot again. I replaced the vmdk and it booted fine. However, it still shows the 24mb vmdk file as a valid hard drive in the gui. Am I missing something somewhere? I attached the hardware as indicated (LSI controller with 7 16gb vmdks attached, boot vmdk on IDE bus).

 

After replacing the VMDK, I expected it to complain at the system OS was degraded, but luckily it did not. I tried a quick search on the board and did not find anything. Has anyone else ran into this? I am running the 5592 builds of DSM (currently up to Update 4) and I am running a completely up to date ESXi 6.0 install. Thanks in advance!

Edited by Guest

Share this post


Link to post
Share on other sites

Ok, so I found some hints here on the board via google. So for now I have updated the ISO file cfg file and am booting off that by adding:

 

bios.bootOrder = "cdrom,hdd,floppy"

 

to the vmx file. It seems to be working for now.

Share this post


Link to post
Share on other sites
Ok, so I found some hints here on the board via google. So for now I have updated the ISO file cfg file and am booting off that by adding:

 

bios.bootOrder = "cdrom,hdd,floppy"

 

to the vmx file. It seems to be working for now.

I haven't had any issues on ESXi 6. Here's how I did it if you are interested.

In case you struggle with the image to be overwritten you may set it to be read-only in the HDD settings of the VM.

Share this post


Link to post
Share on other sites

@NeoID - I pretty much followed your guide, I just could not get the VM to quit seeing the boot drive as a hard drive. I could not find a setting to make the vmdk read only. By using the ISO, I got around both issues. I forgot I had a license for UltraISO from WAY back that still works, so I was able to use that to update the cfg file. All is good now I think.

Share this post


Link to post
Share on other sites
@NeoID - I pretty much followed your guide, I just could not get the VM to quit seeing the boot drive as a hard drive. I could not find a setting to make the vmdk read only. By using the ISO, I got around both issues. I forgot I had a license for UltraISO from WAY back that still works, so I was able to use that to update the cfg file. All is good now I think.

 

Adding rmmod=ata_piix removed the boot image from my list of drives. Just make sure to add the boot drive as a IDE drive.

"This will disable IDE devices and prevent the boot image from taking up one HDD slot in DSM."

 

The alternative is to make the boot image read-only. Power down your VM and select this "Nonepersistant":

vZkOeSX.png

Share this post


Link to post
Share on other sites

Yeah, that can be done and is functional, but then you still have a funky disk with a partial OS installed on it while running. The rmmod take might work as well, but is that something that must be reran after each XPEnology update? This is really only a test XPEnology install for testing updates for functionality (iSCSI, etc.) rather than a production system. Thanks!

Share this post


Link to post
Share on other sites
Sign in to follow this