System only lets me recover. How to force manual install?


Recommended Posts

Greetings. I've had my XPEnology system running for several years. But after we had a power outage that shut off the server unexpectedly I've been unable to get back into it. 

 

I created a new install USB following the instructions from the FAQ. Just like I've done in the past. I edit the grub.cfg, add the Extra and Extra2.lzma files to the disk image, and burn it to a USB.

I reboot the computer and use find.synology.com to see the DS918+ with DSM 6.2-23739 on the network and connects to it. It says the current status is 'Recoverable'.

I connect and when the loader appears in the web browser I only get a [Recover] button. Not [Install] or [Migration]

 

Because I only get one choice I choose it. It says it's repairing/installing the system for about 2 seconds and then goes into the '10 second reboot' countdown. Watching the monitor output the system reboots and gets all the way back around to 'blind mode' which leads me to believe the bootloader is working correctly. But the system never comes back online. The ethernet port lights are lit and the router can see the system by name in the IP list. But it's not discoverable. 

 

I have tried making install USBs with the loaders for the DS3615 and DS3617 but those systems never become discoverable by find.synology.com.

 

I can burn the DS918 img onto the USB again and upon rebooting will be presented with the same Synology screen that only lets me choose to Recover a DSM that I know will not boot or be recovered. 

 

Advice? How do you force a new DSM install when the loader wants to recover an existing system? And will installing a new copy force me to wipe my drives?

 

I'm running 
Gigabyte GA-B85M-D3H

4th Gen Haswell Board
Realtek RTL8111F-VL

 

Thank you.

Edited by Mookinato
added information.
Link to post
Share on other sites
Posted (edited)

Update: I diagnosed the problem to a bricked BIOS.

 

I replaced the Motherboard with a Gigabyte B365M DS3H Motherboard with an i3-9100 chip and Realtek 8118 LAN. 8Gb Ram

I recreated the synoboot USB and updated the MAC address on the CFG file.

Booted up and it allowed me to install DSM_DS918+_23739.pat.

it then rebooted and asked me to recover my old array for the new install

one last reboot and it ... never comes back up. 

 

"screen will stop updating shortly" message appears on the video monitor. But find.synology.com cannot find the server. I can see the IP address in my router, so it's connected to the network but not running the web interface.

 

Just going to let it keep fired up. If it's running some kind of disk check rebooting it will never allow it to finish. 

Edited by Mookinato
added information.
Link to post
Share on other sites

additional info: Configurations i've tried


Synoboot_918+_1.03a2

Synoboot_918+1.04b
Synoboot_918+_1.04b+Xtra

DSM 918+ 6.2.1 23824

DSM 918+ 6.2.0 23739

 

if it were a network card drivers issue, would I be able to install and recover the system, and then have it not connect after reboot?

 

That's as far as I've gotten. I can recreate the USB stick over and over. It'll ask to install the latest DSM.PAT and once it reboots it's not longer discoverable on the network. 

Link to post
Share on other sites

1st: I choose to reinstall the DSM.pat 

2nd: I choose the 6.2.1.pat that is listed as the proper DSM for 1.04b. 

3rd: The machine reboots and I'm presented with the option to Recover my settings. Which I know will end in a server that can not been seen by the network. 

 

Why can I not create a new account? It looks all my data is still on the system. I simply cannot find an option that lets me reinstall the user settings. 

 

Thank you

Screen Shot 2021-08-01 at 4.15.04 PM.png

Screen Shot 2021-08-01 at 4.15.26 PM.png

Screen Shot 2021-08-01 at 4.21.13 PM.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.