• 0

DSM asks for migration or re-installation after modifying grub.cfg and synoinfo.conf


Question

OS: ESXi 6.7 update 3

Machine: Lenovo TS140

DSM Bootloader: jun's 1.04b

DSM Ver: 6.2.3-25426 update 3 for DS918+

 

My DSM has 5 internal hard drive on SATA controller passthrough from esxi host, also has 7 USB portable hard drives passthrough from esxi host. Before making the change, the settings are as below and worked pretty good:

1. grub.cfg:
DiskIdxMap=1800 (18 in hex equals 24 in decimal, this is to hide the VM disk in DSM)
SataPortMap=66 (as per my knowledge, first 6 tells DSM there're 6 disks on SATA 1; 2nd 6 tells DSM there're 6 disks on SATA 2. In my VM DSM, only one VM boot disk on SATA1 and 5 internal disks on SATA2, the passthrough SATA controller from esxi host. So although 6 is more than actual number of disks, it still works fine)

2. synoinfo.conf:
usbportcfg=0xf000000
internalportcfg=0xffffff
maxdisks=24

 

Today, I am planning to add additional 12 external portable hard drives via adding additional USB hubs. My current setting has a max number of 24 for disk ports, two SATAs occupy 16 ports, existing 7 usb drive occupy 7 ports, there's only one left. Since I need to add 12 drives, I need at least 11 additional ports. Considering the minimal hex number more than 11 in decimal is 0x10 (i.e., 16 in decimal), I decided to add 16 additional ports, that being said, I need to change the max number of disks to 40. So here are the changes I made:

1. grub.cfg:
DiskIdxMap=2800 (28 in hex equals 40 in decimal, so I expect this number can still hide the VM disk in DSM after change max number to 40)
SataPortMap=15 (made this change to reflect actual number of disk on two SATA in DSM, 1 VM disk on SATA1, 5 on SATA 2, the passthrough SATA controller from exsi host)

2. synoinfo.conf:
usbportcfg=0xf0000000000 (added four 0s in the end)
internalportcfg=0xffffffffff (added four f in the end)
maxdisks=40 (changed from 24 to 40)

After the changes, I just reboot the DSM VM. When trying to login to DSM web UI, it shows migration screen and asks to either migration or reinstall. I had to download the DSM 6.2.3-25426, then tried both migration and reinstall, but both failed.

Not sure what to do next. Any help will be highly appreciated. Thanks in advance.

Edited by oldcotton
Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I was able to recover my setup without installing DSM. I made a copy of the DSM VM before the changed. I just restored it with the backup.

 

Read anther thread, it seems there's a limit of 26 drives. That being said, it will have issues if you have more than 26 drives:

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.