RedPill - the new loader for 6.2.4 - Discussion


Recommended Posts

Quote

If you're running QEmu-based virtualization (e.g. Proxmox or VirtualBox) set vid to 0x46f4 and pid to 0x0001

Does anyone know , is this the same for ESXi  (I the converted the resulting  .img to .VMDK , and add it as an existing HDD at SATA 0:0 ) 

Link to post
Share on other sites

Hi,

I'm trying to compile the bootloader for DS3615, I've created the redpill.ko and put on the specific folder with the correct name.

But when I execute the bootloader creation I've received the following error, error about keys_unsorted....

 

Do you know how could I fix the problem?

thank you in advance

 

image.thumb.png.2053152b838b0ec8f0fe89567399775a.png

Link to post
Share on other sites

I have made some tests.

 

- Get a Backup of my 2 Drives from DSM 6.2.3-25426 junLoader Machine.

- Make a redpill loader for 6.2.4 and create a new machine (proxmox)

- attach the backup hdds to the new machine and startup

- It comes the assistant and i update to 6.2.4

- WORKS

 

- After that i build the redpill loader for DSM7 and replaced the 6.2.4 in the new machine and startup

- it will hang forever at "------------bootup-smallupdate"

- So i patched out this part from linuxrc.syno.impl and startup again

- Now it works an the DSM7 Migration Assistant starts

- Migrate all Packages include Moments to Photos

- Reboot the whole thing... and it works

 

i will test now a straight upgrade from 6.2.3 -> 7.0 .... WORKING

Edited by loomes
  • Like 10
Link to post
Share on other sites

I have  ds3615 6.2.4 running on Proxmox, great job ThorGroup.

 

image.thumb.png.ab27e2c6084bf95b5aaec8300ae7c7db.png

 

I suppose that if I add the drivers *.ko in the EXT folder of the bootloader generator and I build a new image, I could use in a Baramental server, isn't it? or I'm wrong.

 

Edited by jarugut
  • Like 1
Link to post
Share on other sites

Just FYI for those testing, probably unwise to display your serial number (even if it is generated), as it could theoretically give Synology a way to identify you/your IP/etc.

  • Like 1
  • Thanks 2
Link to post
Share on other sites
5 minutes ago, flyride said:

Just FYI for those testing, probably unwise to display your serial number (even if it is generated), as it could theoretically give Synology a way to identify you/your IP/etc.

it's generated but thank you for the advice, I've removed it.

Link to post
Share on other sites

We are all enthousiast about this amazing work, but endusers (like I am) should wait ThorGroup approval to consider it as stable and OK to run as daily...

 

There is no need to rush in my opinion...

 

By the way I'm running 6.2.3 on ESXi as DS3615xs on a HP Gen8... I guess someone, right in time will give a ready to use vmdk file to test.

 

Thanks

  • Like 1
Link to post
Share on other sites

I agree to that. Just a kind reminder that this is still not stable but mainly for developers to play around. Be patient and wait for beta testing and better tutorials on how to install it. 

Link to post
Share on other sites

Hi,

 

This is the log file (/var/log/message) from ESXi (error 13)

logfile.txt

 

Think this error is the root cause

Aug  3 10:55:20 updater: boot/boot_lock.c(228): failed to mount boot device /dev/synoboot2 /tmp/bootmnt (errno:2)
Aug  3 10:55:20 updater: updater.c:6252 Failed to mount boot partition
Aug  3 10:55:20 updater: updater.c:3013 No need to reset reason for v.25556

Edited by RedwinX
Link to post
Share on other sites

@RedwinX I'm getting the same issue; When I download the boot image from ESXi it's been formatted.

When I click to install the pat file it shows (me anyway) 3 disks that be formatted. 2 yes but the 3rd must be the boot image so I'm guess the VID & PID are wrong(?)

 

I'm going to run the loader again with the PID & VID from juns loader to see if that helps.....nope..no change

I am using the original VMDK from juns loader that maps to the img file but that should matter right?

 

Logs: https://pastebin.com/2szJ58zc

 

image.png.7e7e99cb6dfcf4e225cc1386e1b0a316.pngimage.png.597028ffc54383734a0994f6354bb767.png

Edited by supajason
added log
Link to post
Share on other sites
31 minutes ago, supajason said:

@RedwinX I'm getting the same issue; When I download the boot image from ESXi it's been formatted.

When I click to install the pat file it shows (me anyway) 3 disks that be formatted. 2 yes but the 3rd must be the boot image so I'm guess the VID & PID are wrong(?)

 

I'm going to run the loader again with the PID & VID from juns loader to see if that helps.....nope..no change

I am using the original VMDK from juns loader that maps to the img file but that should matter right?

 

Logs: https://pastebin.com/2szJ58zc

 

image.png.7e7e99cb6dfcf4e225cc1386e1b0a316.pngimage.png.597028ffc54383734a0994f6354bb767.png

 

I think we can try other method. Install from the 1.04b, upgrade to 25556, and then just boot from the new loader, maybe works... I will try the afternoon

 

EDIT : not working, the new loader (with the same mac and serial) see the server as a new ds918+, even you have installed and upgrade it just before...

Edited by RedwinX
Link to post
Share on other sites
3 hours ago, RedwinX said:

Hi,

 

This is the log file (/var/log/message) from ESXi (error 13)

logfile.txt 38.88 kB · 6 downloads

 

Think this error is the root cause

Aug  3 10:55:20 updater: boot/boot_lock.c(228): failed to mount boot device /dev/synoboot2 /tmp/bootmnt (errno:2)
Aug  3 10:55:20 updater: updater.c:6252 Failed to mount boot partition
Aug  3 10:55:20 updater: updater.c:3013 No need to reset reason for v.25556

 

@ThorGroup Per your request for my messages log, confirming this one by @RedwinX is the same result I get now that we solved why I wasn't getting a console login prompt. Tried with a DSM 7 loader and .ko file also and same result on ESXi, can't finish install, get Error 13 with above log. Opened an issue on Github for it, but if you'd rather keep it here, let me know.

Edited by ilovepancakes
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.