RedPill - the new loader for 6.2.4 - Discussion


Recommended Posts

On 4/26/2022 at 6:48 PM, speedyrazor said:

I have an AMD 3900x, using KVM hypervisor.

I am trying to spin up a DS1621+

 

Im using the below:

tinycore-redpill.v0.4.6.img for 1st SATA drive, creating a 2nd SATA drive at 40G. Boot into the tinycore, ifconfig to get IP, then ssh in to run the below commands.

 

sudo su

./rploader.sh update now

./rploader.sh fullupgrade now

./rploader.sh serialgen DS1621+ (copy the MAC address and using on the VM)

./rploader.sh satamap v1000-7.1.0-42661

./rploader.sh backup now

./rploader.sh build v1000-7.1.0-42661 auto

poweroff

 

With VM shutdown, I replace the MAC address with the one from above, then power the VM back on, botting from the Sata drive.

I get to 'Booting the kernel', but http://find.synology.com/ finds nothing.

Anything anyone can see I am doing wrong please?

I got this working, with help, using this before build command, this loaded the correct drivers:

 

./rploader.sh ext v1000-7.1.0-42661 add https://raw.githubusercontent.com/pocopico/redpill-load/master/redpill-virtio/rpext-index.json

 

Link to post
Share on other sites

just build the loader with 9p drivers but find some errors when loading drivers.

xpe              | Loading kmod #0 "9pnet.ko" for pocopico.v9fs (args: )
xpe              | [    5.624691] 9pnet: module has bad taint, not creating trace events
xpe              | [    5.626023] 9pnet: Installing 9P2000 support
xpe              | Loading kmod #1 "9pnet_virtio.ko" for pocopico.v9fs (args: )
xpe              | [    5.643141] 9pnet_virtio: Unknown symbol register_virtio_driver (err 0)
xpe              | [    5.644772] 9pnet_virtio: Unknown symbol unregister_virtio_driver (err 0)
xpe              | [    5.646305] 9pnet_virtio: Unknown symbol virtqueue_add_sgs (err 0)
xpe              | [    5.647698] 9pnet_virtio: Unknown symbol virtqueue_get_buf (err 0)
xpe              | [    5.649022] 9pnet_virtio: Unknown symbol virtqueue_kick (err 0)
xpe              | [    5.650337] 9pnet_virtio: Unknown symbol virtio_check_driver_offered_feature (err 0)
xpe              | [    5.652170] 9pnet_virtio: Unknown symbol register_virtio_driver (err 0)
xpe              | [    5.653604] 9pnet_virtio: Unknown symbol unregister_virtio_driver (err 0)
xpe              | [    5.655099] 9pnet_virtio: Unknown symbol virtqueue_add_sgs (err 0)
xpe              | [    5.656356] 9pnet_virtio: Unknown symbol virtqueue_get_buf (err 0)
xpe              | [    5.657601] 9pnet_virtio: Unknown symbol virtqueue_kick (err 0)
xpe              | [    5.658833] 9pnet_virtio: Unknown symbol virtio_check_driver_offered_feature (err 0)
xpe              | insmod: can't insert '9pnet_virtio.ko': unknown symbol in module, or unknown parameter
xpe              | ERROR: kernel extensions "9pnet_virtio.ko" from pocopico.v9fs failed to load
xpe              | Exit on error [99] rp ext init exec failure...

 

please make it fix for that.. 

thanks..

 

 

Link to post
Share on other sites
On 4/20/2022 at 12:26 PM, neevdg said:

Hi guys,

 

I am using the 918+ ApolloLake dsm configuration. PID, VID and Mac address where set correctly. I get this error when I try to install :

 

We've detected errors on the hard drives (1, 2), and the SATA ports have also been disabled. Please shut down your DS918+ to replace or remove the hard drives and try again. 

 

I have a DESKTOP with E-2126G 16G RAM 4 HGST sata drives,the motherboard has 4 sata ports.

that cpu will not work with DS918 or DS920 it's a Coffee Lake microarchitecture, is manufactured on Intel's 3rd generation, it has to be 6 gen and up for it to work...

Edited by painkiller895
Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)

Hello. I have running dsm6.2.4 918+ with redpill loader which is made by using redpill-helper-v0.12. All is working well but how may I update it to current dsm6.2.4 update5 version. On test mashine it always became "restore" after reboot if I update it via web interface to dsm6.2.4 update5.

Edited by navhawk
Link to post
Share on other sites
22 hours ago, navhawk said:

Hello. I have running dsm6.2.4 918+ with redpill loader which is made by using redpill-helper-v0.12. All is working well but how may I update it to current dsm6.2.4 update5 version. On test mashine it always became "restore" after reboot if I update it via web interface to dsm6.2.4 update5.

 

I suggest you backup your loader and create a TCRP one. You can use the latest TCRP to go through the postupdate process. 

Link to post
Share on other sites
Posted (edited)
On 4/29/2022 at 8:35 PM, painkiller895 said:

that cpu will not work with DS918 or DS920 it's a Coffee Lake microarchitecture, is manufactured on Intel's 3rd generation, it has to be 6 gen and up for it to work...

 

Sorry, but this is a painfully incorrect statement.  Coffee Lake is 8th generation.  If a CPU won't work because of FMA3 support, it won't boot at all.

Edited by flyride
Link to post
Share on other sites
7 часов назад, pocopico сказал:

 

I suggest you backup your loader and create a TCRP one. You can use the latest TCRP to go through the postupdate process. 

I tried to make 6.2.4-25556 bootloader with tinycore-redpill.v0.4.6. Even installtion was successull but after reboot dsm has the status "not installed". But at the same time 7.1 is working...

Link to post
Share on other sites
Posted (edited)
16 minutes ago, navhawk said:

I tried to make 6.2.4-25556 bootloader with tinycore-redpill.v0.4.6. Even installtion was successull but after reboot dsm has the status "not installed". But at the same time 7.1 is working...

 

If there are no old 6.2.4 features you would like to keep, i suggest you go to 7.1. 6.2.4 is somehow left behind in TCRP.

Edited by pocopico
Link to post
Share on other sites
8 hours ago, flyride said:

 

Sorry, but this is a painfully incorrect statement.  Coffee Lake is 8th generation.  If a CPU won't work because of FMA3 support, it won't boot at all.

my bad your 100 % right.  Sorry dude.  DS918 & DS920 should work. It's the hard drive mapping issue...

Link to post
Share on other sites
2 hours ago, maverickjp84 said:

is there a working version of i915.ko for N5105 CUP (Intel Celeron), if so could could the link be posted over here.

UHD Graphic card info below

the best atm is 10th gen support with this patch

https://xpenology.com/forum/topic/59909-i915ko-backported-driver-for-intel-10th-gen-ds918-ver-701-up3/

but you jasper lake is 11th gen like ice lake

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.