RedPill - the new loader for 6.2.4 - Discussion


Recommended Posts

4 hours ago, dodo-dk said:


 

hi, i passthrough 4 drives without problems but with SATA.

this is my config line:

 

sata1: /dev/disk/by-id/ata-WDC_WD60EFRX-68MYMN1_WD-XxXxXxXxXx,backup=0,serial=WD-XxXxXxXxXx,size=5860522584K

 

Yes SATA seems to be working flawlessly, I wonder if it has performance impact.

 

Link to post
Share on other sites

Hi guys.
I've been testing for few days and after surpassing various problems i can't make the system see my discs.


My mobo has 2 sata controlers with 2 ports each. For this old mobo i choose BRODWELL

My default setting for SATA is 22.
Already try change for multiple numbers that i found at many pages but i now that this should be correct.

How do i check if the drivers are correctly?

My setup is: 
Celeron 847 (Sandy bridge as Core i5-2400)
8GB RAM DDR3-L
4 x 1TB WD drivers

Link to post
Share on other sites
Il y a 4 heures, apiros a dit :

Hi Guys!

 

Last week did anything change with the DS3617xs loader on the jimmyGalland repo? 
I was able to create a working image then, since then it's not working.

Hello @apiros

 

There was a dependency problem with the dpkg package that is not present with the pocopico's tool .
This dependency was removed which caused the impossibility of generating an image for ds3617xs.
However I send an alternative two days ago on the develop branch https://github.com/jimmyGALLAND/redpill-load .
You can try and make your feedback

  • Like 1
Link to post
Share on other sites

For those allergic to DSM 7 !

I forgot to add support for u2 / u3 intermediate updates for the DS918p platform, it's done.
"6.2.4-25556u2" on develop branch https://github.com/jimmyGALLAND/redpill-load
Update 3 works without having to redo a new loader than this one, there was no kernel update to go to version 3 from 2.

In the same way update 2 of DSM 6.2.4 works with update 3 on platforms ds3615xs and ds3617xs.


Some modules are available on https://github.com/jimmyGALLAND/redpill-ext  ( like acpi, virtio, redpill-boot_wait ).

 

A request has been sent for "6.2.4-25556u2" on pocopico modules github  https://github.com/pocopico/rp-ext 

In the meantime you can use the branch: "add_support_ds918p_25556u2"  on https://github.com/jimmyGALLAND/rp-ext

 

Link to post
Share on other sites
В 12.01.2022 в 04:00, ZorgeR сказал:

same issue here. ESXi 7, 56% issue on pat installation. SATA boot.

 

Successfully run bromolow-7.0.1-42218 on ESXi 7, just converted vmdk from tinicore github to ESXi format with

vmkfstools -i "hdd-from-git.vmdk" "correct-esxi-hdd.vmdk"

Will try DS3617xs, need more cores.

Many thanks!

Link to post
Share on other sites
1 hour ago, eldi said:

I have a problem after uploading .pat file and waiting for 10:00 min timer, it reloads and asks to upload .pat file again. never ending cycle… Please help.

I had the same problem and it was a driver problem. The test I did was one virtual drive and my lsi card. And here I entered the installation loop. As soon as I got the right driver with help from pocopico, it worked. When I tested without a virtual it didn’t find the harddrives. What I understood was that if there is a problem (like driver problem) it would stop the installation. To be honest i did mostly have not your patience. After two min the xpenology reboots and then either it is ok or there was a problem.

Link to post
Share on other sites

 

12 hours ago, buggy25200 said:

Hello @apiros

 

There was a dependency problem with the dpkg package that is not present with the pocopico's tool .
This dependency was removed which caused the impossibility of generating an image for ds3617xs.
However I send an alternative two days ago on the develop branch https://github.com/jimmyGALLAND/redpill-load .
You can try and make your feedback

Hi @buggy25200,

 

I use debian 8, not tinycore. I have tried tinycore and it gives the same error.

I created the LKM based on the broadwell, then created the image. In both cases I used the develop branch of jimmyGalland.

 

I used Proxmox, created the VM as it should be. After starting the VM, it loads up to the point where I can upload the .pat file and apparently the installation runs successfully. 

On Serial port I see that it never loads the DSM anymore and throws some errors while loading modules.

 

Can not detect ADT device, Retry: 1...
:: Unloading module adt7475[   16.314441] Module [adt7475] is removed. 
 ... [  OK  ]
:: Unloading module i2c-i801[   16.325348] Module [i2c_i801] is removed. 
 ... [FAILED]
:: Loading module adt7475 ... [  OK  ]
Can not detect ADT device, Retry: 2...
:: Unloading module adt7475[   18.350807] Module [adt7475] is removed. 
 ... [  OK  ]
:: Unloading module i2c-i801[   18.360369] Module [i2c_i801] is removed. 
 ... [FAILED]
:: Loading module adt7475 ... [  OK  ]
Can not detect ADT device, Retry: 3...
:: Unloading module adt7475[   20.386502] Module [adt7475] is removed. 
 ... [  OK  ]
:: Unloading module i2c-i801[   20.398994] Module [i2c_i801] is removed. 
 ... [FAILED]

Edited by apiros
Link to post
Share on other sites
4 minutes ago, buggy25200 said:

root not matched with junior
you must boot with the correct version of loader. If you try to update to 701u2 you have to read my previous post.

Envoyé de mon ONEPLUS A6003 en utilisant Tapatalk
 

I do not want to upgrade to 7.0.1-42218u2.
I generated 7.0.1-42218 with the loader and the .pat file is 7.0.1-42218.

Link to post
Share on other sites

Synology is sending out updates during the install process. If you are having issues installing fine and then the first reboot it wants to migrate, you need to cut your internet or block synology's servers.

 

Ran into this issue last night working on a DS3617 box

  • Like 1
Link to post
Share on other sites

@apiros

 

try this

 

DiskStation> mkdir /root/tmproot

DiskStation> mount /dev/md0 /root/tmproot/

DiskStation> chroot /root/tmproot /bin/bash

DiskStation> sha256sum /.syno/patch/zImage

DiskStation> sha256sum /.syno/patch/rd.gz

 

and post here the two results

 

Thx

Link to post
Share on other sites
1 hour ago, rok1 said:

Synology is sending out updates during the install process. If you are having issues installing fine and then the first reboot it wants to migrate, you need to cut your internet or block synology's servers.

 

Ran into this issue last night working on a DS3617 box

OMG!!! It's working! :)
Thanks!

Link to post
Share on other sites
il y a 31 minutes, apiros a dit :

OMG!!! It's working! :)
Thanks!

 

On control panel => update & restore => DSM update => update setting, to avoid future unrequested update, It is better to check the third option, if it is not done yet: Notify me and let me decide whether to install the new update

 

 

1.png

Edited by buggy25200
Link to post
Share on other sites
1 minute ago, buggy25200 said:

 

Vezérlőpulton => frissítés és visszaállítás => DSM frissítés => frissítési beállítás, a jövőbeni kéretlen frissítés elkerülése érdekében, ha még nem tette meg, jobb az első opciót bejelölni: Értesítsen és döntsem el, hogy telepítem-e az újat frissítés

 

 

1.png

Thank you @buggy25200, I have set it up.

Link to post
Share on other sites

Hi. RedPill loader support modules for DVB-T dongles (it9135, siano or any other)? I know, firmware propably i need to download, but in mine machine with Jun's loader couple different dongles not work at all. Problem with loading modules from extra package. In debian work without any problems. I want use TvHeadend in DSM.

Link to post
Share on other sites
29 minutes ago, buggy25200 said:

 

On control panel => update & restore => DSM update => update setting, to avoid future unrequested update, It is better to check the third option, if it is not done yet: Notify me and let me decide whether to install the new update

 

 

1.png

That works after install, but Synology connects to update servers during the install process and downloads updates. 918+ and 3615+ may work ok, but 3617+ is not upgradeable yet to u2 without borking the installation.

Link to post
Share on other sites
9 hours ago, rok1 said:

That works after install, but Synology connects to update servers during the install process and downloads updates. 918+ and 3615+ may work ok, but 3617+ is not upgradeable yet to u2 without borking the installation.

but it works, it's just a little more work, go to page 141 and read what buggy25200 wrote!

Link to post
Share on other sites
On 1/21/2022 at 2:53 AM, myswe said:

I encountered an issue when trying to pass-trough HDD on DSM7. After fresh red-pill DS3615xs installation I followed the Proxmox

documentation to mount two 4TB HDDs to the VM via shell commands

 

qm set 999 -scsi0 /dev/disk/by-id/ata-WDC_WD40EFAX-XXXXXXX_WD-WXXXXXXXXX31
qm set 999 -scsi1 /dev/disk/by-id/ata-WDC_WD40EFAX-XXXXXXX_WD-WXXXXXXXXXN2

 

after booting I see the drives in Synology Storage manager but I can't create a storage volume

See screenshot for error "disk_reason_template_0"

But the storage manager clearly see's both of them


There was a discussion about this here: (see some posts before this linked one for why it happens)
https://xpenology.com/forum/topic/45795-redpill-the-new-loader-for-624-discussion/?do=findComment&comment=221693


Just had the same error but I am using VMware and passthrough the whole raid card.
Anybody knows a workaround for VMware ESXI / PCI Passthrough?

Edited by Byolock
Link to post
Share on other sites
3 hours ago, Byolock said:


There was a discussion about this here: (see some posts before this linked one for why it happens)
https://xpenology.com/forum/topic/45795-redpill-the-new-loader-for-624-discussion/?do=findComment&comment=221693


Just had the same error but I am using VMware and passthrough the whole raid card.
Anybody knows a workaround for VMware ESXI / PCI Passthrough?

For me the passtrough in esxi just works but only with DS3615XS not with the DS918+. I added the mpt2sas drivers. PCI ID for my lsi card is 1000:0072.

There is something fishy with esxi 7, when the passtrough is enabled and i reboot the host machine. The pci card can't be enabled. So i have to disable the passtrough. Reboot the host. And then i can enable paastrough of my hba card without the need of a reboot.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.