RedPill - the new loader for 6.2.4 - Discussion


Recommended Posts

32 minutes ago, luckcolors said:

@jumkey

I wanted to ask about the shutdown extension.

 

I was wondering if you could move it to a separate repo like THG does it.

I mean it doesn't matter in the end but i guess that way it would be more discoverable.

 

Thanks again for your work. :D

rp-ext has added it

https://github.com/pocopico/rp-ext/tree/main/redpill-acpid

  • Like 1
Link to post
Share on other sites
Le 30/10/2021 à 18:56, haydibe a dit :

@titoum: I have some notes to your approach:

  

Instead of doing this:

You can simply download the file from yumkey's repo and put it e.g. in the rp-helper folder, then use the custom_bind_mounts like mentioned earlier.

 

 

 

 The intended approach for rp-helper v0.12 is to create a custom_config.json for your custom configurations ;) There is no need to butcher the global_config.json....

On Linux, you can get the file with `wget -L https://raw.githubusercontent.com/jumkey/redpill-load/develop/bundled-exts.json -o bundled-exts.json`  in your rp-helper folder and use a custom_config.json like this:

 



{
    "docker": {
        "use_custom_bind_mounts": "true",
        "custom_bind_mounts": [
            {
                "host_path": "bundled-exts.json",
                "container_path" :"/opt/redpill-load/bundled-exts.json"
            }
        ]
    },
    "build_configs": [
        {
            "id": "bromolow-7.0.1-42218",
            "platform_version": "bromolow-7.0.1-42218",
            "user_config_json": "bromolow_user_config.json",
            "redpill_lkm_make_target": "test-v7",
            "docker_base_image": "debian:8-slim",
            "compile_with": "toolkit_dev",
            "downloads": {
                "kernel": {
                    "url": "https://sourceforge.net/projects/dsgpl/files/Synology%20NAS%20GPL%20Source/25426branch/bromolow-source/linux-3.10.x.txz/download",
                    "sha256": "18aecead760526d652a731121d5b8eae5d6e45087efede0da057413af0b489ed"
                },
                "toolkit_dev": {
                    "url": "https://sourceforge.net/projects/dsgpl/files/toolkit/DSM7.0/ds.bromolow-7.0.dev.txz/download",
                    "sha256": "a5fbc3019ae8787988c2e64191549bfc665a5a9a4cdddb5ee44c10a48ff96cdd"
                }
            },
            "redpill_lkm": {
                "source_url": "https://github.com/RedPill-TTG/redpill-lkm.git",
                "branch": "master"
            },
            "redpill_load": {
                "source_url": "https://github.com/jimmyGALLAND/redpill-load.git",
                "branch": "develop"
            }
        }
    ]
}

 

Afterwards you can use the auto action for this build config without manual steps required...

Hello, I am trying to build the image for bromolow-7.0.1-42218 , following the advise below. Unfortunatly,  it is not working as expected:  the error message received is in red below :

 

....

[#] Checking runtime for required tools... [OK]
[#] Adding new extension from https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json...
[#] Downloading remote file https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json
######################################################################## 100.0%
curl: (7) Failed to connect to raw.githubusercontent.com port 443: Connection refused
[!] Failed to download https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json

*** Process will exit ***

[!] Failed to add "https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json" as an extension:


,

*** Process will exit ***
[!] Failed to install thethorgroup.boot-wait bundled extension - see errors above

*** Process will exit ***
Makefile:30: recipe for target 'build_redpill_load' failed

 

I am using a Mac Book with big sur 11.6.

 

Someone already encountered this error ?

 

Thanks,

Rikk

 

 

Edited by Rikk
Link to post
Share on other sites
3 hours ago, Rikk said:

Hello, I am trying to build the image for bromolow-7.0.1-42218 , following the advise below. Unfortunatly,  it is not working as expected:  the error message received is in red below :

 

....

[#] Checking runtime for required tools... [OK]
[#] Adding new extension from https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json...
[#] Downloading remote file https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json
######################################################################## 100.0%
curl: (7) Failed to connect to raw.githubusercontent.com port 443: Connection refused
[!] Failed to download https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json

*** Process will exit ***

[!] Failed to add "https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json" as an extension:


,

*** Process will exit ***
[!] Failed to install thethorgroup.boot-wait bundled extension - see errors above

*** Process will exit ***
Makefile:30: recipe for target 'build_redpill_load' failed

 

I am using a Mac Book with big sur 11.6.

 

Someone already encountered this error ?

 

Thanks,

Rikk

 

 

I post it similar issue but I have not find solution. 

 

In some cases, the process with DS918+ finish the image without issue but with DS3615xs show failed with ssl curl.

 

All these problems occur to me since version v012, previously with the v011 I did not have these problems, although it happens equally with this one at now.

 

I am using to compile VMWare with Ubuntu. 

 

 

Link to post
Share on other sites
12 hours ago, Rikk said:

Hello, I am trying to build the image for bromolow-7.0.1-42218 , following the advise below. Unfortunatly,  it is not working as expected:  the error message received is in red below :

 

....

[#] Checking runtime for required tools... [OK]
[#] Adding new extension from https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json...
[#] Downloading remote file https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json
######################################################################## 100.0%
curl: (7) Failed to connect to raw.githubusercontent.com port 443: Connection refused
[!] Failed to download https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json

*** Process will exit ***

[!] Failed to add "https://github.com/jumkey/redpill-load/raw/develop/redpill-boot-wait/rpext-index.json" as an extension:


,

*** Process will exit ***
[!] Failed to install thethorgroup.boot-wait bundled extension - see errors above

*** Process will exit ***
Makefile:30: recipe for target 'build_redpill_load' failed

 

I am using a Mac Book with big sur 11.6.

 

Someone already encountered this error ?

 

Thanks,

Rikk

 

 

are you building it natively in Mac or a VMware / virtual box linux image running on Mac?

 

To my knowledge, there are some other linux packages needed to build with the tool chain and I don't think it can be built natively on Mac.

 

Specifically on this error, you can look at Stack overflow. Seems more to do with GitHub is not reachable (on that stack overflow, recommendation is to use the google DNS server but it's likely that your ISP or DNS provider is blocking access to git?)

Edited by urundai
Link to post
Share on other sites
Le 24/10/2021 à 22:22, buggy25200 a dit :

if someone is interested. I made an extension package/modules for acpi

(I won't be able to use the already existing extensions, it did not work with my config : virtualbox)

test OK with ds918p_42218 ds3615xs_42218

but not tested with ds918p_25556 ds3615xs_25556

 

 

to use


./ext-manager.sh add https://github.com/jimmyGALLAND/redpill-ext/raw/master/acpid/rpext-index.json

 

 

@seanone Maybe try this

Link to post
Share on other sites
On 11/12/2021 at 12:25 AM, titoum said:

apriliars3@ubuntu:~/Descargas/redpill-helper-v0.12$ ./rp-helper.sh ext bromolow-7.0.1-42218 add https://raw.githubusercontent.com/jumkey/redpill-load/develop/redpill-boot-wait/rpext-index.json
[#] Checking runtime for required tools... [OK]
[#] Adding new extension from https://raw.githubusercontent.com/jumkey/redpill-load/develop/redpill-boot-wait/rpext-index.json...
[#] Downloading remote file https://raw.githubusercontent.com/jumkey/redpill-load/develop/redpill-boot-wait/rpext-index.json to /opt/redpill-load/custom/extensions/_new_ext_index.tmp_json
######################################################################## 100.0%

[!] Extension is already added (index exists at /opt/redpill-load/custom/extensions/thethorgroup.boot-wait/thethorgroup.boot-wait.json). For more info use "./rp-helper.sh ext bromolow-7.0.1-42218 info thethorgroup.boot-wait"

*** Process will exit ***

Link to post
Share on other sites
4 hours ago, Nixion said:

my redpill image get stuck on "booting kernel" and not found on find.synology.com of assistent

 

some one can help my i don't now how to do

There is no further screen output once the “booting kernel” message appears. This is expected behaviour. All further output is sent to the serial console (if you have a serial port).

 

Not finding the server with Assistant suggests it hasn’t acquired a DHCP lease, probably due to the network not being brought up. It’s likely your NIC is not supported by the default image. 
 

Exactly what hardware and DSM version are you trying to install on? Please give as much detail as possible. 

Link to post
Share on other sites
1 hour ago, WiteWulf said:

There is no further screen output once the “booting kernel” message appears. This is expected behaviour. All further output is sent to the serial console (if you have a serial port).

 

Not finding the server with Assistant suggests it hasn’t acquired a DHCP lease, probably due to the network not being brought up. It’s likely your NIC is not supported by the default image. 
 

Exactly what hardware and DSM version are you trying to install on? Please give as much detail as possible. 

Another option is to check your router o see if IP was issued. That was the case for me - assistant couldn’t find but I was able to get to it through the IP address (IP:5000). 

Link to post
Share on other sites

now is my xpenology server running 6.2.3-25426 update 3

same server with redpill do not show up in my network

2nic on motherboard and do not work with redpill

and i dont wanna lose my date on de server

 

thx for helping my around

 

 

i make a image with bromolow-7.0-41890 and 412222

noting works

 

Edited by Nixion
Link to post
Share on other sites
7 hours ago, urundai said:

Another option is to check your router o see if IP was issued. That was the case for me - assistant couldn’t find but I was able to get to it through the IP address (IP:5000). 

best option to see whats going on after the initial boot message is still the serial console, easy with esxi but when using baremetal it depends on the systems having a com port or using the right pcie card with a com port (CH382L working with 918+)

https://xpenology.com/forum/topic/36505-serial-port-com1-stages-of-operation/?do=findComment&comment=177569

 

Link to post
Share on other sites
9 hours ago, IG-88 said:

best option to see whats going on after the initial boot message is still the serial console, easy with esxi but when using baremetal it depends on the systems having a com port or using the right pcie card with a com port (CH382L working with 918+)

https://xpenology.com/forum/topic/36505-serial-port-com1-stages-of-operation/?do=findComment&comment=177569

 

i want to install de ds3615

 

and i dont have a serial kabel or port

Edited by Nixion
Link to post
Share on other sites
il y a 24 minutes, Nixion a dit :

i want to install de ds3615

 

and i dont have a serial kabel or port

 

You can install proxmox hypervisor on your baremetal, and in this case control DSM install from a remote connection.

Update DSM on promox is easier.

This is a example config of qemu server for DSM on promox

 

args: -device 'qemu-xhci,id=usb-ctl-synoboot,addr=0x18' -drive 'id=synoboot,file=/var/lib/vz/images/synoboot100.img,if=none,format=raw' -device 'usb-storage,id=synoboot,bootindex=5,removable=off,drive=synoboot'
boot:  
cores: 4
machine: q35
memory: 3000
name: DS3615xs
net0: virtio=08:00:27:20:B1:B8,bridge=vmbr0,firewall=1
numa: 0
onboot: 1
ostype: l26
rng0: source=/dev/urandom
sata0: zfs-data:vm-100-disk-1,size=32G
sata1: Data2:vm-100-disk-0,backup=0,size=430G
scsihw: virtio-scsi-pci
serial0: socket
smbios1: uuid=5b52604d-c8d9-4629-ba3e-b36305df5030
sockets: 1
startup: order=1,up=60,down=60
vga: serial0
vmgenid: 3e754828-a76e-44cd-88a2-80b860349b34

 

Link to post
Share on other sites

I have too much data to switch to proxmox

over 4tb on data

 

i think i stay on 6.2.3-25426 update 3 and wait

for a stable version of the redpill

 

I do not have the chance to adjust everything and I am already aware that I have succeeded in making an image, but it is true that it did not work

 

sorry i use google translate

my English is not so good

  • Like 1
Link to post
Share on other sites
5 hours ago, Brunox said:

if I remember reading correctly, there was a limitation of the hard disk to 2 TB on ESXI, is that still true? or am I confusing something?

depends on esxi version

https://kb.vmware.com/s/article/2058287

with esxi 6.5 and above should be not problem (when not having any limiting factors like vmfs3 volume in storage and updating the host without reformatting the storage)

1 hour ago, buggy25200 said:

Update DSM on promox is easier.

that depends on the person, if you barely can handle linux and you are not familiar with using hypervisors i guess its not

 

1 hour ago, Nixion said:

I have too much data to switch to proxmox

over 4tb on data

i dont think any recent version of a hypervisor will have problems with 4TB (even in a single disk), maybe you dont have enough storage for backup/offload the 4TB?

 

2 hours ago, Nixion said:

and i dont have a serial kabel or port

lots of system at least have a onboard connector for com port and there are only 2 possible way's how the pinout to the subD-9, both types can be bought for a few bugs if you dont have something like that around (like from isa/pci/pcie cards with extra brackets, or from older main board accessories)

 

 

Link to post
Share on other sites
32 minutes ago, IG-88 said:

depends on esxi version

https://kb.vmware.com/s/article/2058287

with esxi 6.5 and above should be not problem (when not having any limiting factors like vmfs3 volume in storage and updating the host without reformatting the storage)

that depends on the person, if you barely can handle linux and you are not familiar with using hypervisors i guess its not

 

i dont think any recent version of a hypervisor will have problems with 4TB (even in a single disk), maybe you dont have enough storage for backup/offload the 4TB?

 

lots of system at least have a onboard connector for com port and there are only 2 possible way's how the pinout to the subD-9, both types can be bought for a few bugs if you dont have something like that around (like from isa/pci/pcie cards with extra brackets, or from older main board accessories)

 

 

I don't know anything about hypervisors and proxmox. I also don't have 4TB HDDs laying around to make backups. my xpenology server is currently working on the ds3617 so will wait a little longer as I already said or if someone can help me in dutch please let me know via pm or something thanks in advance

Link to post
Share on other sites
Quote

i think i stay on 6.2.3-25426 update 3 and wait for a stable version of the redpill

A very sensible thing to do, I am the same position as you with very limited knowledge of Linux, Proxmox or ESXI. My xpenology server is working fine and that is how I will leave it until the final working version becomes available with easy to follow instructions.

 

It's a shame there are so many impatient Noobie questions keep appearing taking up the time of the hardworking individuals trying to get this working for all of us.

Edited by DaveD
Link to post
Share on other sites
1 hour ago, Nixion said:

I don't know anything about hypervisors and proxmox. I also don't have 4TB HDDs laying around to make backups. my xpenology server is currently working on the ds3617 so will wait a little longer as I already said or if someone can help me in dutch please let me know via pm or something thanks in advance

Even with a stable loader I would not try to upgrade the working system without a backup of the data.

Write here what hardware you use (mainboard, nic, hdd, sata or sas adapter,...). If your nas is booting but not seen in your network, probably the nic is not supported. Try with an Intel nic (if you have).

But first make a backup.

  • Like 1
Link to post
Share on other sites
12 hours ago, DaveD said:

A very sensible thing to do, I am the same position as you with very limited knowledge of Linux, Proxmox or ESXI. My xpenology server is working fine and that is how I will leave it until the final working version becomes available with easy to follow instructions.

 

It's a shame there are so many impatient Noobie questions keep appearing taking up the time of the hardworking individuals trying to get this working for all of us.

 

Don't agree that, developer also need much more testers to test it, software is useless without users.

Link to post
Share on other sites
16 hours ago, paro44 said:

Even with a stable loader I would not try to upgrade the working system without a backup of the data.

 

i always would recommend warmly a cold backup...did one before moving to dsm 7.0...all went fine.

then for unknow reason, i had a crash. god bless this usb cold back up drive 🥰

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.