Problems making bootable flash drive from "Jun's Loader v1.03b DS3615xs"


Recommended Posts

Hello, I am new to this forum. Recently tried to install XPEnology on Microserver ver8 but hit a roadblock.

 

I am on a windows 10 machine for the prep part.

 

1. I have downloaded ""Jun's Loader v1.03b DS3615xs"", as per https://xpenology.com/forum/topic/7848-links-to-loaders/ instructions.

2. I have unzipped the "synoboot.img"

3. I have tried to flash the "synoboot.img" to my 128GB SanDisk Ultra Fit USB 3,1 flash drive, using "balenaEtcher" or "win32diskimager-1.0.0-install.exe"

4. In both the cases, after flashing process completes successfully, I got 2 partitions on the flash drive - one 30 MB (with 3 files "extra.lzma", "rd.gz", "zImage"), and the other when I click on it, I got a notification that the disk is not formatted.

 

It seems there is something wrong, because I was expecting to have a 15 MB partition with files and folders like: "EFI", "grub", "bzimage", ...

 

Could I have a help please, what I am doing wrong...?

 

thanks in advance

Link to post
Share on other sites

Basically you need 3-4 programms to make boitable xpeno loader:

 

1)win32diskimager to burn bootable usb (synoboot when properly pre configured- VID/PID....MAC....synology serial) 

 

2) OSFMount to mount 1st 15mb partition.... Or sometimes 2nd 30mb for extra/lzma etc

 

3) Notepad++ (or notepadqq in linux sytems) to edit mounted partition from OSFMount 

 

4) Partition wizztard (or gparted in linux) to prepare usb/hdd etc before burning... 

Link to post
Share on other sites

Hello KameleON, thank you for spending time to help with my problem.

 

WIth OSFMount I am loading the 15 MB partition from the synoboot.img and editing the VID/PID, etc.... Then I am using win32diskimager to make the bootable flash drive but the 15MB partition is not created (just the 30MB one).

 

Not sure how to use Partition wizztard in this process, it is missing from the post:

 

Link to post
Share on other sites

You need partition wizzard (sorry for the typo) after every unsuccsessful attempt to make bootable usb...to format it back to ntfs...and start from scratch... 

 

And you need also or Windows bootable CD/USB or linux one....to format your HDD drives back to ntfs or dos format (to delete unsuccsessful xpenology atrempt)... Xpenology will write linux partitions every time you try to boot it via find.synology.com

Link to post
Share on other sites
Posted (edited)

thank you for the clarification - I use windows-> diskpart to fix the flashdrive back to original.

 

Still, I am not sure how to overcome the missing 15 MB partition problem, after flashing "synoboot.img" with win32diskimager...

 

If I search this partition with the Disk management tool - I see the both 15 and 30 MB partitions, but the 15 MB one is not visible in explorer

image.thumb.png.57fae31a01f2f797d5251296e05c02aa.png

Edited by dimcheff
Link to post
Share on other sites

Have you tried to boot from the stick?
You cant see all drive partitions in windows because of the different file systems.
If you change the grub config using OSFMount and flash the img with etcher your drive should be bootable

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.