Transfert réseau très très très lents voir impossible erreur 0x8007003B


Recommended Posts

Bonjour à tous, 

Depuis quelques mois je rencontre un souci avec les transferts réseau depuis mon NAS vers PC.
Juste après le redémarrage du syno tout est ok transferts réseau dans les 110 MB sans aucun souci.
Puis systématiquement au bout de quelques minutes les transferts via SMB (lecteur réseau Windows) deviennent totalement impossibles.
Débit max 30 MB et direct chute jusqu'à quelques Kb puis échec avec l'erreur: 0x8007003B.
Et cela systématiquement pour les fichiers supérieurs à 1 Gbit.
Avant de venir poser la question j'ai effectué des recherches et ai testé:
- Arrêt antivirus
- Arrêt pare-feu
- Changement SMB1/2/3 etc
- Remplacé tous mes câbles réseau

Rien n'y fait :-(
Si je passe par le navigateur web en téléchargement, aucun souci.

J'ai tenté toutes les solutions proposées sur les forums et rien ne va.
J'avoue que ca me prend bien la tête car peu d'intérêt d'avoir un NAS dans ces conditions là...
 

Le syno est sur ESXI 6.7

Si quelqu'un avait une idée ce serait super cool :-)

Merci à tous et bonne journée .

Link to post
Share on other sites

Bonsoir,

 

Est-ce que les Jumbo Frames n'auraient pas été activées dans la configuration du Syno (et pas pour le reste du réseau, switch compris) ?

Ou l'inverse, activées sur les PC mais pas sur le NAS ?

 

Ça pourrait être une piste, sur les gros transferts,le fait d'utiliser des trames dont la taille n'est pas standard entraîne un échec de transport, et une réémission qui sera de nouveau un échec, etc...

Autre possibilité, un MTU incohérent sur les équipements réseau ou les interfaces (1500 pour ethernet).

 

A vérifier

Jacques

Link to post
Share on other sites

Bonjour jacques, merci de ta réponse.
Le MTU est le MTU de base partout 1500.
En ce qui concerne les Jumbo Frames je ne vois pas où les activer dans le syno...
Le problème se produit uniquement avec le syno, j'ai tenté de faire des transferts d'une machine virtuelle esxi Windows 10 (parallèle au syno)
vers un des postes physiques et aucun souci "transfert à + de 100 Mo/s". Donc pas de souci dans l'esxi...
Tous les pcs du réseau son configurés avec le paramétrage par défaut (aucune personnalisation des cartes réseaux) et connectées en DHCP.
 

Link to post
Share on other sites

Le paramètre a disparu de la configuration en 6.2, auparavant il était dans Panneau de configuration / Réseau / Interface réseau / Modifier / Activer Jumbo Frame

Ceci permettait de modifier le MTU.

En 6.X, le chemin est le même mais le nom est devenu Configurer manuellement la valeur de la MTU.

Si  la valeur est différente, on peut rencontrer des soucis (je l'ai vécu) bien qu'en théorie la valeur du MSS étant échangée à la connexion entre les PC on ne devrait pas dépasser celle du MTU... mais bon, ça n'a pas l'air d'être vrai dans tous les cas.

Les switches gigabit SOHO ne permettent souvent pas de laisser passer autre chose que 1508 octets (soit un MTU de 1500) par trame.

 

Tu peux utiliser l'outil iperf3 pour faire des tests entre les différents PC (une version Windows existe, pour linux le paquet iperf3 est disponible pour la plupart des distributions, et pour Synology, tu peux trouver la version correspondant au DSM que tu utilises ici : www.jadahl.com/iperf-arp-scan/ (ce qui évite d'installer docker comme indiqué dans les pages qui suivent).

Liens vers une page d'explication sur l'usage d'iperf :

https://www.cachem.fr/iperf-routeur-synology/

https://aradaff.com/tester-son-reseau/

 

Ça permettra d'avoir des valeurs précises. Maintenant, si le transfert décroit après un certain temps, il faudra regarder les options de iperf3 pour lancer la commande sur une durée plus longue (par défaut 10 paquets d'environ 100Mb en 10 secondes.

 

Ne pas oublier d'ouvrir le port utilisé par iperf3 (5201 par défaut) dans le(s) pare-feu(x) traversé(s).

 

Jacques

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.