Sign in to follow this  
Exxtreme

CHMOD issues

Recommended Posts

I'm having issues with chmodding files on the synology webserver (xpenology on a hp microserver gen8)... I've tried several ftp and sftp clients, but none allow me to chmod files. I'm not getting any error messages, but the chmod permissions on files/folders doesn't change no matter what i do... Any thoughts?

Share this post


Link to post
Share on other sites

OK so i have tried a little more and found out that the files I uploaded (php fusion 7 cms install files) and tried to chmod doesn't seem to let me do so, but the the default index file for web station that was already on the server (index.html) chmods fine...

 

Is it possible that it has something to do with the file transfer mode?

Share this post


Link to post
Share on other sites

Ok, in order for me to try & help, can you post step by step what you've tried.

Share this post


Link to post
Share on other sites
Ok, in order for me to try & help, can you post step by step what you've tried.

I've tried uploading the files using both FTP and SFTP protocol with these clients: total commander, winscp, bitwise ssh client, filezilla...

 

When I try to chmod a file, lets say config.php, from 777 to 755 it seems to work, cause i'm not getting any error messages, but the new chmod setting doesn't push through.

When I go back to see the chmod setting of the file, the setting is back to 777... It's like it reverts itself...

 

In Bitwise ssh client, I can see that the file attributes of config.php is -rwxrwxrwx and when I chmod the file to 755 the attributes change to -rwxr-xr-x, but when i refresh the window the attributes is -rwxrwxrwx again without me doing anything but refreshing the window...

 

Also - the files I'm uploading is PHP Fusion 7 CMS installation files, and during the installation og the CMS system, it needs some of the files and folders to be chmod 777, but the setup fails and says that the files/folders is indeed NOT 777 even though I can't change the chmod settings AWAY from 777 in the Bitwise client...

 

I'm logging in with my default xpenology admin account in the Bitwise client...

 

Any suggestions?

Share this post


Link to post
Share on other sites

BTW I'm running xpenology 5.2-5592 update 4 on a HP Proliant Microserver with 4 x 3TB WD Red drives in SHR mode...

Share this post


Link to post
Share on other sites

I use Putty and WinSCP to do my under the hood stuff.

 

Try using root instead of admin. The password is the same as your admin account.

Share this post


Link to post
Share on other sites
I use Putty and WinSCP to do my under the hood stuff.

 

Try using root instead of admin. The password is the same as your admin account.

 

Putty & WinSCP is what I use too, however whatever you use you must login as root as suggested by elmuziko

Share this post


Link to post
Share on other sites
I use Putty and WinSCP to do my under the hood stuff.

 

Try using root instead of admin. The password is the same as your admin account.

I can't login using root instead of admin as the username?

 

 

I'm getting this error message:

Connection has been unexpectedly closed

 

Server sent command exit status 255

 

Cannot initialize SFTP protocol. Is the host running a SFTP server?

 

EDIT:

 

When i use Bitwise instead og Winscp I can login as root, but each time i click "New SFTP Window" the log says: "SFTP channel opened" and "SFTP channel closed by server" right after...

 

So I guess the SFTP server doesn't allow me to connect as root, but the xpenology server does...

Share this post


Link to post
Share on other sites

My setup explicitly denies me login for anything other than root; it full on bombs me out. The only changes I've made to the vanilla settings is to disable the admin account and create a new admin with a different name (which is Synology's recommended practise for security).

 

If you can connect using your standard admin account, can you try sudo -s

I assume you have SSH open on 22?

Share this post


Link to post
Share on other sites
My setup explicitly denies me login for anything other than root; it full on bombs me out. The only changes I've made to the vanilla settings is to disable the admin account and create a new admin with a different name (which is Synology's recommended practise for security).

 

If you can connect using your standard admin account, can you try sudo -s

I assume you have SSH open on 22?

I'm sorry but I'm pretty new to this end of it.

Can you explain what you wan't me to try more detailed please...

 

I guess sudo is a command you wan't me to type? in putty?

Share this post


Link to post
Share on other sites

I'm sorry but I'm pretty new to this end of it.

Can you explain what you wan't me to try more detailed please...

 

I guess sudo is a command you wan't me to type? in putty?

 

I assume at the moment from a command line you're typing:

chmod 755 config.php

 

try:

sudo chmod 755 config.php

 

If prompted for a password use your standard admin one (which is also the root).

 

 

Here's a really good article on securing your Syno.

https://www.synology.com/en-global/know ... orials/615

I know it's not relevant to your query but using the standard admin account isn't good practise and possibly the reason you can't get into your box using winSCP.

 

Create a new user, disable the admin account, then try winSCP again as root. Everything works like a charm.

Share this post


Link to post
Share on other sites

I'm sorry but I'm pretty new to this end of it.

Can you explain what you wan't me to try more detailed please...

 

I guess sudo is a command you wan't me to type? in putty?

 

I assume at the moment from a command line you're typing:

chmod 755 config.php

 

try:

sudo chmod 755 config.php

 

If prompted for a password use your standard admin one (which is also the root).

 

I actually haven't tried chmod from a command line... I've tried it from the GUI in the different clients.

 

I will try what you've suggested and report back

Here's a really good article on securing your Syno.

https://www.synology.com/en-global/know ... orials/615

I know it's not relevant to your query but using the standard admin account isn't good practise and possibly the reason you can't get into your box using winSCP.

 

Create a new user, disable the admin account, then try winSCP again as root. Everything works like a charm.

Share this post


Link to post
Share on other sites

Sorry I haven't replied, but I've been terribly busy...

 

It actually worked chmodding from command line, so the problem is solved...

 

Thanks guys :smile:

Share this post


Link to post
Share on other sites
Sorry I haven't replied, but I've been terribly busy...

 

It actually worked chmodding from command line, so the problem is solved...

 

Thanks guys :smile:

 

excellent. Is that with root or sudo?

 

Glad it's working ok

Share this post


Link to post
Share on other sites
Sign in to follow this