Recommended Posts

Hello - I have had a fully working NAS for many months with no hardware or software changes.  I needed to move some things around in my rack, so I shut DSM down properly via the GUI.  Moved the hardware where it needed to go, fired it back up.  I see the normal GRUB bootloader screen and gives the standard loader info.  However, I can now no longer find, ping, or even locate the NAS at all on the network.  It's like the network stack is dead.

 

For reference - DSM version is 6.2.3.xxxx (can't recall the exact subversion).  Jun's bootloader 1.03b for 3617+ on baremetal Chenbro NR12000 hardware (12 cores, 16GB of RAM).  PCI-E NIC ports are Mellanox 10gig which have been working fine for many months.  I never update DSM (no need to - it does all I need).  No one else has access to the machine, or login information.

 

When running, DSM does also see the NR12000's onboard NIC ports as LAN 3 and 4 IIRC, but I never configured them - why would I when I have 2 x 10gig fiber ports already running, lol?  Nevertheless I've tried those 1 gig copper ports in an effort to just see if I can get any type of networking running.

 

Advanced IP scanner doesn't show any IP's being assigned to any of the NICs (fiber or copper).  It seems like maybe the bootloader is dying before the network drivers are installed.  I don't see any link light on either Mellanox port and I feel like I should be.  Normally on a Windows system this means the driver hasn't been loaded yet.

 

How can I troubleshoot the network stack?  Don't have a null modem cable but I do have a Cisco console cable and an APC UPS serial cable if that helps :-)

 

I've reseated the Mellanox card multiple times, changed DAC cables, tried new upstream switch ports.  I have two more known good identical Mellanox cards I'll try to swap in and see if that makes any difference.

 

The only thing I can think of is that I may have changed the USB port that my boot drive was connected to.  Would that have made any difference?  It's still bootable from BIOS but would it somehow kill GRUB's ability to load DSM?

 

Thank you - I can try to provide additional info but it's challenging without DSM loading.

Link to post
Share on other sites

Forgot to mention - I of course tried find.synology.com and the Syno Assistant.  No dice on either and again, the normal IP address I have assigned to the unit doesn't show on Advanced IP Scanner either.

Link to post
Share on other sites
  • 5 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.