seaweasel

Datastore for DSM on Microserver with ESXi

Recommended Posts

Hi all

 

I'm familiar with DSM and some virtualisation such as Fusion, but I've got myself an HP Microserver G1610 and I'm trying to get it set up with ESXi 6 and Xpenology. I'm hitting a bit of a wall with the datastore though. I've a 32GB SanDisk Ultra Fit I'm using for ESXi and I'd also hoped to use to boot DSM, however this isn't available as a datastore using the ESXi Windows client, and I'm also having bother getting a SATA drive up and running with a datastore. I've stuck a 160GB drive in initially while I backup and format the larger drive from my old NAS, and I'm getting a 'cannot change the host configuration' error when trying to create a datastore with it (previously had a W8.1 install on it, and I think it was re-formatted by HP Intelligent Provisioning when I tried that).

 

Any tips for getting this formatted and available to ESXI? I have shell access set up for ESXi, but I'm also running into permission problems when I try and execute any commands (sudo not found, tried creating a new admin user instead of using root but not working with that either).

 

Any advice would be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

ESXi does not allow creation of a datastore on the USB. For this reason, it is good to use a minimal size USB since you are not going to be able to use the rest of the space on the drive.

 

I do recall sometimes having errors when trying to create a datastore on a SATA drive in ESXi 5.5 that had previously been used in another operating system. I do not recall the specific errors that I sometimes get, but in case it helps you I was able to get around the problem using one of the following methods:

 

1) Within ESXi, once again select the disk for creation of a datastore. There are at least two options for formatting (I do not recall the specifics) with one being "newer" and the other being "older" (e.g., v4 vs. v5, or something similar). I was getting an error message when I select the newer version. If I instead select the older version, the drive is able to be formatted and a datastore created. I do not know the practical difference of the older vs. the newer version, but I converted to the newer version by deleting the datastore/disk, and once again going through creation but this time selecting the newer version and proceeding to finish without an error.

 

2) Put the drive in a Windows machine and from the command prompt, run DISKPART, select the disk and run CLEAN

Share this post


Link to post
Share on other sites

HI,

 

ESXI DOES allow to create a Datastore on USB but not from the Windows Vsphere Client. please use ESXI command line tools.

 

My HP Gen 8 booting ESXi 6 and then Xpenology from a single 32 GB USB

 

Here is how I managed to create USB based data store

 

1. using "partedutil" to create a VMFS partition at the end of the used partitions in the USB after booting into ESXI server installed on the USB

- http://kb.vmware.com/selfservice/micros ... Id=1036609

- advice, please use the set option for all your partitions - NOT just for the new ones,

 

2. using "vmkfstools -C vmfs5 -b..." to create a data store on the new VMFS partition of required size

 

I have got 2 data stores , one to store the Expenology boot disk and one to store RDM mapping to my 3 TB drives.

 

I have not issues so far with the setup, and the Xpenology network share can saturate my 100 MBits/s LAN - wish I had a Gigabit one to test.

 

I also wish I had all the commands and the output while getting this setup, but hope this rough guide helps

Share this post


Link to post
Share on other sites

Also, another advice.. please make sure to backup your USB disk before you mess around the partitions with something like "USB Image Tool". will save the pain of reinstalling ESXI on your USB disk again.. and again..it took me couple of night to get the setup up and running with multiple restores from the USB Image Tool

Share this post


Link to post
Share on other sites

Thanks for the replies. I'd tried reformatting that temp disk to FAT in OS X but still the same error, did the same with my 1TB drive and vSphere doesn't seem to see that at all. Think I'll just go with a bare metal install for now to get up and running and then see about virtualising later (to be honest I've no pressing reason to use ESXi, was mostly out of curiosity and to get familiar with it).

 

Cheers.

Share this post


Link to post
Share on other sites