21gramm

Лицензиpoвaние камер как быть

Recommended Posts

Приветствую! Прежде всего, большое спасибо за патч.

Может кто сталкивался, после применения, камеры активируются, но если в параметрах просмотра в режими реального времени источник SurveillanceStation то картинки нет (записи так же нет), если с камеры - то картинка есть. Права у файлов group и owner SurveillanceStation 755. Пробовал переустанавливать, не помогло.

 

А что за камеры?

Share this post


Link to post
Share on other sites

А что за камеры?

У меня Axis 207 и 207W.

 

Удивительно, а проблемы именно на SS версии 8? Как работало на 7рке?

Share this post


Link to post
Share on other sites

Удивительно, а проблемы именно на SS версии 8? Как работало на 7рке?

Проблемка после применения патча, они и на 8 без патча нормально работают.

Share this post


Link to post
Share on other sites
Проблемка после применения патча, они и на 8 без патча нормально работают.

Вы патч применили на 8.0.0-5128? И у всех, у кого глючит - версия SS 8.0.0-5128?

Вернитесь на 8.0.0-5123.

Share this post


Link to post
Share on other sites
Очень вежливо запишусь в очередь на Evansport ds214Play :smile:

+100500

image.png

Пацаны, я всё понимаю, биткойны дико и неудобно итд, но ....эээм... вы можете устоятся в очереди, но мне сидеть и расковыривать новую платформу за пряники чтобы вы съекономили себе пару сот баксов...мммм...неа...

Share this post


Link to post
Share on other sites

Добрый день всем . Стояла ДСМ 5 и SS 7, неделю назад почитав форум и попробовав на тестовой виртуалке решил перейти на DSM 6 и SS 8 (8.0.0-5123 c патчем)

стоит около 10 камер (хиквизион и китайские по onvif) , если заходить с телефона приложением то все нормально . Но как только захожу либо через десктопный клиент или через браузер , при просмотре видео в реальном времени или в конфигурировании камер - То сразу все камеры отваливаются - видео нету , записи нету , само все восстанавливается если выйти . Тоже сначала обновился до последней версии SS , но затем откатился именно до той к которой сделан патч.

Что еще можно попробовать сделать ?

Share this post


Link to post
Share on other sites
Пацаны, я всё понимаю, биткойны дико и неудобно итд, но ....эээм... вы можете устоятся в очереди, но мне сидеть и расковыривать новую платформу за пряники чтобы вы съекономили себе пару сот баксов...мммм...неа...

А ведь при этом пользуется и не мало "корпоративных" клиентов, а не простые домашние пользователи.

Share this post


Link to post
Share on other sites
Добрый день всем . Стояла ДСМ 5 и SS 7, неделю назад почитав форум и попробовав на тестовой виртуалке решил перейти на DSM 6 и SS 8 (8.0.0-5123 c патчем)

стоит около 10 камер (хиквизион и китайские по onvif) , если заходить с телефона приложением то все нормально . Но как только захожу либо через десктопный клиент или через браузер , при просмотре видео в реальном времени или в конфигурировании камер - То сразу все камеры отваливаются - видео нету , записи нету , само все восстанавливается если выйти . Тоже сначала обновился до последней версии SS , но затем откатился именно до той к которой сделан патч.

Что еще можно попробовать сделать ?

Поддерживаю тему, при подключении десктопного клиента камеры отваливаются секунд на 10-15, при подключении мобильного - нет. При просмотре в режиме реального времени камеры периодически сами отваливаются в "Активацию" секунд на 10-15.

В чём проблема? такая фигня на всех обновлённых серверах! Версия 8.0.0-5123.

Share this post


Link to post
Share on other sites
Поддерживаю тему, при подключении десктопного клиента камеры отваливаются секунд на 10-15, при подключении мобильного - нет. При просмотре в режиме реального времени камеры периодически сами отваливаются в "Активацию" секунд на 10-15.

В чём проблема? такая фигня на всех обновлённых серверах! Версия 8.0.0-5123.

А это точно проблема патча и лицензий, а не самой SS? В обычной версии нормально работает? Может лучше обратиться к Сино?

У меня вроде такого не замечено или не обращал внимания, дома вроде как работали камеры так и работают, хотя не часто просматриваю - работает и работает.

Share this post


Link to post
Share on other sites
Поддерживаю тему, при подключении десктопного клиента камеры отваливаются секунд на 10-15, при подключении мобильного - нет. При просмотре в режиме реального времени камеры периодически сами отваливаются в "Активацию" секунд на 10-15.

В чём проблема? такая фигня на всех обновлённых серверах! Версия 8.0.0-5123.

А это точно проблема патча и лицензий, а не самой SS? В обычной версии нормально работает? Может лучше обратиться к Сино?

У меня вроде такого не замечено или не обращал внимания, дома вроде как работали камеры так и работают, хотя не часто просматриваю - работает и работает.

Без КРЯКА работает отлично, у меня домашний сервак с 2мя камерами без кряка не лагает

Share this post


Link to post
Share on other sites

Перезалейте патчер, пожалуйста. Версия 7 меня вполне устраивает, патчер буду хранить у себя.

 

Спасибо!

Share this post


Link to post
Share on other sites
Поддерживаю тему, при подключении десктопного клиента камеры отваливаются секунд на 10-15, при подключении мобильного - нет. При просмотре в режиме реального времени камеры периодически сами отваливаются в "Активацию" секунд на 10-15.

В чём проблема? такая фигня на всех обновлённых серверах! Версия 8.0.0-5123.

А это точно проблема патча и лицензий, а не самой SS? В обычной версии нормально работает? Может лучше обратиться к Сино?

У меня вроде такого не замечено или не обращал внимания, дома вроде как работали камеры так и работают, хотя не часто просматриваю - работает и работает.

Без КРЯКА работает отлично, у меня домашний сервак с 2мя камерами без кряка не лагает

КРЯК на 8 Surveillance station очень-очень сырой! Тестировал на нескольких серверах!

1. Камеры периодически уходят в активацию с прерыванием записи и воспроизведением в реальном времени (особенно при подключение десктопного клиента)

2. Не работают скриншоты, пишет ошибка

3. При добавлении новой камеры, все уходят в активацию!

 

Все вышеописанные глюки пропадали при удалении кряка!

Share this post


Link to post
Share on other sites

Я боюсь дело не в кряке, а в том как вы его установили, проверяйте и правьте права на перезалитые файлы, должно быть разрешение на запись и оунер должен быть сс, я уверен, что у вас не так, я сам не пользуюсь, но я проверял и все работает, а подобные проблемы наблюдаются именно в ситуации, что я описал.

Share this post


Link to post
Share on other sites
Я боюсь дело не в кряке, а в том как вы его установили, проверяйте и правьте права на перезалитые файлы, должно быть разрешение на запись и оунер должен быть сс, я уверен, что у вас не так, я сам не пользуюсь, но я проверял и все работает, а подобные проблемы наблюдаются именно в ситуации, что я описал.

Возможно, я не правильно сделал.

Я делал так:

 

Перезалил новые файлы, потом сделал:

chown SurveillanceStation:SurveillanceStation /var/packages/SurveillanceStation/target/sbin/ssd

chown SurveillanceStation:SurveillanceStation /var/packages/SurveillanceStation/target/lib/libsynoss_1.so

chgrp SurveillanceStation /var/packages/SurveillanceStation/target/lib/libsynoss_1.so

chgrp SurveillanceStation /var/packages/SurveillanceStation/target/sbin/ssd

 

chmod 755 /var/packages/SurveillanceStation/target/sbin/

chmod 755 /var/packages/SurveillanceStation/target/lib/

 

В чём может быть ошибка и как правильно?

И проблема не втом, что камеры не работают! Они работают, пишут, но часто вываливаются в активацию. Особенно при подключении ПКшного клиента...

Если кто может помочь, помогите пожалуйста.

Share this post


Link to post
Share on other sites

Проверил - права и вледелец были не SS , поменял . Без перезагрузки попробовал зайти - все отвалилось . Странно что не отваливается пару камер из 12 ( одна подключена локально в тот же роутер что и Суно , а вот еще 2 находятся совершенно в другом здании и подключены через интернет - проброс портов на роутере) . Человек из соседней темы по камерам подсказал попробовать сделать EoIP - что бы камеры и SS были в одной локалке. )

 

Или есть у кого все в одной локалке и все равно отваливается ?

Дальше пошел эксперементировать - взял чистую суно поставил последнюю SS с лицензией на 2 камеры , подключаю удаленную китайскую по ONVIF , Тест проходит типа все ок , но записи и картинки нету вобще нигде и никак .

Подключаю эту же камеру в DSM 5.2 и SS 7.xx все сразу норм - и картинка и запись идут .

После этого я вообще перестал что либо понимать.

Буду проверять камеры в локалке - сниму в здании - принесу домой , и надо почитать про EoIP может реально весь затык в пробросе портов.

И еще я не понял по поводу потоков TCP - UDP , у меня везде TCP , на udp меняю - камеры недоступны вообще

Share this post


Link to post
Share on other sites

В чём может быть ошибка и как правильно?

Вы зря пользуетесь чужими кривыми инструкциями ) проверьте кто владелец файла должен быть СС, последними командами вы ставите права на всю папку, этого не нужно, надо поставить только на эти файлы. Слишком много ненужных действий, возможно копи-паст в терминалку копирует лишние символы, вряд ли вы руками вбивали эти команды, проверяйте, что-то просто у Вас не так )))

 

Буду проверять камеры в локалке - сниму в здании - принесу домой , и надо почитать про EoIP может реально весь затык в пробросе портов.

У Вас скорее всего проблема в удаленном подключении, тут только эксперементировать 8-ка еще сыровата, может и в ней быть проблема

Share this post


Link to post
Share on other sites

В чём может быть ошибка и как правильно?

Вы зря пользуетесь чужими кривыми инструкциями ) проверьте кто владелец файла должен быть СС, последними командами вы ставите права на всю папку, этого не нужно, надо поставить только на эти файлы. Слишком много ненужных действий, возможно копи-паст в терминалку копирует лишние символы, вряд ли вы руками вбивали эти команды, проверяйте, что-то просто у Вас не так )))

Пробовал даже закидывать кряк в SPK файл и устанавливать - та же беда и проблемы!

Если у кого-то есть РАБОЧИЙ мануал по установке кряка - скиньте пожалуйста

Share this post


Link to post
Share on other sites

Так Вы посмотрели, кто владелец файлов и какие права на них в данный момент? Ну или когда проблемы )

 

ПыСы Инструкции хоть и кривые, но нормальные, все по ним сделать можно, только как я сказал, надо выставлять права, не на папку, а на конкретные файлы, а права других файлов не трогать, ну или все вбивать руками не доверяя копи-пасту или проверять посимвольно или хотя бы потом проверить результат )))

Share this post


Link to post
Share on other sites
Так Вы посмотрели, кто владелец файлов и какие права на них в данный момент? Ну или когда проблемы )

 

ПыСы Инструкции хоть и кривые, но нормальные, все по ним сделать можно, только как я сказал, надо выставлять права, не на папку, а на конкретные файлы, а права других файлов не трогать, ну или все вбивать руками не доверяя копи-пасту или проверять посимвольно или хотя бы потом проверить результат )))

 

На файл SSD права - владелец и группа - SS, права 755

На файл libsynoss_1 - владелец и группа - SS, права 644

 

Права точно как в оригинале, в чистом пакете!

Share this post


Link to post
Share on other sites
Так Вы посмотрели, кто владелец файлов и какие права на них в данный момент? Ну или когда проблемы )

 

ПыСы Инструкции хоть и кривые, но нормальные, все по ним сделать можно, только как я сказал, надо выставлять права, не на папку, а на конкретные файлы, а права других файлов не трогать, ну или все вбивать руками не доверяя копи-пасту или проверять посимвольно или хотя бы потом проверить результат )))

 

На файл SSD права - владелец и группа - SS, права 755

На файл libsynoss_1 - владелец и группа - SS, права 644

Права точно как в оригинале, в чистом пакете!

 

Проблемы при подключении ПКшного или веб клиента, изображение появляется не сразу, а камеры вываливаются в АКТИВАЦИЮ и в этот момент пропадает запись!

Иногда в активацию может вывалится и при просто работающем клиенте.

 

Пробовал экспортировать конфигурацию камер и подтягивать её на оригинальный пакет - всё работает отлично, без тормозов, картинка появляется мгновенно! Только работает всего 2 камеры((

Share this post


Link to post
Share on other sites

Ну Вам же неоднократно писали, что оба файла должны быть 755, в общем как я писал неоднократно, проблема в ваших настройках, вероятнее всего правах или переписано не так или еще что, но метод рабочий это точно, именно по описанию проблемы, косяк в правах на файл. Ищите, пробуйте )

Share this post


Link to post
Share on other sites

Уже год хочу спросить: а нафига все эти линуксовые премудрости с консолью и т.п.? Не проще ли сразу в пакете заменить патченый файл и установить его штатными средствами как обычное обновление??? Делается элементарно 7zip-ом, например. Открываете инсталляшку, находите нужный файл. Драг-н-дроп, заменили. Даже чайнику ничего сложного нет...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.