Jump to content
XPEnology Community

Shuttle XS35V3, not found by Synology Assistant. JMicron ethernet adapter not working


Recommended Posts

Hi folks,

Trying to get an old Shuttle mini-pc working with Xpenology.

Installing synoboot 1.02, 1.03 and 1.04 was no problem, system boots but no access on the JMicron NIC. Even tried cable between the Shuttle and my laptop "cable not connected".

Booting with the old harddisk on win10 brings back the NIC to live with normal internet access.


Guess Xpenology is not compatible with my NIC.

I read some topics on this item, but no clear solutions


Any ideas for solving are welcome




Link to comment
Share on other sites

maybe your topic isn't right, from my point of view blaming drivers is not the best starting point as lack of documentation, reading or experience is more often the case, so phrasing more cautiously is advisable, pointing a finger into the direction of coders or maintainers without even a shred of proof ... not a good starting point


in theory the driver for jmicron would be jme.ko and thats even available in jun's default driver set (i had to look, can't remember ever seen such nic irl, kind of exotic)

so it seems not likely that it is a driver problem because the loader comes with a matching driver (1.02/1.03/1.04)

you already ruled out cable problems as win10 works over network (i guess the system was rj-45 connected when testing)


cpu is a Cedarview from 3/2011, to old for 1.04b 918+, definitely not a problem with the nic with this loader as the kernel does not start to even load a driver


On 5/3/2021 at 1:30 PM, stevepin said:

Even tried cable between the Shuttle and my laptop "cable not connected".

thats not going to work as the loader uses dhcp and most people dont run a dhcp server on there laptops

(should work directly connected with this one https://xpenology.com/forum/topic/12422-xpenology-tool-for-windows-x64/)


as the bios seems not to be uefi (1.03b is not working in uefi mode) and 1.02b seems not to wok too (can do old bios and uefi) i'd suggest trying the mbr version of the loader


for just testing if its found in network you can just use the loader as it comes (vid/pid in grub.cfg is only needed when really installing dsm to disk) - makes things faster when testing with different loaders

i'd suggest loader 1.03b (mbr) as 1st try (doesn't matter if its 3615 or 3617)



  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...