Sign in to follow this  
dualvsta

Problème de plantage Xpenology + ESXI 6.0.0

Recommended Posts

Bonjour à tous,

 

Alors voila, j'ai rassemblé des vielles pièces qui trainaient pour me monter une configuration bidouille.

Cette configuration me permettra de manipuler des machines virtuelles pour ensuite me monter une installation efficace pour gerer et acceder à mes données.

 

La configuration est basée sur une carte mère Gigabyte GA-73PVM-S2H avec une chipset nForce 630i

Une modification a été faite sur le socket 775 pour acceuiller des processeurs Xeon en socket 771

Le processeur est un Xeon E5430

2x2 Go de DDR2 400 Mhz Gskill

 

J'ai installé Windows 7 X64 avec VMware workstation et j'ai créé une machine virtuelle pour faire tourner Xpenology et ça marche nickel chrome.

Aucun problème constaté.

 

J'ai voulu tenter l'installation d'un hyperviseur. J'ai donc installé ESXI 6.0.0 ce qui m'a posé quelques problèmes.

D'abords parce que je suis à la limite en terme de DDR2. Comme mon chipset graphique me pique des Mo, ESXI trouvait moins de 4 Go de ram.

Et il ne reconnaissait pas non plus mon controleur SATA.

J'ai trouvé des astuces sur internet et maintenant tout fonctionne nickel, j'ai monté Xpenology grace aux tutos et monté un disque dur de 1To en RDM.

 

Tout va bien sauf que, pendant un transfert de fichier, toute la machine plante.

Même ESXI plante. j'arrive a copier quelque Go et plus rien, obliger de rebooter.

C'est un phénomène que je n'ai pas du tout avec la machine virtuelle sous windows 7 + VMware.

 

La machine physique, même si c'est un peu bidouillée est propre ( alimentation Seasonic, gros dissipateur, rock stable sous OCCT )

 

Vous savez d'ou ça peut venir ?

 

Merci d'avance :smile:

Share this post


Link to post
Share on other sites

il me semblait qu'il y avait un topik sur le forun english mais j'arrive pas a remettre la souris dessus

Share this post


Link to post
Share on other sites

Quand tu dis :

J'ai trouvé des astuces sur internet et maintenant tout fonctionne nickel, j'ai monté Xpenology grace aux tutos et monté un disque dur de 1To en RDM.

... on parle de quelles astuces là, j'ai un peu peur de la réponse^^???

 

Sinon il est possible que ta RAM soit défectueuse. Fais un memtest.

Vérifie aussi que tu as activé les options de virtualisation dans le BIOS.

Share this post


Link to post
Share on other sites
il parle de monter les DD en RDM je pense

je doute car le pb venait de la quantité de RAM nécessaire à ESXi

Share this post


Link to post
Share on other sites

Alors non et non.

 

Je ne considère pas que monter les DD en RDM était une astuce.

C'était juste impossible au début puisque mon controleur SATA est non reconnu par ESXI 6.0.0

Vphère client ne trouvait alors aucun volume disponible.

 

Pour ça, je suis tombé sur ce lien : http://www.v-front.de/2013/11/how-to-ma ... -ahci.html

Cela m'a permis de faire reconnaitre mon controleur et donc, d'avoir accès à mes disques durs :smile:

 

Pour le problème des 4 Go de ram, j'ai simplement temporairement installé une carte graphique en PCI express.

ESXI trouvait donc bien mes 4 Go de ram et non pas 3.87Go et voulait donc bien continuer l'installation.

 

L'option de virtualisation est bien activée dans le bios.

 

ESXI + Xpenology plante que mon disque dur soit monté en RDM ou pas :sad:

Share this post


Link to post
Share on other sites

un truc m'échappe, comment Vsphere Client pouvait te dire que qu'il n'y avais pas de volume disponible si ESXi n'était pas encore installé? tu as 2 controleurs SATA sur ta carte mere ?

Share this post


Link to post
Share on other sites

ESXI ne veut pas s'installer si la RAM dispo est inférieur a 4 Go.

En revanche, ESXI m'a indiqué ne pas reconnaitre mon controleur SATA mais n'empeche pas son installation sur ma clé USB.

Share this post


Link to post
Share on other sites

ah ok je n'avais pas cette info!donc ton ESXi est installé sur une clé USB. Ne serait-elle pas défectueuse ?aurais-tu moyen d'avoir une autre carte controleur SATA en PCI-Express et compatible avec ESXI ?

 

car la manip pour rendre ton contrôleur actuel compatible me semble douteuse et tirée par les cheveux^^

Share this post


Link to post
Share on other sites

Je n'ai pas encore essayé avec mais j'ai une carte Asus U3S6 mais je n'ai pas vérifié si elle était supporté par ESXI.

Concernant la clé USB, ça m'étonnerait étant donné qu'elle boot bien, que je n'ai pas de message d'erreur et qu'ESXI se charge en RAM d'après ce que j'ai lu.

Donc une fois l'étape de boot passé, elle ne sert plus a rien la clé USB.

 

Bon j'ai installé ESXI 5.5 et j'ai pu récupéré mon install de DSM 5.2U4....et ben ça marche !

La ou ça plantait au bout de quelque Go ( genre 2 ou 3 ), la je suis rendu a 80Go sans problème :geek:

 

 

Si quelqu'un a l'explication, je suis peneur !

Share this post


Link to post
Share on other sites

eh bien une seconde raison pour laquelle je ne franchi pas le cap d'ESXi 5.5 vers 6.0!

 

La première étant le non support d'UPS lors de la migration

Share this post


Link to post
Share on other sites

Surtout que j'ai fait strictement la même chose pendant l'installation.

Y compris la bidouille qui te semblait louche pour faire reconnaitre mon controleur SATA.

 

Mais il y a des gens chez qui ça marche, il doit bien y avoir une raison !

Share this post


Link to post
Share on other sites

pourquoi ne pas installer directement XPEnology plutot que passé par un hyperviseur pour ne faire tourner qu'une VM si j'ai bien compri ?

Share this post


Link to post
Share on other sites

C'est parmi les grandes questions de la vie que je me pose :mrgreen:

 

Je ne suis pas du tout informaticien donc je ne fais certainement pas les choses dans les regles de l'art !

 

J'ai pour le moment une seule machine virtuelle mais je vais jouer un peu pour la dupliquer pour tester les mises a jours et augmenter un peu les services genre un firewall etc...

Share this post


Link to post
Share on other sites

on ne sait jamais ce que l'avenir nous réserve et qui peut le plus peut le moins donc avoir ESXi avec 1 VM est certe inutile en l'état, mais au moins cela te permet d'avoir une base pour ensuite en rajouter d'autres. Chez moi par exemple, j'ai XPenology + Windows 10 + CentOS. Mais au début je n'avais que Xpenology en natif et puis mes besoins ont vite grandi!

Share this post


Link to post
Share on other sites
on ne sait jamais ce que l'avenir nous réserve et qui peut le plus peut le moins donc avoir ESXi avec 1 VM est certe inutile en l'état, mais au moins cela te permet d'avoir une base pour ensuite en rajouter d'autres. Chez moi par exemple, j'ai XPenology + Windows 10 + CentOS. Mais au début je n'avais que Xpenology en natif et puis mes besoins ont vite grandi!

Bonsoir, Je suppose que vous attaquez les vm seulement via vsphere client ? Pas de possibilité d'avoir un écran+clavier +souris pour chaque vm ?

Je n'ai pas encore osé de m'aventurer sur ce terrain car très peu de retour...

 

Envoyé de mon SM-N910F en utilisant Tapatalk

Share this post


Link to post
Share on other sites
on ne sait jamais ce que l'avenir nous réserve et qui peut le plus peut le moins donc avoir ESXi avec 1 VM est certe inutile en l'état, mais au moins cela te permet d'avoir une base pour ensuite en rajouter d'autres. Chez moi par exemple, j'ai XPenology + Windows 10 + CentOS. Mais au début je n'avais que Xpenology en natif et puis mes besoins ont vite grandi!

 

As tu configurer un raid au niveau du controleur de ta carte mère ?

Share this post


Link to post
Share on other sites

Bonsoir, Je suppose que vous attaquez les vm seulement via vsphere client ? Pas de possibilité d'avoir un écran+clavier +souris pour chaque vm ?

Je n'ai pas encore osé de m'aventurer sur ce terrain car très peu de retour...

 

Envoyé de mon SM-N910F en utilisant Tapatalk

 

Il faudrait configurer un pass-through sur la CG et port usb clavier/sourie pour les connecter directement a ta VM mais j'ai pas testé

Share this post


Link to post
Share on other sites

Bonsoir, Je suppose que vous attaquez les vm seulement via vsphere client ? Pas de possibilité d'avoir un écran+clavier +souris pour chaque vm ?

Je n'ai pas encore osé de m'aventurer sur ce terrain car très peu de retour...

 

Bonjour,

 

Je dispose d'un HP N54L qui n'offre pas la possibilité du passthrough. Donc il m'est impossible de dédier la sortie VGA de mon serveur à une VM (ici Windows 10 pour mon cas). Ce que je fais c'est du bureau à distance en RDP (bien plus efficace que VNC car utilise un cache)

Share this post


Link to post
Share on other sites

As tu configurer un raid au niveau du controleur de ta carte mère ?

Bonjour,

 

J'ai 3 disques durs (1 de 250Go, et 2 de 2To). Très honnêtement je ne m'en rappelle plus^^ mais j'ai du mettre la conf SATA en AHCI je crois. Le RAID du DSM est directement gérer par DSM car mes disques sont reliés en RDM d'un point de vue VMWare.

Share this post


Link to post
Share on other sites

As tu configurer un raid au niveau du controleur de ta carte mère ?

Bonjour,

 

J'ai 3 disques durs (1 de 250Go, et 2 de 2To). Très honnêtement je ne m'en rappelle plus^^ mais j'ai du mettre la conf SATA en AHCI je crois. Le RAID du DSM est directement gérer par DSM car mes disques sont reliés en RDM d'un point de vue VMWare.

Pareil pour moi, je l'ai ai mis en rdm. Par contre, je n'ai pas encore changé l'adresse mac. Est-ce nécessaire ? Quel serait l'utilité à part utiliser le service Quick connect?

 

Envoyé de mon SM-N910F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

initialement je n'ai pas changé l'@mac. j'ai ensuite essayé de le faire depuis dans le soucis de faire marcher le service Push mais sans succès. Tout est controler par Synology :/ Donc avec XPenology c'est impossible depuis la version 5.0.

 

Perso, je n'ai pas besoin du quick connect dans la mesure où j'ai un nom de domaine rattaché à une ip fixe.

Share this post


Link to post
Share on other sites

As tu configurer un raid au niveau du controleur de ta carte mère ?

Bonjour,

 

J'ai 3 disques durs (1 de 250Go, et 2 de 2To). Très honnêtement je ne m'en rappelle plus^^ mais j'ai du mettre la conf SATA en AHCI je crois. Le RAID du DSM est directement gérer par DSM car mes disques sont reliés en RDM d'un point de vue VMWare.

 

Est ce que ces VM supplémentaire sont critique ou juste pour des test ?

Share this post


Link to post
Share on other sites
Sign in to follow this