Sign in to follow this  
ayates

Issues after upgrading from DSM 5.1-5022.3 to 5.2-5592.2

Recommended Posts

Hi,

 

A few months ago I setup my first XPEnology running as a VM on ESX 5.5 on Lenovo TS140. I used DSM 5.1-5022 Update 3 as my initial build. The VM is configured with 1x IDE HD for the xpenoboot, 1x SCSI HD for Diskstation and Packages, then I have 4 RDM links to my 4x 4TB HD. Once in Diskstation I then have Volume1 (The single disk with Diskstation/Packages) and Volume 2 (SHR consisting of the 4 HDs for my Data), the IDE boot drive I have configured to be hidden.

So this was all working fine for many months until I decided to try and upgrade to 5.2.

 

Before I did the upgrade I obviously wanted to protect myself in case something went wrong so I took not only a snapshot but I also shutdown the VM and took a complete copy of the whole VM so I could restore to it if I needed.

 

I then proceeded with the upgrade but I must admit that when I did the 5.2 upgrade I made a mistake. I booted correctly from the new XPEnoboot image and selected the Install/Upgrade option, I then connected to with Synology Assistant to go through the upgrade/migration process but the mistake I made was I let it download the update from Synology rather than the manual option and using correct PAT file.

 

Once the upgrade completed I found I could no longer access Diskstation and Synology Assistance could no longer see it, however I could still access my Data/Media and Plex was still running and functioning so I knew Diskstation was running. I eventually managed to get into Diskstation, can't remember what I did, but it showed my Volume had crashed and going into Storage Manager it wouldn't show any Volume or Disk information and eventually showed a connection error. However I knew my Volumes were still all okay because the packages are still running (which are on Volume 1) and all my data was still accessible (which is on Volume 2).

 

Now since I had backups I thought, no problem, restore my snapshot, but this oddly made no difference, it was still not showing my Volumes in Storage Manger and Synology Assistant could still not see it. I then tried restoring the whole VM, again no difference. I believe it did revert the DSM version but could not understand why my volumes still did not show.

 

So next after reading some posts I tried to downgrade, the problem here is that I need Synology Assistant to work which it didn't at first. However I found that if I removed all my RDM connections first and then booted up it all worked normally again, I could access with Synology Assistant, I could downgrade/upgrade without issue and in Diskstation I could see Volume 1 and the Disk without any errors.

 

From what I understand from what I've read on here, taking a snapshot/copy of the VM was in some ways pointless, because apparently some of the Synology install/configuration is installed to all attached disks. So I guess even though I've resolved the main DSM install, whatever configuration information that is on my Data disks is causing the issues.

 

So I guess my question is.. is there anyway I can fix this, without having to copy 10TB of data to somewhere else and then rebuilding Volume 2?

 

Oh one of thing, when I boot in Debug mode, without the RDM connections, I do see it say md2 unknown partition table, and with the RDM connections it says if for md2, md3 and md4, so maybe that is related.

 

Cheers for help.

Share this post


Link to post
Share on other sites
Sign in to follow this