Все еще на DSM 6.1.7-15284. СтОит ли апгрейдится?


Recommended Posts

У меня HP Microserver GEN8 with Xeon E3 processor. Установлена старая DSM 6.1.7-15284 (ds3615xs) от 2018/05/19.

Используется как домашний файл-сервер, hyper backup, Photo Station, media server, vpn server.

Давно не апгрейдил DSM, не следил за новостями и немного отстал от жизни :-). Даже не помню какой у меня bootloader...
Что мне даст апгрейд на более свежую DSM? На какую версию советуете обновлятся и какой бутлоадер использовать?

Еще я использую free Let's Encrypt certificate, и они прислали мне емейл о том, что мой клиентсий софт использует устаревший протокол ACMEv1, предлагают переходить на ACMEv2, иначе скоро все :-). Апгрейд DSM поможет с этой проблемой?

 

Ну и что б дважды не вставать - такой же вопрос в отношении старого NASа для бекапов - HP Microserver GEN7 с родным АМД процессором.
Сейчас на нем установлена та же DSM 6.1.7-15284. Только Lets Encrypt на этом NASе не используется...

 

Edited by SergeS
Link to post
Share on other sites

Апгрейдиться стоит, хотя бы потому, что потом будет сложнее накатывать новую версию. Прецедентов много и нет смысла их перечислять. 

На оба девайса прекрасно встаёт последняя версия DSM - https://archive.synology.com/download/Os/DSM/6.2.3-25426-3

Только сначала поставьте релиз, потом Апдейт: https://archive.synology.com/download/Os/DSM/6.2.3-25426

Загрузчик 1.03b https://mega.nz/#F!yQpw0YTI!DQqIzUCG2RbBtQ6YieScWg!7AoyySoS

  • Thanks 1
Link to post
Share on other sites
2 minutes ago, i926 said:

Апгрейдиться стоит, хотя бы потому, что потом будет сложнее накатывать новую версию. Прецедентов много и нет смысла их перечислять. 

На оба девайса прекрасно встаёт последняя версия DSM - https://archive.synology.com/download/Os/DSM/6.2.3-25426-3

Только сначала поставьте релиз, потом Апдейт: https://archive.synology.com/download/Os/DSM/6.2.3-25426

Загрузчик 1.03b https://mega.nz/#F!yQpw0YTI!DQqIzUCG2RbBtQ6YieScWg!7AoyySoS

Спасибо! По моему у меня именно этот (1.03) загрузчик и стоит... Я так понимаю, что тогда его и перезаписывать не обязательно?
Просто делаешь бекап (на всякий случай), потом накатываешь ДСМ релиз с вашей ссылки, должен предложить миграцию, но если нет - то чистая установка и восстановление из бекапа.
Ну а потом уже накатываешь ДСМ апдейт опять же по вашей ссылки.
Так? Вроде раньше примерно так делал :-)

Link to post
Share on other sites
1 час назад, SergeS сказал:

Спасибо! По моему у меня именно этот (1.03) загрузчик и стоит... Я так понимаю, что тогда его и перезаписывать не обязательно?

Уточните, так как их там два 1.03 загрузчика. Ну и я бы советовал записать по новой загрузчик.

Ну а так, всё просто, Миграция и Восстановление. Сделайте резервную копию настроек, потом, случись чего, восстановитесь из неё 

Апдейт можно и из панели обновить.

Link to post
Share on other sites
Posted (edited)
4 hours ago, i926 said:

Уточните, так как их там два 1.03 загрузчика. Ну и я бы советовал записать по новой загрузчик.

Ну а так, всё просто, Миграция и Восстановление. Сделайте резервную копию настроек, потом, случись чего, восстановитесь из неё 

Апдейт можно и из панели обновить.

Спасибо. обновился на GEN8 пока. Загрузчик был старый, еще 1.02.
Установка релиза, миграция и апдейт пакетов прошли без проблем. Вроде даже все настройки сохранились, пока не вижу, что слетело.

Но установка Update 3 из DSM почему то не проходит, где то на 91% говорит, что "Fail to update the file. The file is probably corrupt."

Рестарт не помогает, то же самое. Прбовал вручную скачать Update 3 и сделать Manual DSM Update - та же ошибка...

 

Что может мешать?

 

Edited by SergeS
Link to post
Share on other sites

Причина ошибки :"Вероятно, файл поврежден" - обычно кроется во флешке. Попробуйте заменить её.

У меня тоже при переходе на 6.2.3 подобная ошибка была и помогла только замена флешки.

Link to post
Share on other sites
On 3/23/2021 at 6:03 PM, i926 said:

Апгрейдиться стоит, хотя бы потому, что потом будет сложнее накатывать новую версию. Прецедентов много и нет смысла их перечислять. 

На оба девайса прекрасно встаёт последняя версия DSM - https://archive.synology.com/download/Os/DSM/6.2.3-25426-3

Только сначала поставьте релиз, потом Апдейт: https://archive.synology.com/download/Os/DSM/6.2.3-25426

Загрузчик 1.03b https://mega.nz/#F!yQpw0YTI!DQqIzUCG2RbBtQ6YieScWg!7AoyySoS

 

На 6.2.4-25556 - низзя! Я правильно понимаю?

 

Link to post
Share on other sites

Да, никак нельзя. Эта версия в преддверии Седьмой, она пока не имеет загрузчика 

  • Thanks 1
Link to post
Share on other sites
Posted (edited)

C N54L все получилось без проблем, update 3 установился без вопросов...


А с Gen8 - проблема, как я выше написал, релиз установился, а апдейты не хотят... Поменял флешку, записал бутлоадер заново, подредактировал конфиг так же как и раньше, запускаю, предложило recovery (а не migration, как раньше), без вариантов... Согласился - все, дальше тишина, доступа нет.

Что я делаю не так?

 

Edited by SergeS
Link to post
Share on other sites
1 hour ago, SergeS said:

C N54L все получилось без проблем, update 3 установился без вопросов...


А с Gen8 - проблема, как я выше написал, релиз установился, а апдейты не хотят... Поменял флешку, записал бутлоадер заново, подредактировал конфиг так же как и раньше, запускаю, предложило recovery (а не migration, как раньше), без вариантов... Согласился - все, дальше тишина, доступа нет.

Что я делаю не так?

 

Странно, выключил, включил - все на месте :-). Потом накатил Апдейт3 - опять при перегрузке ушло в вечность, но выключил-включил - апдейт 3 на месте. Ладно, оставим так, спасибо всем!

Link to post
Share on other sites

Если какие то проблемы по Обновлении, к слову, у меня при обновлении тоже система заглючила, то возможно имеет смысл снести /etc.defaults

1. Удалить папку /etc.defaults . Необходим так называемый ROOT доступ

https://www.synology.com/ru-ru/knowledgebase/DSM/tutorial/General_Setup/How_to_login_to_DSM_with_root_permission_via_SSH_Telnet

2. Перезагрузить Хрень и установить DSM заново

3. Восстановить конфигурацию из *.dss . До всех манипуляций, Обязательно сохранить резервную копию настроек

4. Установить необходимые приложения, настройки должны сохраниться.

5. Радоваться Жизни и Хрени ...))))

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.