benok

SSD Cache works on 5.2

Recommended Posts

ssdcache1.png

 

ssdcache2.png

 

SSD Cache works at last ! :smile:

 

XPenoboot 5.2-5592.1

DSM 5.2-5592.1

ESXi 6.0

Marvell 88SE9230 (passthrough)

Plextor PX-256M5S

 

It was unstable first.

In my case, 2nd SSD got several errors.

(didn't get error on GUI. confirmed with tail -f /var/log/kern.log.)

 

First I think it's trouble with my drive, but it was a problem of my SATA card.

It works with port 1 & port 3 but not works with port 2 & port 4.

After I choose port 1 & port 3 for my SSDs, it's very stable.

 

My impression of SSD cache performance is "not so bad".

A little worse than my expect. :wink:

 

Perhaps, did you check the Syno's HCL ?

https://www.synology.com/en-global/comp ... 2+SATA+SSD

I was lucky to have two SSDs listed on HCL. :grin:

 

p.s.

I want to use 5.1 which doesn't have NFS VAAI problem (see http://xpenology.com/forum/viewtopic.php?f=2&t=6513),

but with 5.1, VM hangs up with esxi too, without PSOD. (Need to hard power off).

If only we don't have NFS problem with 5.2. :sad:

Edited by Guest

Share this post


Link to post
Share on other sites

That's great news that it is working under 5.2 Like you , I also use VAAI on the box that would benefit the most from SSD cache, so I left it on 5.1 for now without SSD cache. VAAI is more important to me than SSD cache at this time. I am using NFS to ESXi 5.5.

Share this post


Link to post
Share on other sites

Hmm, I also may get back to 5.1 too.

I'm using iSCSI with old servers, but it's inconvenient to tweak vmx file or backup VMs.

NFS is so convenient to edit vmx directly from CIFS, and backup directly thin VMs from XPEnology with tar with sparse(S) option.

So I want to migrate old iSCSI VMs to new server with NFS & VAAI.

 

I didn't see kernel module difference between XPE5.1 & 5.2, but something would wrong with 5.2 arond NFS. :sad:

Share this post


Link to post
Share on other sites

I didn't see kernel module difference between XPE5.1 & 5.2, but something would wrong with 5.2 arond NFS. :sad:

 

I found 5.2's NFS trouble of my environment is hardware problem.(viewtopic.php?f=2&t=6513)

VAAI plugin doesn't work on 5.2, but using NFS without VAAI seems to be stable.

 

p.s.

I found Time Backup can't be used with SSD read-write cache. see below. :sad:

http://forum.synology.com/enu/viewtopic ... 6&t=102391

Share this post


Link to post
Share on other sites