Installing xpenology on a dell R730xd


Recommended Posts

It is not possible to put xpenology on this server, every other time it dont sees the network when starting the loader, or it freezes at the moment of loading .pat and its installations

 

inside there are such network cards:
QLogic 577 xx/578xx 10 GB Ethernet BCM57840

BRCM 10G/Ge 2+2P 57800-t rNDC

PERC H730 Mini in mode HBA

 

I tried both 3615 and 3617.....who knows how to do it tell me pls pls pls)))

Edited by ttsume
Link to post
Share on other sites
4 hours ago, ttsume said:

QLogic 577 xx/578xx 10 GB Ethernet BCM57840

BRCM 10G/Ge 2+2P 57800-t rNDC

bnx2x.ko, should work

4 hours ago, ttsume said:

PERC H730 Mini in mode HBA

lsi sas 3108 based, mpt3sas.ko, should work too

 

i's sugegst using the extra.lzma for a newer driver for the nic

you did not specify what loader / dsm version you used, might be 1.03b dsm 6.2.3? (6.2.4 is not working)

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

please describe in more detail what you have done/used

did you follow a tutorial?

Link to post
Share on other sites
Posted (edited)

I used bootloader 1.03 and 1.02 (3615 and 3617)
I also tried to load the file with extra.lzma drivers
But the result is a hang at the time of installation .pat or does not see the network

Edited by ttsume
Link to post
Share on other sites

if you try 1.03b then you will need to use csm/legacy mode in uefi bios and also need to select the non uefi usb boot device

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

also you can't use 6.2.4, try 6.2.0 and the update to 6.2.3

 

just for testing you might try to install with loader 1.04b/918+, you cpu seem new enough (needs haswell or newer)

(it not so preferable because of the lis sas driver problems but might get you some experience on installing)

 

On 3/4/2021 at 8:19 AM, ttsume said:

But the result is a hang at the time of installation .pat

are you sure there is no error?

also i'd expect there would be a difference with 1.02b and 1.03b, like 1.03b not shown in network (as of uefi csm problem)

what happend with 1.02b and installing the pat file, it usually installs and then reboots, so where exactly did it stop?

did you use the webinterface or did you use synology assistant? i usually use the assistant as it seemed more reliable to find the loader in notweork

 

Link to post
Share on other sites

I will describe my server in more detail 

 

2x Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz

3x Samsung SSD 860

PERC H730 Mini

RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

QLogic 577xx/578xx 10 Gb Ethernet BCM57840 

 

What I've already tried:

bootloader 1.03b install DSM_DS3615xs_23739.pat does not work

bootloader 1.03b install DSM_DS3615xs_24922.pat does not work

bootloader 1.03b install DSM_DS3617xs_23739.pat does not work

bootloader 1.03b install DSM_DS3617xs_24922.pat does not work

 

I also tried adding

extra3615_v0.5_test does not work

 

 

 

16 hours ago, IG-88 said:

if you try 1.03b then you will need to use csm/legacy mode in uefi bios and also need to select the non uefi usb boot device

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

also you can't use 6.2.4, try 6.2.0 and the update to 6.2.3

 

just for testing you might try to install with loader 1.04b/918+, you cpu seem new enough (needs haswell or newer)

(it not so preferable because of the lis sas driver problems but might get you some experience on installing)

 

are you sure there is no error?

also i'd expect there would be a difference with 1.02b and 1.03b, like 1.03b not shown in network (as of uefi csm problem)

what happend with 1.02b and installing the pat file, it usually installs and then reboots, so where exactly did it stop?

did you use the webinterface or did you use synology assistant? i usually use the assistant as it seemed more reliable to find the loader in notweork

 

 

 

 

 

Link to post
Share on other sites
6 hours ago, ttsume said:

bootloader 1.03b install DSM_DS3615xs_23739.pat does not work

bootloader 1.03b install DSM_DS3617xs_23739.pat does not work

these two are ok and should work atleast with the realtek - if you use csm mode

 

 

6 hours ago, ttsume said:

bootloader 1.03b install DSM_DS3615xs_24922.pat does not work

bootloader 1.03b install DSM_DS3617xs_24922.pat does not work

why that? its 6.2.2  and need a special extra.lzma to even boot properly, last thing to use as its also replaced by 6.2.3

 

either install with 6.2.0 or 6.2.3 and use the original extra or the latest one made for 6.2.3

 

 

6 hours ago, ttsume said:

I also tried adding

extra3615_v0.5_test does not work

thats a old version and you should always look at the threads topic before downloading if it matches the version you are using

 

i'd suggest use 1.03b 3617 as it comes, no modifcation, use the realtec card and try to find it in network, if it does not show up assume you did something wrong about uefi csm mode

if you can't see where you go wrong the try the same with 1.02b 3617, no mods just as it comes, as this version can do uefi and legacy/csm it should work

only if you find it in network you can start modding grub.cfg for usb vid/pi, as long as you dont master it to find it in network its a waste of time tinkering grub.cfg or use a different extra.lzma (as realtek 8168/8111 sould work ootb with jun's extra.lzma)

 

 

 

Link to post
Share on other sites

If I were you, I would just install ESXi 6.7 or 7.0 and run Xpenology on this with hardware redirect of hard disks into the virtual machine. That way network drivers is of no problem as you just run it with either virtual Intel 1Gbps nics or the VMware vmxnet3 virtual nics. Sure, it's been a while since I did this, as I'm now running it directly on a Supermicro S9XCL mainboard, but when I did run it under ESXi it did run just fine.

Link to post
Share on other sites
Posted (edited)

I checked both versions, and neither was installed.
The installation begins and the moment of transfer of the pat file to install it cannot load completely, I did via a web browser chrome at the time of transfer in the lower left corner is always read as 0%(send status of the file upload), but the meter is in the center of the screen says that the installation continues up to 95% and hangs....
I think the problem lies in the support for controller perc H730, or the problem is that this server configuration the two socket and the system just can't work with this chipset(C610/X99 )

On 3/12/2021 at 11:24 PM, IG-88 said:

 

Edited by ttsume
Link to post
Share on other sites
5 hours ago, ttsume said:

I think the problem lies in the support for controller perc H730,

if it finds a disk to install to the controller is working

if you used loader 1.03b and dsm 6.2.0 or 6.2.3 then the drivers should work too (6.2.2 aka 24922 is incompatible when it comes to drivers)

 

maybe use the serial console to see whats going on, the unit seems to have a serial port so you could use a null-modem cable to connect with putty

or the iDRAC can give a virtual comport to use over network (like hpe iLO)

its unusual to just freeze, there is usually a error with a number

(you did read the tutorial about usb vid/pid in grub.cfg?)

 

Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)

unfortunately no, it was not possible to win work on the 30th series, I tried it on r630\730, I also tried it on r620, it was installed immediately without any manipulations, so I had to switch to the platform with supermicro +hba card, everything immediately worked perfectly...

5 hours ago, George300 said:

Hello 

 

R430 I encountered the same problem, the installation starts but 95% hangs.

 

Were you able to find a solution to the problem?

 

George

 

 

Edited by ttsume
Link to post
Share on other sites

 

5 hours ago, George300 said:

R430 I encountered the same problem, the installation starts but 95% hangs.

Were you able to find a solution to the problem?

in some cases it is possible to install on a different system and after installing take disk and usb flash drive to the other system that did not install

Link to post
Share on other sites

Hi Masters, Thank you so much for all the valuable advice.

 

So the H730 is causing the problem. :( If I understand correctly, I have 3 options:

 

1) I install it on another device and then move the hard drive to the R430.

2) VMware ESXI 7.0 + DSM

3) I'm buying a Supermicro HBA card ... Please enter the model number (article number) of the card you are using successfully in R630.

 

In addition to the above, other tips, advice? You advise you which version?

 

George

 

Link to post
Share on other sites

Dear All

 

By moving the hard drive, I was able to start the software on the R430. I see the device on the network and the ping is fine. In contrast, neither the assistant nor the browser sees it. Network card configuration problem may be the cause? Proposal

 

George

Link to post
Share on other sites
1 hour ago, George300 said:

I see the device on the network and the ping is fine. In contrast, neither the assistant nor the browser sees it. Network card configuration problem may be the cause? Proposal

if its booting on the R430 you could switch it off and then use a rescue linux to mount the system partition and then extract /var/log/dmesg, we would be able to see what driver is loaded

 

just to make sure - you dont use the same loader (same mac addrerss in grub.cfg) more then once in you network?

check you dhcp server (internet router?) for info's about ip and mac

 

Link to post
Share on other sites

I entered a fixed IP address outside the DHCP domain with no error.

I checked the R430 has a Broadcom Gigabit Ethernet BCN57020 network card. :( Unfortunately the card is not supported.

 

Is there a dual 1 GB network card proposal recommended for Dell R430 / 630/730 server?

Link to post
Share on other sites
  • 3 weeks later...
On 3/27/2021 at 8:33 AM, George300 said:

I checked the R430 has a Broadcom Gigabit Ethernet BCN57020 network card. :( Unfortunately the card is not supported.

i do have all the usual braodcom drivers for dell in my extra.lzma

i guess yours is BCM5720 and that should be working with tg3.ko

if you have pci vendor and device id i can check if its in the driver

imho it should work, try 3615 and 918+ (r430 seems to be haswell, so 918+ should work)

 

On 3/27/2021 at 8:33 AM, George300 said:

Is there a dual 1 GB network card proposal recommended for Dell R430 / 630/730 server?

any intel based will do, there seem to be a lot hpe quadport intel nic's around, maybe you can get one for cheap

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.