HELP !! DSM 6.1 or DSM 6.2 from Synology with XPEnology on QNAP TS-269-Pro


Recommended Posts

Hello everybody

I need your help because I am standing still!

I have a QNAP TS-269Pro with the QNAP operating system 4.3 and I'm not satisfied and it is a cumbersome system.
I really like Synology's DSM.
I would like my QNAP TS-260Pro with DSM 6.x ...? to install.

I downloaded the XPENOLOGY tools and tried them out.

 

I've tried all 3 types of Synology NAS.
DS3615XS and DS3617XS do not start at all.
The only one is the DS916 +, which boots from the USB USB-STICK and I can almost install the DSM 6.2. However, it breaks off with error 13 every time in 57%.


In the forum I read that it is often due to errors in the configuration (wrong VID or PID) but the singd genua entered correctly as USBDeview shows..
The MAC address matches the effective MAC address of the QNAP TS269Pro.
 

I also tried to install the DSM 6.1, but 57% of them get error 13 and the installation breaks off.

OSFMOunt in the grub.cfg
the right ones:
set vid = 0xfrom USB stick
set pid = 0xfrom USB stick
set sn = generated Serial Number
set mac1 = MAC from my real TS-269Pro


I don't know what to do anymore, does someone have a tip / help ???

 

best regards

peppi

Link to post
Share on other sites

error 13 usually point to usb vid/pid problems, you dont have to care about sn and mac for testing, that can be changed later even after installing

found this one in the forum, bios settings might be the interesting part

https://xpenology.com/forum/topic/2795-xpenology-on-qnap-ts269pro/

 

3615/17 loader 1.02b dsm 6.1 are usually working as it supports legacy bios and uefi, 1.03b is csm/legacy only

1.04b is not possible with this hardware

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

for your 916+ boot

if you have another x64 hardware you can use the usb and a disk from the qnap and try to install on this hardware, if that works you can transfer usb and disk to the qnap and boot it there, if there is a special install problems this might skip the install step, the ram might be a little thin with 1GB

2GB should work but i dont know if 1GB is ok

 

11 hours ago, peppi01 said:

The only one is the DS916 +, which boots from the USB USB-STICK and I can almost install the DSM 6.2.

916+ is loader 1.02b and dsm 6.1

 

maybe qnap 269 is uefi, then for 1.03b you would need to use csm/legacy mode AND you nee to choose the non-uefi boot device

see the following example from qnap, the sandisk cruzer is there 2 times, the one with "uefi:... " is not right for csm mode, if that is used the its still booting in uefi, csm is a option an it needs the usb legacy boot device be get used

https://www.qnap.com/en/how-to/tutorial/article/updating-the-bios-on-a-qnap-nas/

 

GUID-D17C6BE8-7395-42F5-9B52-3F525079B74

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.