How to disable Dell OptiPlex "No hard drive detected" when rebooting?


Recommended Posts

Noob question, not directly related to Xpenology setup.

 

Whenever I reboot Xpenology or shut it down and turn on again, a warning screen shows up on startup saying "No hard drive detected". I have to click continue for it to disappear, and then the PC would restart again but this time it loads Xpenology.

 

I tried fiddling with the boot priorities, disabling eufi, disabling errors/warnings in bios, but nothing works.

 

This error forces me to be physically go next to the PC and hit enter whenver I need to restart Xpenology.

 

All hard drives are connected to a SAS controller. All SATA connections on the motherboard are empty.

 

Thanks!

20210227_005815.jpg

Edited by gameboy
Link to post
Share on other sites

have'nt seen bios option of dell, so only generic suggestions

beside disabling any boot options other then usb you could also disable sata in bios

maybe it helps if you connect one drive (even if not using it in dsm) to a sata port or you connect one of the drives from the lsi (the chipset sata's are usually not that bad)

  • Thanks 1
Link to post
Share on other sites

Thanks! I tried changing boot priorities but nothing worked. However your suggestion regarding disabiling SATA ports might work. I'll give it a shot. Otherwise I'll connect one drive to motherboard SATA and see how it goes. Thanks for the idea! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.