• 0

Redoing NAS (XPEnology) with SABnzbd in Docker; cannot change default port (and is driving me nuts).


Question

Hi all,

Been busy with this from early this morning; long story short, I managed to setup SABnzbd, Sonarr, Radarr and got them working. I could change the default ports for Sonarr and Radarr without any issues... These are all running from a XPEnology NAS with Docker.
 

However changing the default port for SABnzbd (from 8080 to something like 13502) is becoming a real pain. Every single time I change it to a different port and restart, reboot, whatever. It will go back to port 8080. I have no clue how to force a different port. I tried a ton of things including editing the sabnzbd.ini file and change the port there, but it simply gets reset.
 

Sidenote; if I change the HTTPS port it will work, however it's not possible for me to get a Let's Encrypt certificate on the hostname XPEnology NAS (using afraid.org DDNS service).

Anyways, can someone tell me how I can change the default port for SABnzbd running through Docker? I don't want to use the default port.
 

I think the issue is related to how SABnzbd is started from Docker:
2021-02-22 13:52:39,987::INFO::[SABnzbd:1162] Arguments = "/app/sabnzbd/SABnzbd.py" "--config-file" "/config" "--server" "0.0.0.0:8080"
 

But I have no clue on how to change that port number (and where).
 

Maybe someone has some advice for me or can help me? This is driving me nuts!
 

Thanks!

Regards,
HHawk

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hi Dfds,

Thank you for responding, but now (for me at least) where do I add that exactly.
I did read something about it, but I have no idea where to exactly add that to be honest. I did search XPEnology NAS for something like that (to add it), but could not find it. :(

My previous build didn't use Docker at all (installed it from packages back then). I upgraded the old DSM 5.x to DSM 6.x about 2 years ago and decided to finally upgrade everything (in terms of hardware) and redo my complete setup agian, but this time with Docker.

Sorry for my ignorance.

Regards,
HHawk

 

 

//edit

 

I searched Google for that file: docker-compose.yml.
It should be located in /volume1/@docker/ however nothing is there. Only a bunch of other directories. :(

Edited by HHawk
Added more information.
Link to post
Share on other sites
  • 0

I actually meant the docker compose script for SABnzbd. If you've already installed SABnzbd open the docker app & edit the it's container settings, under port settings set the local port to 13502 & the container port to 8080, save & restart the container.

Link to post
Share on other sites
  • 0

Okay, I created a docker-compose.yml (seems indeed pretty easy) with the following:
 

version: "2.1"
services:
  sabnzbd:
    image: ghcr.io/linuxserver/sabnzbd
    container_name: SABnzbd
    environment:
      - PUID=1028
      - PGID=100
      - TZ=Europe/Amsterdam
    volumes:
      - /volume1/docker:/config
      - /volume1/DiskStation/Downloads/complete:/downloads
      - /volume1/DiskStation/Downloads/temp:/incomplete-downloads
    ports:
      - 44100:12025
    restart: unless-stopped



However, when I run it, I noticed straight away the following again:

2021-02-23 09:17:01,536::INFO::[SABnzbd:1427] Starting web-interface on 0.0.0.0:8080

2021-02-23 09:17:01,536::INFO::[_cplogging:216] [23/Feb/2021:09:17:01] ENGINE Bus STARTING

2021-02-23 09:17:01,639::INFO::[_cplogging:216] [23/Feb/2021:09:17:01] ENGINE Serving on http://0.0.0.0:8080

2021-02-23 09:17:01,640::INFO::[_cplogging:216] [23/Feb/2021:09:17:01] ENGINE Bus STARTED
...
2021-02-23 09:17:01,641::INFO::[panic:239] Launching browser with http://127.0.0.1:8080/sabnzbd



Seems it's forcing 8080 again. What am I doing wrong?

Edited by HHawk
cleaned up post
Link to post
Share on other sites
  • 0

Ok, I've just created a new SABnzbd container redirecting 8080 - 44100 & I'm able to access it on port 44100 

 

In the Docker app the port settings for the container look like this:

image.png.11b4f65145a36e29d90fb4ef5e761f70.png

Link to post
Share on other sites
  • 0

Be sure you are using Docker network bridge mode, not bind mode.

 

Inside the container, it WILL be using port 8080 as that is how the program is configured.  Docker is translating it to the configured map port before it exits Docker into your network.

Edited by flyride
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.