Recommended Posts

Bonjour à tous,

 

J'utilise DSM ver. 6.1.3 et tout fonctionne parfaitement et j'ai quelques sites personnels en https, mais je voudrais pouvoir créer des sites en http.

 

A première vue, en créant un nouveau vhost (via l'interface de webstation), il n'est pas possible de dire que le site sera en http... il est automatiquement en https.

 

Je n’ai pas trouvé, dans l’interface de websation un endroit où forcer un site à fonctionner en http.

 

Je n’ai pas non plus trouvé de fichier vhost individuel (exemple : site1.vhost.conf). Le seul fichier trouvé est VirtualHost.json qui regroupe tous les domaines. Je n’ai pas non plus réussi à le faire un .htaccess.

 

Je me tourne donc vers vous et espère qu’une bonne âme pour m’aider…

 

Question : comment faire pour héberger des sites en http tout en gardant les sites qui sont actuellement en https ? Où faut-il le définir ou quel fichier faut-il modifier ou ajouter (en mode root)

 

D’avance merci pour le coup de pouce ou vos idées pour résoudre mon petit soucis.

 

Bon dimanche à tous.

Edited by Yann
Link to post
Share on other sites
  • Yann changed the title to Sites en https et d'autres en http

Salut,

 

Est-on sur que tu ne confonds pas site et services internet?

 

Si tu parles de sites, genre site perso hébergé sur WebStation, alors tout se passe dans WebStation :

image.thumb.png.9c61153e1bc256bdf0afa6e0d34b08dc.png

 

Sinon il faut aller du coté du panneau de configuration > "Portail des applications" > Proxy inversé

image.thumb.png.25cf2d06d631931bbfcedfc57d2b7b5f.png

Link to post
Share on other sites

Bonjour Nicoueron,

 

Merci pour ta réponse.

 

Je cherche bien une solution pour avoir des sites en https et d'autres en http, par exemple :

 

- site 1 : https:\\www.site1.net (sur le port 443 et avec certificat SSL, cela fonctionne parfaitement)

- site 2 : http:\\www.site2.net ( sur le port 80 et sans certificat, mais là c'est renvoyé automatiquement sur le port 443 et donc en https)

 

C'est donc l'option 1 de ta réponse, mais je suis ne vois pas où définir que le site2 (http:\\www.site2.net) est exclusivement sur le port 80. J'ai défini la même chose que ton image hormis que j'ai Apache 2.2 et PHP 7. Avec cette configuration, site 2 est automatiquement redirigé sur le port 443.

 

Une autre idée ?

 

 

 

 

Link to post
Share on other sites

J’avoue que je suis un peu surpris de vouloir faire du http en 2021, mais bon😅

 

ton web station est de toute évidence configurer pour faire la redirection automatiquement indépendamment du vhost. Si tu décoche cette option au niveau de DSM peut être que ça corrigera « ton pb » ? Mais sans conviction

Link to post
Share on other sites

Bonjour Nicoueron,

 

Merci de ta réponse et de ton intérêt à mon soucis.

 

Peux-tu m'indiquer où désactiver dans Webstation la redirection automatique ? Je ne trouve pas cet option et cela ne coûte rien d'essayer.

 

Merveilleuse journée.

Link to post
Share on other sites

Bonjour Nicoueron,

 

Merci pour ta réponse.

 

Problème résolu, faute de frappe dans le routage de mon routeur 🤬

 

Désolé du dérangement.

 

Merci à tous pour votre intérêt, particulièrement à Nicoueron pour ses réponses précises.

 

Une merveilleuse fin de journée.

 

Yann

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.