Проблема при установке на Proxmox 6.3-3


Recommended Posts

Всем добрый день.

 

Лоадер ds3615_6.2

link https://mega.nz/#!zcogjaDT!qIEazI49daggE2odvSwazn3VqBc_wv0zAvab6m6kHbA (for DS3617xs) - v1.03b

Система

 

CPU(s) 24 x Intel(R) Xeon(R) CPU E5-2620 v2 @ 2.10GHz (2 Sockets)

Kernel Version Linux 5.4.78-2-pve #1 SMP PVE 5.4.78-2 (Thu, 03 Dec 2020 14:26:17 +0100)

PVE Manager Version pve-manager/6.3-3/eee5f901

 

Проблема. Запускаю лоадера захожу в Web Интерфейс и получаю ошибку «Connection failed. Please check your network settings.», асистент машину видит, но ничего не может сделать, выдавая ошибку и предлагая позвать сапорт так же открывает 23 порт.

 

Лоадер был установлен как через args так и через диск. Лоадер запускается IP виден и nmap говорит что 80 и 5000 порт открыты.

 

 


uzer@laya:~$ sudo nmap -p- 192.168.1.62
Starting Nmap 7.80 ( https://nmap.org ) at 2021-02-12 10:09 MSK
Nmap scan report for diskstation (192.168.1.62)
Host is up (0.00056s latency).
Not shown: 65533 closed ports
PORT STATE SERVICE
80/tcp open http
5000/tcp open upnp
MAC Address: 76:CA:AA:A7:32:D4 (Unknown)
Nmap done: 1 IP address (1 host up) scanned in 2.30 seconds
 

 

Самое смешное что на для тестов ставил на Proxmox 6.2-12, там он завелся просто через args: с кривым bootdisk.

Старая машина



args: -device 'ich9-usb-ehci1,id=usb-ctl-synoboot,addr=0x18' -drive 'id=usb-drv-synoboot,file=/var/lib/vz/data/disk_image/images/700101/synoboot.img,if=none,format=raw' -device 'usb-storage,id=usb-stor-synoboot,bootindex=1,removable=off,drive=usb-drv-synoboot'
balloon: 0
boot: c
bootdisk: virtio0
cores: 2
cpu: kvm64,flags=-pcid
machine: q35
memory: 512
name: srv-sngyv1
net0: e1000=E6:F0:BD:54:7D:21,bridge=vmbr0
numa: 0
ostype: l26
sata0: /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR9936156,cache=unsafe,size=976762584K
sata1: /dev/disk/by-id/ata-WDC_WD1002FAEX-00Y9A0_WD-WCAW31164248,cache=unsafe,size=976762584K
sata2: /dev/disk/by-id/ata-ST1000DM010-2EP102_Z9ANHR4M,cache=unsafe,size=976762584K
sata3: /dev/disk/by-id/ata-ST1000DM010-2EP102_Z9ANK8B9,cache=unsafe,size=976762584K
scsihw: virtio-scsi-pci
smbios1: uuid=7ae44487-4657-45ab-8220-7e53382529cd
sockets: 1
vga: virtio
vmgenid: f17143a0-f6c8-4a80-b616-dd8305a13cb2

 

Новая машина

 


balloon: 0
boot:
cores: 2
cpu: kvm64
hotplug: usb
machine: q35
memory: 2048
net0: e1000=76:CA:AA:A7:32:D4,bridge=vmbr0
numa: 0
ostype: l26
sata0: zfs_disk:vm-100-disk-0,cache=writeback,size=50M
scsihw: virtio-scsi-pci
serial0: socket
smbios1: uuid=3089755a-fd37-438a-802b-77a5a5552e3a
sockets: 1
vga: virtio
vmgenid: 306f94e5-08bb-4fb9-80aa-a71b9c7ba86e

 

В консоли

 

 


patching file etc/rc
patching file etc/synoinfo.conf
patching file linuxrc.syno
patching file usr/sbin/init.post
START /linuxrc.syno
Insert Marvell 1475 SATA controller driver
Insert basic USB modules...
:: Loading module usb-common ... [ OK ]
:: Loading module usbcore ... [ OK ]
:: Loading module ehci-hcd ... [ OK ]
:: Loading module ehci-pci ... [ OK ]
:: Loading module ohci-hcd ... [ OK ]
:: Loading module uhci-hcd ... [ OK ]
:: Loading module xhci-hcd ... [ OK ]
:: Loading module usb-storage ... [ OK ]
:: Loading module BusLogic ... [ OK ]
:: Loading module vmw_pvscsi ... [ OK ]
:: Loading module megaraid_mm ... [ OK ]
:: Loading module megaraid_mbox ... [ OK ]
:: Loading module megaraid ... [ OK ]
:: Loading module scsi_transport_spi ... [ OK ]
:: Loading module mptbase ... [ OK ]
:: Loading module mptscsih ... [ OK ]
:: Loading module mptspi ... [ OK ]
:: Loading module mptsas ... [ OK ]
:: Loading module mptctl ... [ OK ]
:: Loading module megaraid_sas ... [ OK ]
:: Loading module mpt2sas ... [ OK ]
:: Loading module mpt3sas ... [ OK ]
Insert net driver(Mindspeed only)...
Starting /usr/syno/bin/synocfgen...
/usr/syno/bin/synocfgen returns 0
All disk ready or timeout execeed
Partition Version=0
Partition layout is not DiskStation style.
NOT EXECUTE /sbin/e2fsck.
Mounting /dev/md0 /tmpRoot
mount: lseek failed, msg:Invalid argument
mount: mounting /dev/md0 on /tmpRoot failed: No such device
mount /dev/md0 fail, returns
Exit on error [3] no init exists...
Fri Feb 12 07:04:54 UTC 2021
none /sys/kernel/debug debugfs rw,relatime 0 0
sys /sys sysfs rw,relatime 0 0
none /dev devtmpfs rw,relatime,size=1013800k,nr_inodes=253450,mode=755 0 0
proc /proc proc rw,relatime 0 0
linuxrc.syno failed on 3
starting pid 4190, tty '': '/etc/rc'
:: Starting /etc/rc
:: Mounting procfs ... [ OK ]
:: Mounting tmpfs ... [ OK ]
:: Mounting devtmpfs ... [ OK ]
:: Mounting devpts ... [ OK ]
:: Mounting sysfs ... [ OK ]
mdadm: error opening /dev/md1: No such file or directory
rc: Use all internal disk as swap.
rc: No assigned swap disk (sdg2) can be assembled, use all instead.
rc: Use all internal disk as swap.
rc: No disk (sdg2) can be assembled.
swapon: can't stat '/dev/md1': No such file or directory
:: Loading module sg ... [ OK ]
:: Loading module mdio ... [ OK ]
:: Loading module fat ... [ OK ]
:: Loading module vfat ... [ OK ]
:: Loading module ip_tunnel ... [ OK ]
:: Loading module vxlan ... [ OK ]
:: Loading module dca ... [ OK ]
:: Loading module e1000e ... [ OK ]
:: Loading module i2c-algo-bit ... [ OK ]
:: Loading module igb ... [ OK ]
:: Loading module ixgbe ... [ OK ]
:: Loading module r8168 ... [ OK ]
:: Loading module libcrc32c ... [ OK ]
:: Loading module mii ... [ OK ]
:: Loading module libphy ... [ OK ]
:: Loading module atl1 ... [ OK ]
:: Loading module atl1e ... [ OK ]
:: Loading module atl1c ... [ OK ]
:: Loading module alx ... [ OK ]
:: Loading module uio ... [ OK ]
:: Loading module ipg ... [ OK ]
:: Loading module jme ... [ OK ]
:: Loading module skge ... [ OK ]
:: Loading module sky2 ... [ OK ]
:: Loading module ptp_pch ... [ OK ]
:: Loading module pch_gbe ... [ OK ]
:: Loading module qla3xxx ... [ OK ]
:: Loading module qlcnic ... [ OK ]
:: Loading module qlge ... [ OK ]
:: Loading module netxen_nic ... [ OK ]
:: Loading module sfc ... [ OK ]
:: Loading module e1000 ... [ OK ]
:: Loading module pcnet32 ... [ OK ]
:: Loading module vmxnet3 ... [ OK ]
:: Loading module bnx2 ... [ OK ]
:: Loading module bnx2x ... [ OK ]
:: Loading module cnic ... [FAILED]
:: Loading module r8169 ... [ OK ]
:: Loading module tg3 ... [ OK ]
:: Loading module usbnet ... [ OK ]
:: Loading module ax88179_178a ... [ OK ]
:: Loading module button ... [ OK ]
:: Loading module synobios ... [ OK ]
udhcpc (v1.16.1) started
eth0 Link encap:Ethernet HWaddr 76:CA:AA:A7:32:D4
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:77 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4899 (4.7 KiB) TX bytes:0 (0.0 B)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
:: Starting syslogd ... [ OK ]
:: Starting scemd
:: Starting services in background
Starting findhostd in flash_rd...
Starting services in flash_rd...
Running /usr/syno/etc/rc.d/J01httpd.sh...
Starting httpd:80 in flash_rd...
Starting httpd:5000 in flash_rd...
Running /usr/syno/etc/rc.d/J03ssdpd.sh...
/usr/bin/minissdpd -i eth0
(15): upnp:rootdevice
(51): uuid:upnp_SynologyNAS-76caaaa732d4::upnp:rootdevice
(56): Synology/synology_broadwell_3617xs/6.2-23739/192.168.1.62
(44): http://192.168.1.62:5000/description-eth0.xml
Connected.
done.
/usr/syno/bin/reg_ssdp_service 192.168.1.62 76caaaa732d4 6.2-23739 synology_broadwell_3617xs eth0
Running /usr/syno/etc/rc.d/J04synoagentregisterd.sh...
Starting synoagentregisterd...
Running /usr/syno/etc/rc.d/J30DisableNCQ.sh...
Running /usr/syno/etc/rc.d/J80ADTFanControl.sh...
Running /usr/syno/etc/rc.d/J98nbnsd.sh...
Starting nbnsd...
Running /usr/syno/etc/rc.d/J99avahi.sh...
Starting Avahi mDNS/DNS-SD Daemon
cname_load_conf failed:/var/tmp/nginx/avahi-aliases.conf
:: Loading module hid ... [ OK ]
:: Loading module usbhid ... [ OK ]
============ Date ============
Fri Feb 12 07:05:03 UTC 2021
==============================
starting pid 5884, tty '': '/sbin/getty 115200
Fri Feb 12 07:05:04 2021

DiskStation login:
 

 

Еще вопрос, какой логин и пароль для лоадера (DiskStation login)?

Edited by n1kt0
Link to post
Share on other sites

 

Твою же дивизию.

Этому барахлу нужен обязательно инет для работы!!!

 

Залез в messages а там 

 

synoupgrade: synoupgrade.c:1441 fail to perform curl, CURLcode returns 7

Думаю, дай инет подключу, что будет...он заработал.

 

Всем спасибо. Прошу прощения 😃

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.