• 0

@appstore Disk Migration


Question

Hi,

 

I would like to know how I can move my App Disk from 120GB to 500GB Disk.

 

So what I mean is that i have the @appstore on the 120GB with all packages installed. Now i want to move this to my new 500GB Disk.

 

What is the best method for this please.

 

Thanks

Edited by Vodka2014
Link to post
Share on other sites

Recommended Posts

  • 0

I would like to know at what stage you get "disk full". If it is during the file move, then I am thinking about a permissions problem somewhere.

What I did was the move, changed the symlinks and restarted DSM, I confirmed that the applications seemed to be working before I removed my original disk.

But there was more work to do before removing the disk. I remember that I had to move the user home service from volume1 to volume2

 

Edited by billat29
reread earlier post
Link to post
Share on other sites
  • 0

Thanks. So it might be better if i do an new install on everything and migrate over the files and DB's i need etc....

 

Do you think The Kingston SSD Clone Software will work for this ?

Edited by Vodka2014
Link to post
Share on other sites
  • 0

Yes i want to move everything from the 120GB Disk to the 500GB Disk. This has my @appstore on it. Once done the new 500GB Disk will be there an i will remove the 120GB Disk.

 

This is what i am trying to get done. 

Link to post
Share on other sites
  • 0

Ok so i found a tool that will allow me to Clone the Disk to Disk but now how do i Extend the Volume of the Unallocated Space ? I do not see it at all in the Disk manager. 

 

Any Advice. 

 

Thanks in advanced 

Link to post
Share on other sites
  • 0
Just now, Vodka2014 said:

Thanks @flyride and the easy way to do this and keep all my data ?

 

I am really having a hard time to get this all to work. 

 

Yeah, this stuff can get complicated and there are a lot of tricks.  The @appstore folder is not a shared folder, but it is part of the data array.  This allows us to use array manipulation to do what we need and not screw up your volume location or put your data at additional risk. Here is what I would try.  You need a spare disk larger than the new 500GB disk that you can use temporarily.

 

The assumption is that you have a RAID0 Basic volume now (/volume1) with your app store on it .  If you built a SHR with it, do not follow this guide immediately and post the results of a df and a cat /proc/mdstat and let's evaluate before you proceed.

  1. Convert your RAID0 Basic volume with the 120GB disk into a RAID1, adding the new 500GB disk.  Do not make a SHR.  The result will be a 120GB RAID1
  2. Shutdown and remove your 120GB disk. If it was the #1 disk slot on the controller, move the new 500GB disk into it.
  3. Add your spare disk, boot and repair the RAID1 array with it (again do not make SHR). The array will be expanded automatically.
  4. Once it's done, shutdown, remove the spare disk, reboot and you will have a "broken" RAID1 array (which is a RAID0)
  5. Confirm which /dev/md device it is by running cat /proc/mdstat
  6. Assuming it's /dev/md2 (substitute whatever you figure out from the mdstat command), issue the following command as root:
    mdadm --grow --raid-devices=1 --force /dev/md2
Link to post
Share on other sites
  • 0
16 minutes ago, billat29 said:

I'm going to try it in a virtual machine BRB

Edited 1 minute ago by billat29
flyride's on the case

 

Never you mind, we need all the helpers we can get.  You found something basically identical to what I was brain-dumping just then :-)

Link to post
Share on other sites
  • 0

@Vodka2014 I broke my virtual environment. That was while I was setting up to test this. I didn't get as far as trying it.

Then @flyride came in and they really, really know their stuff. So I edited my post and crossed my offer out.

I have watched flyride sort out the most difficult problems and would have every confidence that if anyone can sort you out, they can.

 

My concern now, having reread all this, is what state is your system in? I don't understand why you need to order another 500GB disk right now.

You started with a 120GB and tried to move @appstore onto the 500GB. That didn't work,

so where is @appstore now? Is it back on the 120GB? Does your system work without the 500GB or are you now spread over the two disks?

And looking at flyrides post are you RAID0 or SHR?

 

Link to post
Share on other sites
  • 0

So what i did was Clone the 120GB to the 500GB so that worked :)

 

I will need to do some testing on Sunday but from what i know you need 2x Disks to Expand a Volume this is why i need another 500GB then Remove it for RAID 0 again. 

 

Link to post
Share on other sites
  • 0

I started with my virtual machine on 6.2.3 U3. It had one 8GB drive.

I then defined and added a 128GB virtual drive and rebooted the machine:

image.thumb.png.2bdbfe1096efa313a5952bc974989353.png

 

I have two unused drives as the first is the bootloader and I haven't applied the fix for hiding it when running in a VM.

I then went to Storage Manager>Storage Pool>Action and selected "change RAID type".

I selected RAID1 and dragged and dropped my new drive

image.thumb.png.61d181883773b14ef71602b7b9c85087.png

 

Next it resynchronised.

image.thumb.png.e5e9cba753143bcacb1ba23b58be6a78.png

Then I shut down and removed the old drive before restarting ..

Link to post
Share on other sites
  • 0

When I restarted, the storage pool had crashed

 

image.thumb.png.8f775ce84e4b75588d5974c8be86b34c.png

 

I ignored that and connected by SSH and ran the magic command:

sudo mdadm --grow --raid-devices=1 --force /dev/md2

That immediately sorted the crashed storage pool and started an expansion

image.thumb.png.da93f690a20c146e18cc385fbd6ee0cd.png

 

 

When that was done, I went to expand the volume as the link said but found it was already done

 

 

image.thumb.png.b5cdeb80437e3a5cff064f6d0826d599.png

 

and that was it. It seemed to have worked. My packages were still there as was my (limited) data.

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.