Recommended Posts

Guten Morgen!

 

Ich habe gestern mein erstes Xpenology (6.2, DS3617xs) aufgesetzt und bin begeistert, wie schnell und unkompliziert das von statten ging!

 

Als vorheriger OMV-User fiel mir vor allem auch das unfassbar Noob-freundliche GUI auf, weswegen ich auch gerne bei DSM bleiben möchte, allerdings steckt mir ein sehr großer Dorn im Auge, welcher - sollte das nicht fixbar sein, leider ein KO-Kriterium für mich wäre: Das teil bootet einfach super langsam (30-45sek)...

 

Das NAS wird im Schnitt 6-10h die Woche genutzt, weswegen ein 24/7 Betrieb für mich ausfällt. Gibt es keine Energiespar-Optionen abseits von „An“ und „Herunterfahren“?

 

Lässt sich der Boot durch den Einbau einer SSD beschleunigen, sodass zwingend immer von dieser gebootet wird? Gibt es darüber hinaus einen Standby/Hibernate/whatever?

 

 

Info zur Hardware: Asrock Q1900 mit 4GB DDR3 und aktuell keine SSD. 

Link to post
Share on other sites

Du hast die Möglichkeit, den Zeitraum für das Auswahlmenü des Loaders in der grub.cfg zu verkürzen.

 

Steht auf, glaube ich, auf 10sekunden. Das könntest Du auf 1sek. stellen.

 

Was für HDDs benutzt Du? Das langsamere Booten könnte auch mit den HDDs zusammenhängen oder andere Hardware defekte.

 

Wie viele Pakete laufen bei Dir? Bis sämtliche Dienste geladen sind kann es natürlich eine gewisse Zeit dauern.

 

Ich finde jetzt aber Bootzeiten bis 60sek.vollkommen normal auf einer Baremetal Installation.

 

Mich stört das aber auch nicht wirklich.

 

Falls ich Zeit finde, dann werde ich mal bei mir messen.

Link to post
Share on other sites

Kann ich den Stick dann einfach aus dem NAS ziehen > in den Windows-Rechner, grub.cfg bearbeiten > wieder zurück ins NAS? Oder zerschieße ich mir da irgendwas?

Lässt sich die Zeit auch auf unter 1 sek einstellen? Auf 0 oder 0.1?

 

ich hab aktuell nur ne alte Seagate 4TB drin, müsste ne 7200u/min sein. Laut überprüfung von DSM ist die Platte in Ordnung. 
 

Mit OpenMediaVault kam ich nach 2-3 Sekunden nach WOL ins Web GUI, da sind dann deine genannten 60Sekunden in Relation schon ne andere Hausnummer...

 

Pakete habe ich bisher noch keine Installiert, lediglich Die HDD eingebunden und überprüfen lassen. Ich hab noch nicht einmal ein Volume eingerichtet. 

Würde eine SSD denn einen vergleichbaren Schub wie auf nem Windows PC geben? Hab noch die ein oder andere SSD in der Grabbelkiste liegen. 

 

Da das NAS on Demand starten soll, sobald von verschiedenen Endgeräten ein WOL gesendet wird, sollten die Daten dann auch dementsprechend schnell zur Verfügung stehen. 
 

 

Edit: Wie kommt denn mein Name in den Threadtitel? Könnte ein Mod das irgendwie ändern, ich kann den Post leider nicht mehr editieren

Edited by Trip28
Verwirrender Threadtitel
Link to post
Share on other sites

Hi,

 

notfalls erstellst Du den Stick einfach neu. Die .img Datei solltest Du so oder so "aufheben",falls sich ein USB Stick mal verabschiedet.

 

Ich bin da jetzt nicht der Experte in Sachen Geschwindigkeit. Klar, SSDs sollten(könnten) generell schneller sein als HDDs, allerdings müssen auch die restlichen Komponenten dazu passen.

 

Da findet sich bestimmt jemand anderes der da mehr erzählen kann.

 

Ich habe 3 echte Synologys zu Hause. Und die jüngste (DS214play) braucht auch einiges um hochzufahren.

 

Du kannst höchstens mit Spindown arbeiten, wenn keine Pakete den Spindown verhindern (google).

 

Ansonsten per Zeit das Nas hoch und runter fahren lassen.

 

Man könnte sich noch etwas per Smartphone und Geofence bauen, um das NAS zu starten, aber das hat hier nichts verloren.

 

Erstelle ein Volume mit ein paar Paketen die Du auch nutzen würdest und schaue dir dann Die Zeit erneut an.

 

An 2-3 Sekunden kommst Du jedenfalls nicht dran.

 

Wenn es Dir so wichtig ist einen schnellen Zugriff zu bekommen, dann solltest Du vielleicht bei OMV bleiben.

 

Eine echte Diskstation im Ruhezustand benötigt auch um die 10 Sekunden, um wieder ganz da zu sein, zumindest mein schnellste Krücke.

 

Mein Xpenology läuft 24/7.

 

Darf man fragen für was Du den schnellen Zugriff benötigst?

 

Ich hatte Anfangs per Dsfinder das Nas gestartet und die 1minute hatte ich immer übrig.

 

 

 

Link to post
Share on other sites
15 hours ago, Trip28 said:

Kann ich den Stick dann einfach aus dem NAS ziehen > in den Windows-Rechner, grub.cfg bearbeiten > wieder zurück ins NAS? Oder zerschieße ich mir da irgendwas?

der usb ist wenn dsm gestartet ist nicht gemounted und wird nur beim booten benutzt

Link to post
Share on other sites

2-3 Sekunden wohl eher aus dem Standby, kein richtiger cold boot. Sobald man konventionelle HDDs in einem System hat, ist die response time meist immer um einiges höher, da die erst ihren spin-up fahren müssen.

 

Betreffend XPEnology und boot time: ja, wenn man nur SSDs verwendet geht es etwas schneller. Den timeout im Loader kannst du von 3 Sekunden (default) auf 1 Sekunde heruntersetzen, aber ob das nun der absolute Bringer ist...

 

Wie Du die grub.cfg nachträglich bearbeiten bzw. den stick mounten kannst, ist hier beschrieben:

 

 

 

Link to post
Share on other sites

Also ich habe gerade einen neuen Gehäuselüfter verbaut und mal auf die Stoppuhr geschaut.

 

Mein XPE, Asrock J4105M mit zur Zeit, 16GB Ram, 2x 3TB WD Red, 2x 6TB WD Red und 1x 2,5" 500GB für BTRFS (zum spielen) benötigt ca. 90sek. (+ - 10sek) zum hochfahren.

 

Der Browser zeigt die Anmeldefläche und der Synology Assistent zeigt "Dienste werden geladen".

Nach ein paar weiteren Sekunden zeigt der Assistent fertig an.

 

Ob die Shares eventuell schneller zur Verfügung stehen habe ich jetzt nicht getestet.

 

Jetzt hast Du einen Anhaltspunkt.

Link to post
Share on other sites

Leute, danke für eure Antworten!

 

6 hours ago, jensmander said:

2-3 Sekunden wohl eher aus dem Standby, kein richtiger cold boot. [...]

 

Betreffend XPEnology und boot time: ja, wenn man nur SSDs verwendet geht es etwas schneller. Den timeout im Loader kannst du von 3 Sekunden (default) auf 1 Sekunde heruntersetzen, aber ob das nun der absolute Bringer ist...

 

 

Korrekt, es handelte sich dabei natürlich nicht um einen Kaltstart. Allerdings scheint es bei DSM ja keinen Standby o.Ä zu geben, lediglich den Spindown der Festplatten oder die Herunterfahren-Option oben rechts in der Taskleiste.

 

Es ist also auch nicht möglich, DSM gezielt von einer bestimmten Platte booten zu lassen (SSD)?

Link to post
Share on other sites

DSM wird auf allen Datenträgern installiert. Damit arbeitet das Betriebssystem redundant, und Du kannst das Nas hochfahren falls eine HDD defekt ist oder ähnliches.

 

Funktioniert natürlich nur bei mindestens 2 HDDs so.

 

A la Windows & Co. Boot HDD gibt es nicht.

 

Aufgrund technischer Gegebenheiten kannst Du den Ruhezustand mit XPE nicht erreichen, höchstens in den Standby schicken, wenn die Hardware es möglich macht und umgekehrt WOL, falls unterstützt.

 

Standby geht aber nur, wenn keine Dienste das verhindern.

 

Vielleicht wird es irgendwann gehen.....

Edited by apejovic
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.