Recommended Posts

By mistake, on an HP Proliant gen8, I upgraded the system to version 6.01, trough the dsm upgrade. I have old bootloader for 5.2.  Of course now the NAS no longer starts and I don't know what to do. He doesn't remember anything more than what I did in the previous 5.2 installation. I would be grateful if you could guide me step by step on how to recover this mess.

Edited by albruno
Link to post
Share on other sites
2 hours ago, albruno said:

HP Proliant gen8, I upgraded the system to version 6.01

 

there is a older tutorial for it

https://xpenology.com/forum/topic/5442-downgrade-from-dsm-60/

 

 

imho easyest way might be to use a loader for dsm 6.0 and use it the way it is now

the hardware is capable of running even the latest 6.2.3

 

loaders are here

https://xpenology.com/forum/topic/7848-links-to-loaders/

there is also a older tutorial for that

https://xpenology.com/forum/topic/7507-tutorial-installmigrate-dsm-52-to-602-juns-loader/

if you feel confident you might delete a older directory from 5.x installtion

https://xpenology.com/forum/topic/26723-network-down-after-dsm-login/?tab=comments#comment-137953

and proceed to update 6.2.3, the loader and method of customization is the same as with 6.0

most important is to know the vid/pid of the usb boot device, that values need to be in grub.cfg

(mac address of nic and serial are optional and can be changed later on)

 

this is about 6.1 but replace 1.02b loader with 1.03b and dsm 6.1 with 6.2.3 and it will work for 6.2.3 too

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

  • Thanks 1
Link to post
Share on other sites

So, if i have a new bootloader on usb i can restart server? It seem too simple! Why is not this the way to upgrade and tutorials say to install the new dsm trough the bootloader? Thanks anyway! 

Edited by albruno
Link to post
Share on other sites
42 minutes ago, albruno said:

So, if i have a new bootloader on usb i can restart server? It seem too simple! Why is not this the way to upgrade and tutorials say to install the new dsm trough the bootloader? Thanks anyway! 

 

Migration upgrade with new bootloader == in-place upgrade, boot failure, then boot with new bootloader

 

Bootloader must be configured either way.  Not sure how that is simpler than the tutorial procedure.

 

You will have xpenoboot file problem however that will need a quick fix.

Edited by flyride
Link to post
Share on other sites
10 hours ago, flyride said:

Bootloader must be configured either way.  Not sure how that is simpler than the tutorial procedure.

he might need to restore/rebuild his old loader and as dsm is not starting anymore, he would need to use a recovery linux, assemble the raid1 system partitions and change the version file

and after that he ends up with a massively outdated 5.2 system and no knowledge about 6.x that will help him later

seems better to invest the time in getting 6.0 up and deciding about to repeat the steps used for 6.0 to get 6.2 up and running

(no difference in preparing jun#s loader for 6.0 or 6.2)

 

Link to post
Share on other sites
2 hours ago, IG-88 said:

potrebbe aver bisogno di ripristinare / ricostruire il suo vecchio caricatore e poiché dsm non si avvia più, dovrebbe utilizzare un Linux di ripristino, assemblare le partizioni di sistema raid1 e modificare il file di versione

e dopo di ciò si ritrova con un sistema 5.2 enormemente obsoleto e nessuna conoscenza di 6.x che lo aiuterà in seguito

Sembra meglio investire il tempo nell'ottenere 6.0 su e decidere di ripetere i passaggi utilizzati per 6.0 per ottenere 6.2 attivo e funzionante

(nessuna differenza nella preparazione del caricatore di giugno per 6.0 o 6.2)

 

I need a fast option. If i make a usb loader 6.01, can i boot the dsm? I have no monitor and so i need something i pull in usb and then can do anything trough the net. I have only 1 HDD inside and no raid

Edited by albruno
Link to post
Share on other sites

 

Jun's loader v1.01 DS3615xs

DS3615xs 6.0.2 Jun's Mod V1.01.zip | 24.0 MB | MD5 = cf9d920edef96d58ae709674dc71511b

from here

https://xpenology.com/forum/topic/7848-links-to-loaders/

transfer it to usb with the tool "Win32DiskImager 1.0"

win10 has a access problem for some time but if you start your (unix aware) editor (notepad++) "as adminsttrator" you can access the grub.cfg with the file open dialog in the editor

if its linux you mount the 1st partition and edit the grub.cfg as you would do with other stuff

the usb vendor and device id can be accessed in windows device manager or   tools like "UsbTreeView" or "USBDeview", on linux its just lsusb and you will see you devices

after changing usb vid/pid in loader you are good to go (mac is only needed for WOL and sn is only used for special things - both can be changed later when the system is already running)

 

you should read a little here to get a better understanding of what you try to do

https://xpenology.com/forum/topic/7507-tutorial-installmigrate-dsm-52-to-602-juns-loader/

 

the dsm install file is this (the one the loader was made for)

https://global.download.synology.com/download/DSM/release/6.0.2/8451/DSM_DS3615xs_8451.pat

 

 

if you are fine with the way of setting up the usb, you could pretty much do the same with the 1.03b loader for 3615 and install 6.2.3

https://global.download.synology.com/download/DSM/release/6.2.3/25426/DSM_DS3615xs_25426.pat

 

the tutorial for this is the one also used for 6.1

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

 

but keep the link in mind from above and delete the old folder ".xpenoboot" before proceeding to 6.2.3

https://xpenology.com/forum/topic/26723-network-down-after-dsm-login/?tab=comments#comment-137953

 

 

 

 

Link to post
Share on other sites

If you configure grub by modifying the loader, no keyboard or monitor is needed on the DSM device (which is what the directions state, and most people do).

 

Optionally you may interact with grub at boot time, and in that case, you will need a keyboard and monitor.

Link to post
Share on other sites
11 minutes ago, albruno said:

know that. When i istalled the 5 versione i used monitor and keyboard for select xpenology installation in grub. I dont need it in version 6?

with 6.x there is noting on the monitor then the grub selection and you only need the defaut (1st entry)

there is no console output, that goes all to the serial port

so even with keyboard and monitor, there is nothing you would need it for, only in rare case of the special reinstall option you would need to select something in grub

(if you scroll through the grub.cfg you will see the menu options of grub in the lower area)

  • Thanks 1
Link to post
Share on other sites
On 1/19/2021 at 8:32 PM, IG-88 said:

 

Jun's loader v1.01 DS3615xs

DS3615xs 6.0.2 Jun's Mod V1.01.zip | 24.0 MB | MD5 = cf9d920edef96d58ae709674dc71511b

from here

https://xpenology.com/forum/topic/7848-links-to-loaders/

transfer it to usb with the tool "Win32DiskImager 1.0"

win10 has a access problem for some time but if you start your (unix aware) editor (notepad++) "as adminsttrator" you can access the grub.cfg with the file open dialog in the editor

if its linux you mount the 1st partition and edit the grub.cfg as you would do with other stuff

the usb vendor and device id can be accessed in windows device manager or   tools like "UsbTreeView" or "USBDeview", on linux its just lsusb and you will see you devices

after changing usb vid/pid in loader you are good to go (mac is only needed for WOL and sn is only used for special things - both can be changed later when the system is already running)

 

you should read a little here to get a better understanding of what you try to do

https://xpenology.com/forum/topic/7507-tutorial-installmigrate-dsm-52-to-602-juns-loader/

 

the dsm install file is this (the one the loader was made for)

https://global.download.synology.com/download/DSM/release/6.0.2/8451/DSM_DS3615xs_8451.pat

 

 

if you are fine with the way of setting up the usb, you could pretty much do the same with the 1.03b loader for 3615 and install 6.2.3

https://global.download.synology.com/download/DSM/release/6.2.3/25426/DSM_DS3615xs_25426.pat

 

the tutorial for this is the one also used for 6.1

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

 

but keep the link in mind from above and delete the old folder ".xpenoboot" before proceeding to 6.2.3

https://xpenology.com/forum/topic/26723-network-down-after-dsm-login/?tab=comments#comment-137953

 

 

 

 

I cant install. find synology stop loader at 56% and want version 6.03 or above. How can I do?

Link to post
Share on other sites
3 hours ago, albruno said:

I cant install. find synology stop loader at 56% and want version 6.03 or above. How can I do?

try the version the loader was made for (6.0.2)

https://global.download.synology.com/download/DSM/release/6.0.2/8451/DSM_DS3615xs_8451.pat

maybe do a test install with your new usb loader and a single empty disk, if that works out, use the usb with your 5.2 disks

(if you got 6.02 installed you could pretty much do the same steps with loader 1.02b or 1.03b and try to install dsm 6.1 or 6.2)

 

there is a warning in the 6.0.2 tutorial and its kind of prominent

image.thumb.png.66751c47dcc588c93629170fa60807f9.png

 

 

Edited by IG-88
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.