Jump to content
XPEnology Community

VM Xpenology DSM 6.2 ne démarre pas après mise à jour vers ESXi 6.7


wile_e
 Share

Recommended Posts

Bonjour,

 

j'ai profité d'un peu de temps libre ce weekend pour faire l'une ou l'autre mise à jour. Malheureusement, cele ne me réussit pas trop. Je soumets les deux problèmes. A voir lequel est à solutionner en premier.

 

Tout d'abord, j'ai fait la mise à jour de ESXi 6.5 vers ESXI 6.7 avec la custom image de chez HP, s'agissant d'un HPE Proliant Gen10.

J'en suis donc à cette version :

VMware ESXi 6.7.0 build-9484548

 

Par contre, aucune mise à jour vers les update 1, 2 ou 3 ne se fait. J'ai ce message d'erreur :

[root@localhost:~] esxcli software vib update -d /vmfs/volumes/StockVm/ESXi670U1HPE2019.zip
 [DependencyError]
 VIB VMware_bootbank_esx-base_6.7.0-1.39.11675023 requires esx-update << 6.7.0-1.40, but the requirement cannot be satisfied within the ImageProfile.
 VIB VMware_bootbank_esx-base_6.7.0-1.39.11675023 requires esx-update >= 6.7.0-1.39, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.
 

Ensuite, et c'est le plus important, si ma VM en Debian10 démarre bien, ma VM sous DSM 6.2 ne démarre plus, avec ce message d'erreur :

Failed to power on virtual machine Wile_DSM6. Unable to enumerate all disks. Click here for more details.

La VM avait créée avec les infos de ce site. Je retrouve ceci dans le serial.out :

DS3617xs 6.2.1 VMWare/ESXI with Jun's Mod v1.03b for DSM 6.2.1 -- Custom

De mémoire, la version de DSM a environ 18 mois. Et elle fonctionnait hier midi sous ESXi 6.5.

 

J'avais trouvé une piste avec le controller cache qui est désactivé par défaut mais je ne vois pas où je pourrais activer ce paramètre.

 

Merci,

wile_e

Link to comment
Share on other sites

Bonjour Wele_e,

 

Je ne suis pas un spécialiste vmware ESXi mais pour ma part j'ai préféré les product patch de vmware plutôt que les custom HP ou DELL.

 

Pour ma part j'utilise un DELL poweredge T320 pour lequel DELL annonçait qu'il n'était pas compatible ESXi6 mais qu'il s'arrêtait à la version 5.

 

J'ai donc fait l'installation directement avec les product patch de vmware.

Product Patches (vmware.chttps://my.vmware.com/group/vmware/patch#search)

 

Par contre je ne fais pas la migration ESXi 7 car mon contrôleur Sata raid n'est pas compatible.

 

Dans un premier temps j'essaierai d'installer la version 6.7 de vmware (6.7.0 Update 3 (Build 17167734)) sur ton serveur.

 

Pour ta VM dsm qui ne démarre plus, à priori il ne trouve plus les disques, n'oublies pas la vm synoboot sur le contrôleur SATA 0 et les autres disques sur le contrôleur SATA 1

 

Désolé de ne pas pourvoir t'aider plus.

 

Tiens nous au courant

 

Link to comment
Share on other sites

  • 11 months later...

Je n'avais pas donné de feedback l'année dernière, désolé. Et un peu difficile de dire avec précision comment tout cela s'était solutionné. Peut-être le simple changement du contrôleur SATA de 0 à 1 mais désolé je ne sais plus :(

 

Ici, j'ai effectué la mise à jour d'ESXi vers la tout dernière version 6.7.

J'en suis donc là : (Updated) HPE-ESXi-6.7.0-Update3-18828794-Gen9plus-670.U3.10.8.1.2 (Hewlett Packard Enterprise) (au lieu 6.7 Update 1)

 

Par contre, impossible de passer de la version 6.7 à la version 7.

Quelle que soit la version (HPE ou VMware 'classique'), j'ai ce genre d'erreur :

 

[wile@localhost:~] esxcli software vib update -d /vmfs/volumes/StockVm/Wile_DSM6/VMware-ESXi-7.0U2a-17867351-depot.zip
 [DependencyError]
 VIB VMW_bootbank_vmkusb_0.1-4vmw.670.3.159.18828794 requires vmkapi_incompat_2_5_0_0, but the requirement cannot be satisfied within the ImageProfile.

 

Ca n'empêche pas les VM de tourner mais comme il est toujours bon de mettre à jour, je ne sais pas vraiment quoi faire pour contourner ces erreurs.

 

 

Link to comment
Share on other sites

honnêtement vouloir les dernières versions d'ESXi n'apporteront pas grand chose si ton matériel n'est pas récent. C'est prendre le risque de rendre incompatible DSM et de nouvelles failles de sécurité en passant à la 7.

Ma préconisation est de rester sur une version stable et compatible avec ton serveur physique.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...