Intel X540-T2 NIC not obtaining IP address / stays disconnected


Recommended Posts

Recently I upgraded my router to QNAP QHora301W router with 2x 10Gbe network port.

To utilize the new 10Gbe network ports, I installed a Supermicro Intel X540-T2 network card into my Xpenlogy NAS.

I then booted the system with the 1 onboard NIC (Intel I219V or Intel I211AT) connected, and confirmed the system picked up the two new ports on the X540-T2.

So I wired a CAT7 wire between the router and the NAS.

After the physical wire was setup, although there are blinking lights on both sides and router management page shows a 10Gbe link is established, Synology side shows the port as disconnected.

What step I can do in SSH to troubleshoot or attempt the get them working?

 

Hardware Configuration:

Intel Core i7-8700T (ES)

ASRock Z390M-ITX/ac

Supermicro Intel X540-T2

 

Bootloader Configuration:

Jun's v1.04b DS918+

with v0.13.3

with NVMe Patch

on DSM 6.2.3-25426 Update 3

 

Thanks.

Edited by Dipper315
Provide more details
Link to post
Share on other sites
1 hour ago, Dipper315 said:

Hardware Configuration:

Intel Core i7-8700T (ES)

ASRock Z390M-ITX/ac

Supermicro Intel X540-T2

 

Bootloader Configuration:

Jun's v1.04b DS918+

with v0.13.3

with NVMe Patch

on DSM 6.2.3-25426 Update 3

you can check with

Quote

lspci -k

that the driver is loaded, it should be "ixgbe"

 

also keep in mind the default config of 918+ is only 2 nic's

your board has already two nic's so both new ports might be above that limit and you need to tweak your synoinfo.conf to use them

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

"...

!!! still network limit in 1.04b loader for 918+ !!!

atm 918+ has a limit of 2 nic's (as the original hardware)
If there are more than 2 nic's present and you can't find your system in network then you will have to try after boot witch nic is "active" (not necessarily the onboard) or remove additional nic's and look for this after installation
You can change the synoinfo.conf after install to support more then 2 nic's (with 3615/17 it was 8  and keep in mind when doing a major update it will  be reset to 2 and you will have manually change this again, same as when you change for more disk as there are in jun's default setting) - more info's are already in the old thread about 918+ DSM 6.2.(0) and here

https://xpenology.com/forum/topic/12679-progress-of-62-loader/?do=findComment&comment=92682

..."

 

  • Thanks 1
Link to post
Share on other sites
Posted (edited)

Thanks for pointing me to the right place. I got the card to function.

I will just briefly recap what I did that worked for me so that others that might encounter a similar issue knows what to do.

Pre-requisite: Set MAC1-MAC4 in grub file (For my use case)

1. SSH into the NAS and type the following.

Quote

lspci -k

2. Look for NIC in question. In my case a X540-T2 with 2 ports, so it showed up as "ixgbe"

0000:01:00.0 Class 0200: Device 8086:1528 (rev 01)
        Subsystem: Device 15d9:0734
        Kernel driver in use: ixgbe
0000:01:00.1 Class 0200: Device 8086:1528 (rev 01)
        Subsystem: Device 15d9:0734
        Kernel driver in use: ixgbe

3. Since the card showed up with the correct drive loaded. I proceeded to modify the synoinfo.conf (in /etc AND /etc.defaults)

  • Change maxlanport from 2 to 8
    • Original
      • maxlanport="2"

         

    • Modified
      • maxlanport="8"

         

  • Added the followings to the end
eth4_mtu="1500"
eth5_mtu="1500"
eth6_mtu="1500"
eth7_mtu="1500"

4. Save and rebooted the device.

After performing these steps, I got X540-T2 to function.

Results below:

image.thumb.png.356a4ab81a3000a79cfb27ef05ff7e97.png

 

Hopefully somebody will find my recap useful.

Thanks IG-88 for the prompt reply.

Edited by Dipper315
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.