• 0

xpenology supply NFS to esxi 7 datastore?


Question

Is anyone using xpenology to supply NFS for esxi 7?

I was not able to make it work. It does work as expected on my real Synology 1815+ running DSM beta 7.0, but no matter what I tried I could not get the esxi host to add a datastore on the XPEnology NAS. I can use nfs v3 and v4 to my real synology.

 

 if you are able to make it work I would appreciate some feedback.

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have configured an NFS mount accessed by ESXi on XPE DSM in the past, and it works fine, but I haven't tried explicitly to use it as a datastore.  What errors do you get?

Link to post
Share on other sites
  • 0

I am trying to use remote/shared storage to facilitate vmotion between two esxi hosts. thus I am trying to mount an NFS share hosted on my XPE box as a datastore on both of my hosts. I believe I worded that correctly, but I admit that I don't understand your comment as I don't understand how else esxi can access an NFS share.

 

Xpenology side

Control Panel - file services, NFS and NFS4.1 checked to enable. NFS advanced settings at default.

Control Panel - shared folder, created a share "NFS" NFS Permissions, added 2 entries, one for each host, by single IP, Read/Write, squash>no mapping, Asyncronous>Yes, Non-priv port>Denied, Cross-mount>Allowed

Control Panel, Info Center, service, confirmed NFS enabled and firewall exception in place. 

 

vmWare side

html5 client login as root to the esxi host

navigate to storage - datastores - click new datastore

Mount NFS datastore

name:DS2_NFS

NFS server: 10.0.0.11 (ip of my xpenology system)

NFS share: /volume2/NFS (case sensitive path to my NFS share as detailed in dsm-control panel-shared folder-NFS share, NFS permissions on bottom)

NFS 3 , or NFS 4 (tried both)

 

create NFS datastore task starts up, running, Failed - an error occurred during host configuration

 

error bar message: failed to mount NFS datastore DS2_NFS - Operation failed, diagnostics report:Mount failed:unable to complete Sysinfo Operation. Please see the vmkernal log file for more details.:unable to connect to NFS server

 

host - monitor - logs - 

2021-01-02T23:38:54.839Z cpu0:2100027 opID=9c4e526e)NFS: 162: Command: (mount) Server: (10.0.0.11) IP: (10.0.0.11) Path: (/volume2/NFS) Label: (DS2_NFS) Options: (None)
 

Link to post
Share on other sites
  • 0

I previously did a scripted NFS mount on ESXi.

 

I tried all the above except didn't bother with a firewall exception and was able to mount a test NFS datastore using either V3 and V4 protocols.

Link to post
Share on other sites
  • 0

I have not had any luck yet. I wonder if it is an issue with 918+?

I have not been able to scare up any spare hardware to build a test xpenology yet either :(

 

Edited by mervincm
Link to post
Share on other sites
  • 0

This issue is bewildering to me.

I built a test xpenology system and it worked first try.

I tried it on my main system once again, and it worked this time. I moved over a couple VMs to NFS storage on my main system, and everything is working perfectly. A week later I go to use a VM and it has read errors and cannot be restarted. sure enough, the NFS share is no longer available to vsphere and can not be re-established.

I didn't change any network config, nor NFS share permissions, nothing at all on vsphere or synology that I can recall.

I can still connect to the same NFS share from my backup synology, so the share is actually available, I just can't use it from vsphere .....

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.