Power off from the buttom


Recommended Posts

I can confirm you that CONFIG_ACPI_PROC_EVENT=y is build in beta v3 et v4

 

And with that Kernel you really get no events in /proc/acpi/event by pressing the power button on bare metal installation?

 

I'm working on beta5, restart from scratch with config file from v1.0 and enable just the ACPI_PROC_EVENT. Boot, and insmod button.ko.

I got nothing (tail -f /proc/acpi/event nor cat /proc/acpi/event) when pressing power button while DSM is started :sad:

Link to post
Share on other sites
I'm working on beta5, restart from scratch with config file from v1.0 and enable just the ACPI_PROC_EVENT. Boot, and insmod button.ko.

I got nothing (tail -f /proc/acpi/event nor cat /proc/acpi/event) when pressing power button while DSM is started :sad:

 

Until this is not working we don't need to take care about the usermode program acpid (or busybox-acpid).

In DSM 4.3 v1.0 I've seen, that CONFIG_ACPI_PROCFS is not configured. So, could please enable the follwing parameters:

CONFIG_ACPI_PROCFS=y

CONFIG_ACPI_PROC_EVENT=y

CONFIG_ACPI_PROCFS_POWER=y

 

Respectively please set the CONFIG_ACPI_* parameters to the same values as in the working DSM 4.2 Kernel.

 

Thank you very much.

Link to post
Share on other sites
  • 3 weeks later...
I'm working on beta5, restart from scratch with config file from v1.0 and enable just the ACPI_PROC_EVENT. Boot, and insmod button.ko.

I got nothing (tail -f /proc/acpi/event nor cat /proc/acpi/event) when pressing power button while DSM is started :sad:

 

Until this is not working we don't need to take care about the usermode program acpid (or busybox-acpid).

In DSM 4.3 v1.0 I've seen, that CONFIG_ACPI_PROCFS is not configured. So, could please enable the follwing parameters:

CONFIG_ACPI_PROCFS=y

CONFIG_ACPI_PROC_EVENT=y

CONFIG_ACPI_PROCFS_POWER=y

 

Respectively please set the CONFIG_ACPI_* parameters to the same values as in the working DSM 4.2 Kernel.

 

Thank you very much.

 

CONFIG_ACPI_PROCFS and CONFIG_ACPI_PROCFS_POWER are not enabled in 4.2.

Just rebuild kernel with these options enabled but still nothing...

 

What about the new implementation of acpi in /sys/ ? (CONFIG_ACPI_PROC_EVENT is deprecated)

Link to post
Share on other sites
  • 3 weeks later...
I'm working on beta5, restart from scratch with config file from v1.0 and enable just the ACPI_PROC_EVENT. Boot, and insmod button.ko.

I got nothing (tail -f /proc/acpi/event nor cat /proc/acpi/event) when pressing power button while DSM is started :sad:

 

Until this is not working we don't need to take care about the usermode program acpid (or busybox-acpid).

In DSM 4.3 v1.0 I've seen, that CONFIG_ACPI_PROCFS is not configured. So, could please enable the follwing parameters:

CONFIG_ACPI_PROCFS=y

CONFIG_ACPI_PROC_EVENT=y

CONFIG_ACPI_PROCFS_POWER=y

 

Respectively please set the CONFIG_ACPI_* parameters to the same values as in the working DSM 4.2 Kernel.

 

Thank you very much.

 

CONFIG_ACPI_PROCFS and CONFIG_ACPI_PROCFS_POWER are not enabled in 4.2.

Just rebuild kernel with these options enabled but still nothing...

 

What about the new implementation of acpi in /sys/ ? (CONFIG_ACPI_PROC_EVENT is deprecated)

 

I build a acpid v2.0 from source for using new implementation of acpi, and it can start on DSM 4.3 but with logout as below:

#acpid -l -d -f

acpid: cannot open input layer

inotify fd: 4

acpid: inotify_add_watch() failed: No such file or directory (2)

netlink opened successfully

acpid: starting up with netlink and the input layer

parsing conf file /etc/acpi/events/anything

acpid: 1 rule loaded

acpid: waiting for events: event logging is on

 

It seems acpid can not open netlink input layer when using netlink and the input layer instead of deprecated /proc/acpi/event interface. I look into source code, acpid will try to open /dev/input/event*, and it seems missing from synology DSM. acpid also try to read event from /proc/acpi/event, but as mentioned previously, when press power button, there was no output in /proc/acpi/event. So power button can not work.

Link to post
Share on other sites
  • 2 weeks later...

actually, i think the physical button should use "poweroff" or "shutdown -h now"

normally we can shutdown in the web interface, which regard as the safest shutdown

however when something happen and the web service and ssh/telnet service is closed, you 'll finded no way to shutdown properly (unless you plug a keyboard and blindtype your login password poweroff

Link to post
Share on other sites
actually, i think the physical button should use "poweroff" or "shutdown -h now"

normally we can shutdown in the web interface, which regard as the safest shutdown

however when something happen and the web service and ssh/telnet service is closed, you 'll finded no way to shutdown properly (unless you plug a keyboard and blindtype your login password poweroff

 

The shutdown script should be a follow:

 

syno_poweroff_task -r

poweroff

 

If you directly call poweroff, after reboot it will a notification for improper shutdown.

Link to post
Share on other sites
actually, i think the physical button should use "poweroff" or "shutdown -h now"

normally we can shutdown in the web interface, which regard as the safest shutdown

however when something happen and the web service and ssh/telnet service is closed, you 'll finded no way to shutdown properly (unless you plug a keyboard and blindtype your login password poweroff

 

The shutdown script should be a follow:

 

syno_poweroff_task -r

poweroff

 

If you directly call poweroff, after reboot it will a notification for improper shutdown.

 

interesting. I had been using poweroff whenever shutdown from DSM hung, and sometimes if I was just in console and too lazy to open DSM. I never recall any improper shutdown notifications though.

Link to post
Share on other sites
  • 2 weeks later...

Hi everybody

I tried to follow the solution given by darkest_star on page 1. (I'm using a HP n54L running on DSM 4.3 update4). But I stopper on step 4, because I can't find the "acpi" folder in /etc. (altough the guide indicated to copy a file in /etc/acpi/PWRF/

Anyone know what's going on ? what can I do ?

 

Thank you

Link to post
Share on other sites
  • 2 weeks later...
I tested gnoBoot alpha 10.2 and DSM 4.3-3827, it can corretly handle acpi event and acpid v1.0/v2.0 both work fine.

 

Hi.

In files DSM_DS3612xs_3810.pat / 3827 / 4458 there is no module: button.ko.

Where it is possible to find it?

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 2 weeks later...
  • 3 weeks later...
Has someone tested button on page 1 in Nanoboot 5.0.2.4?

ACPI should be included in 5.0.2.3 but button.ko isn't in lib/modules.

 

Who got it run? Need help

 

Button mod from first page is not working on 5.0.2.4 but IT IS working on 5.0.3.1!

Link to post
Share on other sites
  • 1 month later...

Sorry, but for me it is not working in 5.0.3.1. I took the packages from the links suggested in the Howto guide: viewtopic.php?f=15&t=3666

 

Neither the load of button.ko was included in /etc/rc nor the other stuff has been in place (S30 start/stop, busybox-copy, ...) So when I try to enable everything that is needed, I get an "acpid: applet not found" in case I try to start the daemon. So I assume there is no acpid-enabled busybox in this distribution.

 

Probably I've made a mistake, so correct me if I'm wrong. THanks in advance.

Link to post
Share on other sites
Sorry, but for me it is not working in 5.0.3.1. I took the packages from the links suggested in the Howto guide: viewtopic.php?f=15&t=3666

 

Neither the load of button.ko was included in /etc/rc nor the other stuff has been in place (S30 start/stop, busybox-copy, ...) So when I try to enable everything that is needed, I get an "acpid: applet not found" in case I try to start the daemon. So I assume there is no acpid-enabled busybox in this distribution.

 

Probably I've made a mistake, so correct me if I'm wrong. THanks in advance.

 

 

Do not write what you have hardware - maybe you can have the BIOS turned off acpi ?

Link to post
Share on other sites
Do not write what you have hardware - maybe you can have the BIOS turned off acpi ?

 

Sorry, my fault:

- HP Gen7 N54L

- 16GB RAM

- 1*2TB (to be replaced by 4TB)+3*4TB Syno Array,

- ODD bay with "Sharkoon QuickPort intern multi" hotplug docking incl. 2*USB3 front panel ports

- NEC chipset based USB3 PCI Xe card with 19pin connector and 2 additional rear ports

 

ACPI is enabled in BIOS. But as I stated: For me it looks like nanoboot does not include the necessary acpi-enabled busybox, so the symlink to acpid does not lead to the expected result when starting the daemon.

Link to post
Share on other sites
Do not write what you have hardware - maybe you can have the BIOS turned off acpi ?

 

Sorry, my fault:

- HP Gen7 N54L

- 16GB RAM

- 1*2TB (to be replaced by 4TB)+3*4TB Syno Array,

- ODD bay with "Sharkoon QuickPort intern multi" hotplug docking incl. 2*USB3 front panel ports

- NEC chipset based USB3 PCI Xe card with 19pin connector and 2 additional rear ports

 

ACPI is enabled in BIOS. But as I stated: For me it looks like nanoboot does not include the necessary acpi-enabled busybox, so the symlink to acpid does not lead to the expected result when starting the daemon.

 

Nanoboot 5.0.3.1 have acpi enable for 100% because it's work on my system :smile:

I use power button for on or off my nas so acpi works fine with last nanoboot.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.